summaryrefslogtreecommitdiff
path: root/kde-frameworks/frameworkintegration
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest2
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.71.0.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index affbe69bacf9..158c7eb756a8 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,3 +1,5 @@
DIST frameworkintegration-5.70.0.tar.xz 1753940 BLAKE2B 5da86d4b7fe8a696e217273ff468c668ec1e04c138dd756a0a9280fbd6acb99f9cbd3bbce1790886de50335d036e7a99a83f1ea4ad4103101ecc46878d0e071b SHA512 70a72388315c0ca1625bb279b15a9df1693aed9a6dd470af8744b856e5c7cc458b0ffcc384489889e8c3e753edb03062b41cc688361498e45ac3a26d7be70a34
+DIST frameworkintegration-5.71.0.tar.xz 1754420 BLAKE2B 29e26fb31a5f2480428c2610d9f6a77d8ab37b5305ad82d7eb0cd1cc0b229257d00fc11632dfb45e61fae2723879fa24bbe8bcbb165cd211e59b404328ca8ab5 SHA512 a6a934acd284df0f2e5842eec851ae77890d40ea6e9d7a9e7205c10b746057f908d1e19ef405a783d15eb64656e98b074a0794bacdf89ab830f2c7f70bf91838
EBUILD frameworkintegration-5.70.0.ebuild 1052 BLAKE2B 6e5469f3599240695d2bbcbf6f52559658ed6332056da4e772464ea25cda7aa5c9ddda8665e38eac9318a84fe558ef86bdac565466ddddc0af95ab949dbd3846 SHA512 2fa31b0ca870cfa3ab3c808756230ec5236819397cc4e4498dcaefe1f09c962cb6dc8c477418a6b9a1035b639ccdd858dcc105fedb33ee406ac28fa2d8032988
+EBUILD frameworkintegration-5.71.0.ebuild 1055 BLAKE2B 8aaea9918be48001ce172f3b1745105e3dc913eba4eec2e05bdcdbc1ef59b7cf24888bda6beecf54ca2232fbb90e409d353dba824ba30315d662780682232d85 SHA512 c3452f8a9fdb0bf27205a0504234698a5e1809a19f0e769b944eb9fdac39b94f54eff7b199d8dc4b25b072f3f78e93bfaf1ba89a76865f44a7d850c485944970
MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.71.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.71.0.ebuild
new file mode 100644
index 000000000000..9f5ba007e2d5
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.71.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.14.1
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+# drop qtwidgets subslot operator when QT_MINIMAL >= 5.15.0
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5=
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+# requires running Plasma environment
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}