summaryrefslogtreecommitdiff
path: root/kde-apps/yakuake/yakuake-24.02.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/yakuake/yakuake-24.02.2.ebuild')
-rw-r--r--kde-apps/yakuake/yakuake-24.02.2.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/kde-apps/yakuake/yakuake-24.02.2.ebuild b/kde-apps/yakuake/yakuake-24.02.2.ebuild
new file mode 100644
index 000000000000..9447f8bb7e48
--- /dev/null
+++ b/kde-apps/yakuake/yakuake-24.02.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.0.0
+QTMIN=6.6.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Quake-style terminal emulator based on konsole"
+HOMEPAGE="https://apps.kde.org/yakuake/"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE="absolute-position"
+
+# slot op: Uses Qt6::GuiPrivate for qtx11extras_p.h
+# kde-frameworks/kwindowsystem[X]: Unconditional use of KX11Extras
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6=[dbus,gui,widgets]
+ >=dev-qt/qtsvg-${QTMIN}:6
+ >=kde-apps/konsole-${PVCUT}:6
+ >=kde-frameworks/karchive-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kcrash-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/kglobalaccel-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kiconthemes-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/knewstuff-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ >=kde-frameworks/knotifyconfig-${KFMIN}:6
+ >=kde-frameworks/kparts-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+ >=kde-frameworks/kstatusnotifieritem-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=kde-frameworks/kwindowsystem-${KFMIN}:6[X]
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+ x11-libs/libX11
+ absolute-position? ( kde-plasma/kwayland:6 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # TODO: start to use WITH_X11 option? but there's still the
+ # KX11Extras use...
+ local mycmakeargs=(
+ $(cmake_use_find_package absolute-position KWayland)
+ )
+
+ ecm_src_configure
+}