summaryrefslogtreecommitdiff
path: root/kde-apps/kontactinterface/kontactinterface-24.02.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/kontactinterface/kontactinterface-24.02.2.ebuild')
-rw-r--r--kde-apps/kontactinterface/kontactinterface-24.02.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/kde-apps/kontactinterface/kontactinterface-24.02.2.ebuild b/kde-apps/kontactinterface/kontactinterface-24.02.2.ebuild
new file mode 100644
index 000000000000..42e5fe0bf4ac
--- /dev/null
+++ b/kde-apps/kontactinterface/kontactinterface-24.02.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="true"
+KFMIN=6.0.0
+QTMIN=6.6.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Library for embedding KParts in a Kontact component"
+HOMEPAGE="https://api.kde.org/kdepim/kontactinterface/html/index.html"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+# slot op: Uses Qt::GuiPrivate for qtx11extras_p.h
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6=[dbus,gui,widgets,xml]
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kparts-${KFMIN}:6
+ >=kde-frameworks/kwindowsystem-${KFMIN}:6[X]
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+"
+RDEPEND="${DEPEND}"