summaryrefslogtreecommitdiff
path: root/kde-apps/kimap
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/kimap')
-rw-r--r--kde-apps/kimap/Manifest5
-rw-r--r--kde-apps/kimap/files/kimap-21.08.3-CVE-2021-38373.patch51
-rw-r--r--kde-apps/kimap/kimap-21.08.3-r1.ebuild (renamed from kde-apps/kimap/kimap-21.04.3.ebuild)6
-rw-r--r--kde-apps/kimap/kimap-21.08.3.ebuild40
4 files changed, 57 insertions, 45 deletions
diff --git a/kde-apps/kimap/Manifest b/kde-apps/kimap/Manifest
index 9ae4f3a87517..29e24ade7a03 100644
--- a/kde-apps/kimap/Manifest
+++ b/kde-apps/kimap/Manifest
@@ -1,5 +1,4 @@
-DIST kimap-21.04.3.tar.xz 128564 BLAKE2B 11b775fbb697989e27e1b3c2c41520b8be0745730f3d6a9ee2d5e3cc6f12734a3f527600dc376c26b00719981ef8c8fb37559432662cc5a192541a5fcbe486db SHA512 4b8cb4d2268c7e03dd8aaa1ecd6ce45f3c2a4ec2594585238102d0933d2540805f0ede1763f5e68ee156498870b402af3556e7b5509a406651dda674ad7aeebe
+AUX kimap-21.08.3-CVE-2021-38373.patch 1878 BLAKE2B 9eec46fab80e30fd42eb20f7fc130890d0a73548effa31656f3e1a4f83cffc8095affa30bfafe10ddad12f872c41e4bd6046f3754b957c8921402b59f3c74bd3 SHA512 c1150bf87a9f1abe75a3b6c56f3b2f6f8c6b88beed5f8158cea57a5cef1ffd16498c6ea761d22ee0a776d5c570dcc4184264770e9f8e16cc772860c20092a719
DIST kimap-21.08.3.tar.xz 127416 BLAKE2B 688ae70e9b4c280798b42cfed5cbd5dc6afd7ad48081294d0b66a2712fb420bc2b972527dfd5c128b826d97b6b9f75298229c357cb4668fc32720e731513a24d SHA512 65feaddd6ee0a965dda73036c4adf2e20e56a4abf4bf93f1ec5da03c53701991126ab2d65647c92048c56f1bcd45ea8b429ed99ddc08efdd54846a0d1222db83
-EBUILD kimap-21.04.3.ebuild 850 BLAKE2B d21a6f839d928aff0dbf04b8b0228f67a6aaca03a68a7ef57548b52679ddedad5bac0fa65dac9d9748e6f17f35e71252a240cac8ea7b32e0d5711d6f69a8ecee SHA512 03bc27c0509a42a6bd89286006c5f1e1a2c27ecbb237b752c4db6941febe8b209a52afff3bf3a99d2812e9152d4655bd6755912cd2b5bc966089974209976d33
-EBUILD kimap-21.08.3.ebuild 853 BLAKE2B a96661475af4845d09438d0d94a85bf697580bbc0d38857f1636c45bc24ca786a280befa326e11254fd8bf1f0052cca04460f2628b96c3f9938e9a4f7c4bfdde SHA512 d66638c8b805b02b97f6d2fe8a51c8cd358e8fd10d3d26f0ab30d561e8e6897f27875f8cfeea5370fa5d24518adf62b7e908dcb79ff51c746808fde328ea4ee8
+EBUILD kimap-21.08.3-r1.ebuild 903 BLAKE2B d95e50888cc0bbc37b96a290aca69aef96b3f3d9f533e89306bb5f7f46cdec52d2e91f21c4b1aee43929d6c20b6a8a2f322e172692e0a6cbcba5fa345ec1bb3a SHA512 c4c20a09ec7d885c4251c42a62197a5d901b4ccd4cff510733bc2090856927189350abb83c33caed884b08203db459da0c1a43643c2fd8ff2db172e7f39188f2
MISC metadata.xml 318 BLAKE2B 922a5e32e706b2976c5f359a14194d268d3f499398576c80ce5fad8c0fcea0fbf048de4480a80a6a1889c88b8b6c14147654a3ab4d5ffbcc258c2290da63f6d1 SHA512 614cb8dda7ad2088e5d6ef39b449bb4be0ac72cd0231c320188d76d1816dce6490c5114bb4798112c4b11d99d30a9e82ff8fcf08ffa8c049589682a5e38208f6
diff --git a/kde-apps/kimap/files/kimap-21.08.3-CVE-2021-38373.patch b/kde-apps/kimap/files/kimap-21.08.3-CVE-2021-38373.patch
new file mode 100644
index 000000000000..90d216b0b846
--- /dev/null
+++ b/kde-apps/kimap/files/kimap-21.08.3-CVE-2021-38373.patch
@@ -0,0 +1,51 @@
+From 5aed4138567934c3be20cddb60fe6d7d4a10da0f Mon Sep 17 00:00:00 2001
+From: Volker Krause <vkrause@kde.org>
+Date: Mon, 15 Nov 2021 18:18:28 +0100
+Subject: [PATCH] Treat SSL handshake errors as fatal also when using STARTTLS
+
+This fixes the infinite SSL error dialog loop also when using
+STARTTLS, the previous fix was only effective for direct TLS
+connections.
+
+CCBUG: 423424
+(cherry picked from commit cbd3a03bc1d2cec48bb97570633940bbf94c34fa)
+---
+ src/loginjob.cpp | 22 +++++++++-------------
+ 1 file changed, 9 insertions(+), 13 deletions(-)
+
+diff --git a/src/loginjob.cpp b/src/loginjob.cpp
+index 7d53187..b5fbede 100644
+--- a/src/loginjob.cpp
++++ b/src/loginjob.cpp
+@@ -552,19 +552,15 @@ void LoginJob::connectionLost()
+ {
+ Q_D(LoginJob);
+
+- // don't emit the result if the connection was lost before getting the tls result, as it can mean
+- // the TLS handshake failed and the socket was reconnected in normal mode
+- if (d->authState != LoginJobPrivate::StartTls) {
+- qCWarning(KIMAP_LOG) << "Connection to server lost " << d->m_socketError;
+- if (d->m_socketError == QAbstractSocket::SslHandshakeFailedError) {
+- setError(KJob::UserDefinedError);
+- setErrorText(i18n("SSL handshake failed."));
+- emitResult();
+- } else {
+- setError(ERR_COULD_NOT_CONNECT);
+- setErrorText(i18n("Connection to server lost."));
+- emitResult();
+- }
++ qCWarning(KIMAP_LOG) << "Connection to server lost " << d->m_socketError;
++ if (d->m_socketError == QAbstractSocket::SslHandshakeFailedError) {
++ setError(KJob::UserDefinedError);
++ setErrorText(i18n("SSL handshake failed."));
++ emitResult();
++ } else {
++ setError(ERR_COULD_NOT_CONNECT);
++ setErrorText(i18n("Connection to server lost."));
++ emitResult();
+ }
+ }
+
+--
+2.34.0
+
diff --git a/kde-apps/kimap/kimap-21.04.3.ebuild b/kde-apps/kimap/kimap-21.08.3-r1.ebuild
index 7ecf4e28e606..8d37f8edc147 100644
--- a/kde-apps/kimap/kimap-21.04.3.ebuild
+++ b/kde-apps/kimap/kimap-21.08.3-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
ECM_TEST="forceoptional"
PVCUT=$(ver_cut 1-3)
-KFMIN=5.80.0
+KFMIN=5.84.0
QTMIN=5.15.2
inherit ecm kde.org
@@ -31,6 +31,8 @@ DEPEND="${RDEPEND}
test? ( >=dev-qt/qtnetwork-${QTMIN}:5 )
"
+PATCHES=( "${FILESDIR}/${P}-CVE-2021-38373.patch" )
+
src_test() {
# tests cannot be run in parallel #605586
local myctestargs=(
diff --git a/kde-apps/kimap/kimap-21.08.3.ebuild b/kde-apps/kimap/kimap-21.08.3.ebuild
deleted file mode 100644
index 195787a96ec5..000000000000
--- a/kde-apps/kimap/kimap-21.08.3.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ECM_TEST="forceoptional"
-PVCUT=$(ver_cut 1-3)
-KFMIN=5.84.0
-QTMIN=5.15.2
-inherit ecm kde.org
-
-DESCRIPTION="Library for interacting with IMAP servers"
-HOMEPAGE="https://api.kde.org/kdepim/kimap/html/index.html"
-
-LICENSE="GPL-2+"
-SLOT="5"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-IUSE=""
-
-RDEPEND="
- dev-libs/cyrus-sasl
- >=dev-qt/qtgui-${QTMIN}:5
- >=kde-apps/kmime-${PVCUT}:5
- >=kde-frameworks/kcodecs-${KFMIN}:5
- >=kde-frameworks/kcoreaddons-${KFMIN}:5
- >=kde-frameworks/ki18n-${KFMIN}:5
- >=kde-frameworks/kio-${KFMIN}:5
-"
-# TODO: Convince upstream not to install stuff with tests
-DEPEND="${RDEPEND}
- test? ( >=dev-qt/qtnetwork-${QTMIN}:5 )
-"
-
-src_test() {
- # tests cannot be run in parallel #605586
- local myctestargs=(
- -j1
- )
- ecm_src_test
-}