summaryrefslogtreecommitdiff
path: root/kde-apps/grantlee-editor/grantlee-editor-24.02.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/grantlee-editor/grantlee-editor-24.02.2.ebuild')
-rw-r--r--kde-apps/grantlee-editor/grantlee-editor-24.02.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/kde-apps/grantlee-editor/grantlee-editor-24.02.2.ebuild b/kde-apps/grantlee-editor/grantlee-editor-24.02.2.ebuild
new file mode 100644
index 000000000000..1aedcbe5b633
--- /dev/null
+++ b/kde-apps/grantlee-editor/grantlee-editor-24.02.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.0.0
+QTMIN=6.6.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Utilities and tools to manage themes in KDE PIM applications"
+
+LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-libs/ktextaddons-1.4.42:6
+ >=dev-qt/qtbase-${QTMIN}:6[gui,widgets]
+ >=dev-qt/qtwebengine-${QTMIN}:6[widgets]
+ >=kde-apps/akonadi-contacts-${PVCUT}:6
+ >=kde-apps/kmime-${PVCUT}:6
+ >=kde-apps/messagelib-${PVCUT}:6
+ >=kde-apps/pimcommon-${PVCUT}:6
+ >=kde-frameworks/karchive-${KFMIN}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:6
+ >=kde-frameworks/kcontacts-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kcrash-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+"
+RDEPEND="${DEPEND}"