summaryrefslogtreecommitdiff
path: root/gui-wm/hyprland/files/hyprland-0.30.0-no-wlroots-automagic-r1.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gui-wm/hyprland/files/hyprland-0.30.0-no-wlroots-automagic-r1.patch')
-rw-r--r--gui-wm/hyprland/files/hyprland-0.30.0-no-wlroots-automagic-r1.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/gui-wm/hyprland/files/hyprland-0.30.0-no-wlroots-automagic-r1.patch b/gui-wm/hyprland/files/hyprland-0.30.0-no-wlroots-automagic-r1.patch
new file mode 100644
index 000000000000..452c1cc80f5e
--- /dev/null
+++ b/gui-wm/hyprland/files/hyprland-0.30.0-no-wlroots-automagic-r1.patch
@@ -0,0 +1,18 @@
+diff --git a/meson.build b/meson.build
+index d515621e..08993f8a 100644
+--- a/meson.build
++++ b/meson.build
+@@ -39,7 +39,12 @@ add_project_arguments(
+ ],
+ language: 'cpp')
+
+-wlroots = subproject('wlroots', default_options: ['examples=false', 'renderers=gles2'])
++if get_option('xwayland').enabled()
++ wlroots = subproject('wlroots', default_options: ['backends=drm,libinput,x11','examples=false','renderers=gles2','xcb-errors=disabled','xwayland=enabled'])
++else
++ wlroots = subproject('wlroots', default_options: ['backends=drm,libinput','examples=false','renderers=gles2','xcb-errors=disabled','xwayland=disabled'])
++endif
++
+ have_xwlr = wlroots.get_variable('features').get('xwayland')
+ xcb_dep = dependency('xcb', required: get_option('xwayland'))
+