summaryrefslogtreecommitdiff
path: root/gui-libs
diff options
context:
space:
mode:
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/Manifest.gzbin4288 -> 4286 bytes
-rw-r--r--gui-libs/wayfire-plugins-extra/Manifest4
-rw-r--r--gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.7.5.ebuild36
-rw-r--r--gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild7
-rw-r--r--gui-libs/wlroots/Manifest2
-rw-r--r--gui-libs/wlroots/wlroots-0.16.2.ebuild82
6 files changed, 128 insertions, 3 deletions
diff --git a/gui-libs/Manifest.gz b/gui-libs/Manifest.gz
index b10222ab9a76..45d94df8c87c 100644
--- a/gui-libs/Manifest.gz
+++ b/gui-libs/Manifest.gz
Binary files differ
diff --git a/gui-libs/wayfire-plugins-extra/Manifest b/gui-libs/wayfire-plugins-extra/Manifest
index 65c39846acac..7d144be835a4 100644
--- a/gui-libs/wayfire-plugins-extra/Manifest
+++ b/gui-libs/wayfire-plugins-extra/Manifest
@@ -1,4 +1,6 @@
DIST wayfire-plugins-extra-0.7.0.tar.xz 74312 BLAKE2B f72d706502499e4d467a4b59e10f66628024be1bab1c5e10c807758869c9b9e4aacbe426c2db0e3faa5ab166f7e4f4d0f1c345e205c6747a16a164745c6f0d74 SHA512 ff25a4685c88ca0129a2372b216166246cab072c2cb4f84eb7bd500db525bf5881bd7e54d0d888473d4aab0e5b33d2ee13eb7f788bb2a524e1e8e0c5efc1a6bd
+DIST wayfire-plugins-extra-0.7.5.tar.xz 75136 BLAKE2B 7ffbb73f09175cc92f09b8a3f0493942741564278f95ff1d80066044b02ce4ceb925919ddb54fc6a37676b925d95ea7f93d09c6b0ccd448c6e9b821106d6e3ea SHA512 9cc816c3c727b0093fd15ef52dea215598b4c49ef96c098f53938c041b3908b30f4dd616be4b459b7382d630a47b36baf845c24de84f35670ba2912711205911
EBUILD wayfire-plugins-extra-0.7.0-r1.ebuild 715 BLAKE2B 770f6c408639be29ec16702a98f36bf02e4aaf66ab87e153388d4e458d6119dfd35f7c587f1ca3844df4fb01a561d1c8b7adb34154d6d7121e9b22797fb006de SHA512 b5dee6dbdc71b904b27bf94929886008b0c94deec5e8cac02bc39ed2e4642a100eded21a6819d88017219088a4ef477f9f2856a554f64cd907815f5a83dd5295
-EBUILD wayfire-plugins-extra-9999.ebuild 684 BLAKE2B 6bedcb051d70e8992c3ed0bd9e686b24628321c9bb34bc72c473c19f6d53a6b54c887747bad3b3b5e7f88eefc3d0fafc7a08db4a06cf88ae8b9727735b6626b8 SHA512 97e32218968d27d00ee9525dc3ceddc1d70f94f7bdd361d1b95ec836d7e391cb68536385f8df7259572c9dcc4e574c4a72643f64fbcfb4336578336c33b05619
+EBUILD wayfire-plugins-extra-0.7.5.ebuild 773 BLAKE2B dceb44cffc2fc78abbdb8bfdf348f5219b9fe52d57ab2f202ae7b6513dab7bf35bb9ed84a2595a2e384be2312d0d8ce9fbfe04e95f6c9a49ee97d306986e95f5 SHA512 ca35dac368bdfebb4d87924d9c90cf2899597f7e6e14870c6441115ef603505db8280285d3ee8c8ea3273d01fbc18a5c1ace60fe31627f6e7b2407d56056b920
+EBUILD wayfire-plugins-extra-9999.ebuild 738 BLAKE2B 6686c04e8b8b03f318d73be5143c9bbf9e5a324e10e18c9cc74d211696e294241c416abafded760cdb9e34974c63f57d2534d3c549b70e0ca062750881f26ca4 SHA512 94ef764336abfaa7baee7632fcd06690af2c356a8740a3e81392dd52d0859a493c384c82649f91081854604f37fed7375222f21ed63d8c7c6d1dde0d9df78962
MISC metadata.xml 175 BLAKE2B 4ab58afd88032bf1566270b8294b9e73a1f428b9d5eba0ce122d5b9ce7b23df157f4581232e54659a6e12699af37ca24a639d20f009ca64506692930cfec6160 SHA512 ec5bffe4b7e2473390477784440903946ad4012afbe5a7d651c454b665c95e68d142eaccb464d7181b1c27c22347dc831da35c54019421dbd2ca1ad17744e18d
diff --git a/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.7.5.ebuild b/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.7.5.ebuild
new file mode 100644
index 000000000000..b9222da14f98
--- /dev/null
+++ b/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.7.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="extra plugins for wayfire"
+HOMEPAGE="https://github.com/WayfireWM/wayfire-plugins-extra"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/wayfire-plugins-extra.git"
+else
+ SRC_URI="https://github.com/WayfireWM/wayfire-plugins-extra/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="
+ dev-cpp/glibmm:2
+ x11-libs/pixman
+ gnome-base/librsvg
+ >=gui-libs/wlroots-0.16.0:0/16
+ <gui-libs/wlroots-0.17.0:=
+ >=gui-wm/wayfire-0.7.5
+ x11-libs/cairo
+ x11-libs/pixman
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
diff --git a/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild b/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild
index 2558b0e79566..e1eb8908ec68 100644
--- a/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild
+++ b/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit meson
@@ -21,9 +21,12 @@ SLOT="0"
DEPEND="
dev-cpp/glibmm:2
+ x11-libs/pixman
+ gnome-base/librsvg
~gui-libs/wlroots-9999:=
~gui-wm/wayfire-9999
x11-libs/cairo
+ x11-libs/pixman
"
RDEPEND="${DEPEND}"
diff --git a/gui-libs/wlroots/Manifest b/gui-libs/wlroots/Manifest
index b6c1fa885738..44ce60c5d121 100644
--- a/gui-libs/wlroots/Manifest
+++ b/gui-libs/wlroots/Manifest
@@ -4,11 +4,13 @@ DIST wlroots-0.14.1.tar.gz 505840 BLAKE2B fca4d259cdde62da0c196344ce1d0f5dd679d0
DIST wlroots-0.15.1.tar.gz 565816 BLAKE2B 09b704a55d8b4a5ab19bb0fcdd041635fbbbb8eed94ff6d189ef47f9f86e90178efa8441c7db78839b1145ed79ed016d520d6599e256cdcf49130cda38bc307d SHA512 6228160f2f350a406c612f1048d7075cf2f78206cc84bc16f889d5d0acd614f9e98845fffed03d7067cfdbd7558b77fcc5d8cedc3868d866e476523126a63677
DIST wlroots-0.16.0.tar.gz 588565 BLAKE2B d1233f85bc4d80bfc65efb04367e136a351efc5e47168e30f061a8b4eecdd4bdbde6355e35211c610285b4d031c754f90c94b49e63c5b2f665890765b139bf76 SHA512 0b56f31284cc250019cda1e80d1660031d397e880a8c1aac2e60d7758bcac26e50144a499c13c61e24fe2664ba1e6cbb8262bfe28c817f4664162b1de592f1b6
DIST wlroots-0.16.1.tar.gz 588945 BLAKE2B bd7dae29ef730c32ade389bbc1f99610afc0c35fc05a5c80e9257d6eb2ca99c38ecb6277206015432033c59c11fab4743f49413a6a19cf1d35cdbe62cdb57925 SHA512 a590960d3a228f1fec007d20094e48d9276568f59e2ce3bac56889fb7df519d68ffb81a73130b7bbf350ec95056009aaabb18ada52a97486d6ad1d5deb6844c3
+DIST wlroots-0.16.2.tar.gz 589804 BLAKE2B 49911556f1442b43b46e3ec7750706cabeeab915bc36b178b92dec7b66743f4c2f0e335c6e26e318a25ceda41170b20913987a94a3c516df580d379305df7cc2 SHA512 3c1d4fecb3b751987e7051e69849fd62bd4eed95f2d2e548f06e42e4829d0fc24f20c1bfe056a53ede2d1fd05e0c566269a7b9f2bab0de0057a32b55e826a7c0
EBUILD wlroots-0.14.0-r2.ebuild 1481 BLAKE2B f350d6bbaf05a349cb9ee5ac67cea0c29b1e737b7fdb819ab4fee051311e48c5a448e3d2f2690f9c6effcedde2fc940779fa409ba7ba03acf099b5e4961f7e19 SHA512 4f50dfcfa7fd7cc1e5c5653f9b79da8fdda49994f2a385c145a272bf1d9227d6c5b5a13bd7f4c381036343c9b7f65c6b322b2a3bc188ea39ab427c7d1a424c81
EBUILD wlroots-0.14.1-r1.ebuild 1484 BLAKE2B 9de2dec4bbb573b4288a9c994047de1547ed6c7be66af4e8f7b5c3d459a4e2cccc97f3883bbb633942ade7f81ba2a883a14a40ac25f8033a57b24a6556d579b1 SHA512 c59c653561420f563e34584f48c646ea38a0622f65ed054d8895508f66fe4ef10e6b77d07b7bcb555fdf5c2077b7bd8f43df495a742b31075739630a666d4859
EBUILD wlroots-0.15.1-r1.ebuild 1903 BLAKE2B db14251e37bb2448556a7a8f98fadfea64c4c6047b3c8736932ca08ea586a8cc0db0c8d54335f0dad5d36a52c7a10f87f6d60425c35d5bf361334ab0e3ad0f5a SHA512 6bd49fad40df4267c4490e928fe750677fadf9dd1f08856fab8777000af8a3769f0710be0741ce98cfbbe2cb4cb1cfc6020937078211abf5aa5a224b702b4135
EBUILD wlroots-0.15.1.ebuild 1694 BLAKE2B 6612ccfa47cb13280a788b766b8c986c37f8ed256808e54068709e84e629e7618ecda9624faea2ac63878f232996c47a8f36a4ae760d7747cd7c918ed0667d90 SHA512 fbb4123948bc0d9f69bfd8d9c3990aa21e648b5e1a7018aa6c4bcc6bf6aa0982bf8ff5aea6df9ea460f29ba48646687747457ec3d146808a3f0ac2b8b667f374
EBUILD wlroots-0.16.0.ebuild 1893 BLAKE2B 8e5d718648c21c9a70790b415e35c53617e79049c95bf71116860b81e4e0d755327fbfcee9bf9ed056f214b21b4389abcd8f61377fea777a8ef7701be3f0b74e SHA512 5c1c731c375f704e24fecd1363e62330e945ce7903257d4759c852aa76415e24d0a2bf1f7a4daf29edc37a1b6c5da9f852020414b03d26f5956a4228de23e616
EBUILD wlroots-0.16.1.ebuild 1890 BLAKE2B 33db6d694d1e847f74071e941494305471d788f714c08aaa9c61cd2028de0b878401c61c65e950387b7e7b90f9a8e966e107d137e344b62a2a235130a655b9f0 SHA512 95a360381f5cc33677e466c063af8c276a0745c4d66c4242b13baffb2ce1931845624427394d6e112824571c5b36ad77294a9d86ca7b4199030236cee422306c
+EBUILD wlroots-0.16.2.ebuild 1893 BLAKE2B e033370c3a1d9c72f78b751be111a24a3a292519d76f8c1cd238cbec95938bdcf372d8c6b442f542c756adcc5c7117f976cfb624849a6f5acb9932da4a0bfa0a SHA512 d91ff110f9f98ffaae54c61bae849505e5c4606c68096431cd9cc8f5ff0a604561a09351278492ee4f76d569c451315ffdc406b6170f2911e549e7a2cef8b111
EBUILD wlroots-9999.ebuild 1893 BLAKE2B 8e5d718648c21c9a70790b415e35c53617e79049c95bf71116860b81e4e0d755327fbfcee9bf9ed056f214b21b4389abcd8f61377fea777a8ef7701be3f0b74e SHA512 5c1c731c375f704e24fecd1363e62330e945ce7903257d4759c852aa76415e24d0a2bf1f7a4daf29edc37a1b6c5da9f852020414b03d26f5956a4228de23e616
MISC metadata.xml 1718 BLAKE2B 5cc70d12e054c4765c2d1c96349f938eee8f2ad96fa2c09c5bd3abbe1320845b2aa046a3160a1d45cb7d545a9c1900f5a80ca510250f49cd8112ab789ff65cbf SHA512 7a30d581216cd1a1719874019eec3fd932d6230cd96f419504d70c66f004b2743ec5c795e43c7ed65df5277d0ee42e0b1cc762d6332b9ecbd464c1e3433fe667
diff --git a/gui-libs/wlroots/wlroots-0.16.2.ebuild b/gui-libs/wlroots/wlroots-0.16.2.ebuild
new file mode 100644
index 000000000000..70208ce481f5
--- /dev/null
+++ b/gui-libs/wlroots/wlroots-0.16.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Pluggable, composable, unopinionated modules for building a Wayland compositor"
+HOMEPAGE="https://gitlab.freedesktop.org/wlroots/wlroots"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/${PN}/${PN}.git"
+ inherit git-r3
+ SLOT="0/9999"
+else
+ SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+ SLOT="0/$(ver_cut 2)"
+fi
+
+LICENSE="MIT"
+IUSE="+hwdata +seatd tinywl +udev vulkan x11-backend X"
+
+DEPEND="
+ >=dev-libs/libinput-1.14.0:0=
+ >=dev-libs/wayland-1.21.0
+ >=dev-libs/wayland-protocols-1.28
+ media-libs/mesa[egl(+),gles2]
+ hwdata? ( sys-apps/hwdata:= )
+ seatd? ( sys-auth/seatd:= )
+ udev? ( virtual/libudev )
+ vulkan? (
+ dev-util/glslang:0=
+ dev-util/vulkan-headers:0=
+ media-libs/vulkan-loader:0=
+ )
+ >=x11-libs/libdrm-2.4.114:0=
+ x11-libs/libxkbcommon
+ >=x11-libs/pixman-0.42.0:0=
+ x11-backend? ( x11-libs/libxcb:0= )
+ X? (
+ x11-base/xwayland
+ x11-libs/libxcb:0=
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-wm
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.24
+ >=dev-util/meson-0.60.0
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # xcb-util-errors is not on Gentoo Repository (and upstream seems inactive?)
+ local emesonargs=(
+ "-Dxcb-errors=disabled"
+ $(meson_use tinywl examples)
+ -Drenderers=$(usex vulkan 'gles2,vulkan' gles2)
+ -Dxwayland=$(usex X enabled disabled)
+ -Dbackends=drm,libinput$(usex x11-backend ',x11' '')
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use tinywl; then
+ dobin "${BUILD_DIR}"/tinywl/tinywl
+ fi
+}
+
+pkg_postinst() {
+ elog "You must be in the input group to allow your compositor"
+ elog "to access input devices via libinput."
+}