summaryrefslogtreecommitdiff
path: root/gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-1.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-1.0.2.ebuild')
-rw-r--r--gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-1.0.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-1.0.2.ebuild b/gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-1.0.2.ebuild
new file mode 100644
index 000000000000..75140bfaf553
--- /dev/null
+++ b/gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-1.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal using Qt/KF5/libfm-qt"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~riscv"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-2.0.0"
+DEPEND="
+ >=dev-qt/qtbase-6.6:6[dbus,gui,widgets]
+ kde-frameworks/kwindowsystem:6
+ >=x11-libs/libfm-qt-2.0:=
+"
+RDEPEND="${DEPEND}
+ sys-apps/xdg-desktop-portal
+"