summaryrefslogtreecommitdiff
path: root/gui-libs/wpebackend-fdo/wpebackend-fdo-1.14.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gui-libs/wpebackend-fdo/wpebackend-fdo-1.14.2-r1.ebuild')
-rw-r--r--gui-libs/wpebackend-fdo/wpebackend-fdo-1.14.2-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/gui-libs/wpebackend-fdo/wpebackend-fdo-1.14.2-r1.ebuild b/gui-libs/wpebackend-fdo/wpebackend-fdo-1.14.2-r1.ebuild
new file mode 100644
index 000000000000..f2b174fcd992
--- /dev/null
+++ b/gui-libs/wpebackend-fdo/wpebackend-fdo-1.14.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="WPE backend designed for Linux desktop systems"
+HOMEPAGE="https://wpewebkit.org/"
+SRC_URI="https://wpewebkit.org/releases/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="1.0"
+
+KEYWORDS="amd64 arm arm64 ~ia64 ~loong ppc ppc64 ~riscv ~sparc x86"
+
+RDEPEND="
+ media-libs/libepoxy[egl(+)]
+ dev-libs/glib:2
+ >=dev-libs/wayland-1.10
+ >=gui-libs/libwpe-1.6:1.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dbuild_docs=false # hotdoc not packaged
+ )
+
+ meson_src_configure
+}