summaryrefslogtreecommitdiff
path: root/gui-libs/wf-config
diff options
context:
space:
mode:
Diffstat (limited to 'gui-libs/wf-config')
-rw-r--r--gui-libs/wf-config/Manifest4
-rw-r--r--gui-libs/wf-config/wf-config-0.8.0.ebuild44
-rw-r--r--gui-libs/wf-config/wf-config-9999.ebuild6
3 files changed, 51 insertions, 3 deletions
diff --git a/gui-libs/wf-config/Manifest b/gui-libs/wf-config/Manifest
index 038c8fc70350..92a34d88249c 100644
--- a/gui-libs/wf-config/Manifest
+++ b/gui-libs/wf-config/Manifest
@@ -1,4 +1,6 @@
DIST wf-config-0.7.1.tar.xz 39120 BLAKE2B b18048334df12b002391fe4a74529cb61df76a0678c9052f8ac91d777e8a48dae46b87680fb44630ebfb9a350dbac36b15bc81850341fa4cd6299c12f6fa057d SHA512 d535a09a3465a54a607df7b8764ee6818ab8b83536d68c85167b282b95a176636e4bf5cda6c0d1638c07721a1f4208203e9d41b83675038fb590a535314df719
+DIST wf-config-0.8.0.tar.xz 41200 BLAKE2B d56cd04c18c2cd8c0bac86493ad662244bde0e9cce1caf81d0fff34d9f2df2470c1aa8c95fead9e91dd5793d570b01dc6ef99b1986b8658b06ef93156a1526f8 SHA512 79cca2429a39ee81f853043698c57fc08025634926773253cff73fc564dcf203335b4b861d82b60a769bbab7b07be6a7e181c9ea29ad98ce930de20f9723893f
EBUILD wf-config-0.7.1-r1.ebuild 809 BLAKE2B 9f67605ea19118594c5a1d4a7e908787b9731234efa01ed4dcf5957d4a8c7e2f2dab90983e3b45a9a760ac2a0bbc7873ef09cc04c1247e326f0cf5a19e51de46 SHA512 0c48c0fc68edb3aab37eec47058db82434b3ce970b473927067aa94d274360faa5a871857466d4df54aaec138a7e13d371c54ef59af2e598498e8a15dccb317f
-EBUILD wf-config-9999.ebuild 810 BLAKE2B 68f71681519ec39e272cf5a35fc48855314fd77b0c98784f662ff266f9ca26bbcd415e8a7bc17793214ca72f7af6e1e581cba164ca8643f52f371186d3cd7c45 SHA512 e998fa99485845ee9f57a3fa57576f6f1908ea51f1232d88ce29f1e972656aacd6862ae5b7e2431fabfb5f430b3af064fda870db77e3caae1538ce25c8a703ec
+EBUILD wf-config-0.8.0.ebuild 903 BLAKE2B 14d1bfd040fcd566c009f24321aa5a2d143a795852ce7812c087b94d6c7c970a8755b89fb489f73d42b46728d497172d3b7ea421391a59b46311bf265387e8e7 SHA512 82be0c1a9e66fa71a5bb37396dfa4a2da0e515a657993f48c57360f2cee7c3261b7db4e0d5bbe995e35f9e2c84ccc155a1752872aaad5e716d389f8f0ff00d80
+EBUILD wf-config-9999.ebuild 903 BLAKE2B 14d1bfd040fcd566c009f24321aa5a2d143a795852ce7812c087b94d6c7c970a8755b89fb489f73d42b46728d497172d3b7ea421391a59b46311bf265387e8e7 SHA512 82be0c1a9e66fa71a5bb37396dfa4a2da0e515a657993f48c57360f2cee7c3261b7db4e0d5bbe995e35f9e2c84ccc155a1752872aaad5e716d389f8f0ff00d80
MISC metadata.xml 507 BLAKE2B 503103e40f0527b6593821f4170bf58d7077d6d32096cb71d125ed88ac768c341b089a6d7c173797aa4604e6450f9c9716fb4122d8d499b67f1067f75d3c60a0 SHA512 122c9699e3a22be6d91680ac303d09b9614313345f11a9a3a344c4064fecede8107f3b891c9e04bb19479aeed846beb18355803dc41b2052a81fb6c016c25f5f
diff --git a/gui-libs/wf-config/wf-config-0.8.0.ebuild b/gui-libs/wf-config/wf-config-0.8.0.ebuild
new file mode 100644
index 000000000000..4e970b7ae0aa
--- /dev/null
+++ b/gui-libs/wf-config/wf-config-0.8.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="library for managing wayfire configuration files"
+HOMEPAGE="https://github.com/WayfireWM/wf-config"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/wf-config.git"
+ SLOT="0/9999"
+else
+ SRC_URI="https://github.com/WayfireWM/wf-config/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+ SLOT="0/$(ver_cut 1-2)"
+fi
+
+LICENSE="MIT"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/libevdev
+ dev-libs/libxml2
+ media-libs/glm
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+ test? ( dev-cpp/doctest )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature test tests)
+ -Dlocale_test=false # requires de_DE locale to be installed
+ )
+
+ meson_src_configure
+}
diff --git a/gui-libs/wf-config/wf-config-9999.ebuild b/gui-libs/wf-config/wf-config-9999.ebuild
index ae9b12db688b..4e970b7ae0aa 100644
--- a/gui-libs/wf-config/wf-config-9999.ebuild
+++ b/gui-libs/wf-config/wf-config-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 2019-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit meson
@@ -11,13 +11,14 @@ HOMEPAGE="https://github.com/WayfireWM/wf-config"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/WayfireWM/wf-config.git"
+ SLOT="0/9999"
else
SRC_URI="https://github.com/WayfireWM/wf-config/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+ SLOT="0/$(ver_cut 1-2)"
fi
LICENSE="MIT"
-SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
@@ -36,6 +37,7 @@ BDEPEND="
src_configure() {
local emesonargs=(
$(meson_feature test tests)
+ -Dlocale_test=false # requires de_DE locale to be installed
)
meson_src_configure