summaryrefslogtreecommitdiff
path: root/gui-libs/hyprutils/hyprutils-0.1.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gui-libs/hyprutils/hyprutils-0.1.4.ebuild')
-rw-r--r--gui-libs/hyprutils/hyprutils-0.1.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/gui-libs/hyprutils/hyprutils-0.1.4.ebuild b/gui-libs/hyprutils/hyprutils-0.1.4.ebuild
new file mode 100644
index 000000000000..d7a92f59830e
--- /dev/null
+++ b/gui-libs/hyprutils/hyprutils-0.1.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Hyprland utilities library used across the ecosystem"
+HOMEPAGE="https://github.com/hyprwm/hyprutils"
+
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN^}.git"
+else
+ SRC_URI="https://github.com/hyprwm/${PN^}/archive/refs/tags/v${PV}/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${PN}-${PV}"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+# Disable tests since as per upstream, tests require a theme to be installed
+# See also https://github.com/hyprwm/hyprcursor/commit/94361fd8a75178b92c4bb24dcd8c7fac8423acf3
+RESTRICT="test"