summaryrefslogtreecommitdiff
path: root/gui-apps/wl-clipboard/wl-clipboard-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/wl-clipboard/wl-clipboard-9999.ebuild')
-rw-r--r--gui-apps/wl-clipboard/wl-clipboard-9999.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/gui-apps/wl-clipboard/wl-clipboard-9999.ebuild b/gui-apps/wl-clipboard/wl-clipboard-9999.ebuild
index 7e7fdd6a0b37..5f2e91e8c06d 100644
--- a/gui-apps/wl-clipboard/wl-clipboard-9999.ebuild
+++ b/gui-apps/wl-clipboard/wl-clipboard-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 2019-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit meson
@@ -18,10 +18,17 @@ fi
LICENSE="GPL-3"
SLOT="0"
-IUSE=""
DEPEND="dev-libs/wayland"
RDEPEND="${DEPEND}"
BDEPEND="
+ dev-libs/wayland-protocols
dev-util/wayland-scanner
- dev-libs/wayland-protocols"
+"
+
+src_configure() {
+ local -a emesonargs=(
+ -Dfishcompletiondir="${EPREFIX}/usr/share/fish/vendor_completions.d"
+ )
+ meson_src_configure
+}