summaryrefslogtreecommitdiff
path: root/gui-apps/kanshi/kanshi-1.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/kanshi/kanshi-1.6.0.ebuild')
-rw-r--r--gui-apps/kanshi/kanshi-1.6.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/gui-apps/kanshi/kanshi-1.6.0.ebuild b/gui-apps/kanshi/kanshi-1.6.0.ebuild
new file mode 100644
index 000000000000..14e7f07ebbf4
--- /dev/null
+++ b/gui-apps/kanshi/kanshi-1.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="dynamic display configuration (autorandr for wayland)"
+HOMEPAGE="https://wayland.emersion.fr/kanshi/ https://sr.ht/~emersion/kanshi/"
+SRC_URI="
+ https://git.sr.ht/~emersion/kanshi/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+S=${WORKDIR}/${PN}-v${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+man varlink"
+
+RDEPEND="
+ dev-libs/libscfg
+ dev-libs/wayland
+ varlink? ( dev-libs/libvarlink )
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ man? ( >=app-text/scdoc-1.9.3 )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ $(meson_feature varlink ipc)
+ )
+ meson_src_configure
+}