summaryrefslogtreecommitdiff
path: root/gui-apps/gnome-console
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/gnome-console')
-rw-r--r--gui-apps/gnome-console/Manifest3
-rw-r--r--gui-apps/gnome-console/gnome-console-43.0.ebuild47
-rw-r--r--gui-apps/gnome-console/metadata.xml8
3 files changed, 58 insertions, 0 deletions
diff --git a/gui-apps/gnome-console/Manifest b/gui-apps/gnome-console/Manifest
new file mode 100644
index 000000000000..95f623309d82
--- /dev/null
+++ b/gui-apps/gnome-console/Manifest
@@ -0,0 +1,3 @@
+DIST gnome-console-43.0.tar.xz 161916 BLAKE2B 9790026541e61d0ae303831363fec15efce242c35bde2e628eec7b9c405095de9301dec344feaf83e035a5343ee8cb71dbece951def6d145555de40c73d9acc4 SHA512 b4da0f0c1e35bb468f5db8080b762c652358bd96d95dfbbc0d9b5c02d47c513c8adc23b1b38653873ab3a817e82bad5776ceeb6568d2041ab026ca460a7c3808
+EBUILD gnome-console-43.0.ebuild 869 BLAKE2B b4be5d3e916c3f67467dd7cdb0354161ab1b9ded68ef20237f12a5873433fbe357a7d00202d292c5b4ff990397bbb9241451a6d1f46350b402dc3fd75f63a300 SHA512 9c43aff050f658e75c5c630e59376c38fceec74379bbe4351f29364be4474c37e27e07792f0807cf01394af5343d7571638c7923088083b1921b40c85dca282a
+MISC metadata.xml 254 BLAKE2B de7a97001e5947704f42973c8a0c3a23c2d80afb976254f5fd21e9d372a946e055d4cdc3c0eaed010505f87929b56e8b1e650c945e2a302644adbc9440833be8 SHA512 c81da4f9b80e5691a167f4590906952e25356604ec17689c005be14efb394c0634776bbe84df936edde239480bdf46db41216b00da4a3a45f670e9ca18ab0132
diff --git a/gui-apps/gnome-console/gnome-console-43.0.ebuild b/gui-apps/gnome-console/gnome-console-43.0.ebuild
new file mode 100644
index 000000000000..c4b376a3f0ff
--- /dev/null
+++ b/gui-apps/gnome-console/gnome-console-43.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A simple user-friendly terminal emulator for the GNOME desktop"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/console"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.72:2
+ >=gui-libs/gtk-4.6:4
+ >=gui-libs/libadwaita-1.2:1
+ >=gui-libs/vte-0.70.0:2.91-gtk4
+ gnome-base/libgtop:2=
+ >=dev-libs/libpcre2-10.32:0=
+ gnome-base/gsettings-desktop-schemas
+
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local emesonargs=(
+ -Ddevel=false
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/gui-apps/gnome-console/metadata.xml b/gui-apps/gnome-console/metadata.xml
new file mode 100644
index 000000000000..f453528b934f
--- /dev/null
+++ b/gui-apps/gnome-console/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+</pkgmetadata>