summaryrefslogtreecommitdiff
path: root/gui-apps/foot-terminfo
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/foot-terminfo')
-rw-r--r--gui-apps/foot-terminfo/Manifest2
-rw-r--r--gui-apps/foot-terminfo/foot-terminfo-1.12.1.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/gui-apps/foot-terminfo/Manifest b/gui-apps/foot-terminfo/Manifest
index 6b61d149de58..fe24ec620908 100644
--- a/gui-apps/foot-terminfo/Manifest
+++ b/gui-apps/foot-terminfo/Manifest
@@ -1,3 +1,5 @@
DIST foot-1.11.0.tar.gz 468899 BLAKE2B f3e3909c670598dab151f8be4104921fddd6621e833a8fe43c68d06347e3e866101fe1563282622436638674b7f73770762d47a7b9fd61d42b00bc7634e2ea76 SHA512 edf8130dfb52e06b6d8638115eca19695b24536f3f6b284e0319876edb95c3c86800f9527cc9dae3f66d2d317d26add793634a19f302e52c9f0118b9b91fc9c2
+DIST foot-1.12.1.tar.gz 484702 BLAKE2B 5f3ed5923dfe2e3d110da298d4abefb331c15bb0f3db3135a4e8d481b528b3f8287fc5d8516e9d3a34b8084f6364edae93dee496d9192fe610d2c17733277451 SHA512 553f404b074f4372fb8cfb050f0378d1cbe1620ea8afe2e279523df3006eefd0b0ed24addca33de10cfc8109e5aaec66beccbd5f30e032bb9f2bd9b81ac798cb
EBUILD foot-terminfo-1.11.0-r1.ebuild 650 BLAKE2B c55b2484914072849ef8b591be60847277299fd4a32a1d57bbd415f0e6dd764dbd189a289fbdd46a325f2004e5449dfc2f362c39541f94bed8806d144a8e9652 SHA512 ed97c8e883e7c152cb9707c7bbb71516802f8b87992cc64ea6d597257d92c122073f8ecccf10e448862ad1407243084a1ba6bc963f98e39df447c670418a96be
+EBUILD foot-terminfo-1.12.1.ebuild 650 BLAKE2B c55b2484914072849ef8b591be60847277299fd4a32a1d57bbd415f0e6dd764dbd189a289fbdd46a325f2004e5449dfc2f362c39541f94bed8806d144a8e9652 SHA512 ed97c8e883e7c152cb9707c7bbb71516802f8b87992cc64ea6d597257d92c122073f8ecccf10e448862ad1407243084a1ba6bc963f98e39df447c670418a96be
MISC metadata.xml 395 BLAKE2B ab339b3a0e03010977d4ef364da63a1cce6d1986829234a158c6d3c6bd9d639235d081d34bf8a49f8deb9d567b05320479718a5c79cf6b5a8113067fc69e2ad1 SHA512 d04b9e89a98877d7c39b48af3221705f3e2ebd0ed34fb0508bd13228c196350dda1a21a430b42777ccf9349e2e1ab76f39c20961de4429b10d5925a81855a291
diff --git a/gui-apps/foot-terminfo/foot-terminfo-1.12.1.ebuild b/gui-apps/foot-terminfo/foot-terminfo-1.12.1.ebuild
new file mode 100644
index 000000000000..665d31273e16
--- /dev/null
+++ b/gui-apps/foot-terminfo/foot-terminfo-1.12.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Terminfo for foot, a fast, lightweight and minimal Wayland terminal emulator"
+HOMEPAGE="https://codeberg.org/dnkl/foot"
+SRC_URI="https://codeberg.org/dnkl/foot/archive/${PV}.tar.gz -> foot-${PV}.tar.gz"
+S="${WORKDIR}/foot"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="!>=sys-libs/ncurses-6.3[-minimal]"
+BDEPEND="sys-libs/ncurses"
+
+src_prepare() {
+ default
+ sed -i s/@default_terminfo@/foot/ foot.info || die
+}
+
+src_install() {
+ dodir /usr/share/terminfo/
+ tic -xo "${ED}"/usr/share/terminfo foot.info || die
+}