summaryrefslogtreecommitdiff
path: root/gnustep-libs/dbuskit/dbuskit-0.1.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-libs/dbuskit/dbuskit-0.1.1-r1.ebuild')
-rw-r--r--gnustep-libs/dbuskit/dbuskit-0.1.1-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnustep-libs/dbuskit/dbuskit-0.1.1-r1.ebuild b/gnustep-libs/dbuskit/dbuskit-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..de48698483fe
--- /dev/null
+++ b/gnustep-libs/dbuskit/dbuskit-0.1.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools gnustep-2
+
+DESCRIPTION="framework that interfaces Objective-C applications with the D-Bus IPC service"
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="http://download.gna.org/gnustep/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=sys-apps/dbus-1.2.1"
+RDEPEND="${DEPEND}"
+
+PATCHES=( ${FILESDIR}/${P}-remove_gc.patch )
+
+src_prepare() {
+ default
+
+ if ! use doc; then
+ # Remove doc target
+ sed -i -e "/SUBPROJECTS/s/Documentation//" GNUmakefile \
+ || die "doc sed failed"
+ fi
+
+ # Bug 410697
+ sed -e "s#ObjectiveC2/runtime.h#ObjectiveC2/objc/runtime.h#" \
+ -i configure.ac || die "ObjectiveC2 runtime sed failed"
+
+ eautoreconf
+}