summaryrefslogtreecommitdiff
path: root/gnustep-base/mknfonts/mknfonts-0.5-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-base/mknfonts/mknfonts-0.5-r3.ebuild')
-rw-r--r--gnustep-base/mknfonts/mknfonts-0.5-r3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnustep-base/mknfonts/mknfonts-0.5-r3.ebuild b/gnustep-base/mknfonts/mknfonts-0.5-r3.ebuild
new file mode 100644
index 000000000000..af4957771143
--- /dev/null
+++ b/gnustep-base/mknfonts/mknfonts-0.5-r3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnustep-base
+
+DESCRIPTION="A tool to create .nfont packages for use with gnustep-back-art"
+HOMEPAGE="https://packages.debian.org/mknfonts.tool"
+SRC_URI="mirror://debian/pool/main/m/${PN}.tool/${PN}.tool_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND="gnustep-base/gnustep-gui
+ >=media-libs/freetype-2.1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-rename.patch
+ "${FILESDIR}"/${P}-pkgconfig.patch
+)
+
+src_prepare() {
+ default
+
+ # Correct link command for --as-needed
+ sed -i -e "s/ADDITIONAL_LDFLAGS/ADDITIONAL_TOOL_LIBS/" GNUmakefile || die
+}