summaryrefslogtreecommitdiff
path: root/gnustep-apps/sogo
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-apps/sogo')
-rw-r--r--gnustep-apps/sogo/Manifest7
-rw-r--r--gnustep-apps/sogo/files/sogod.confd6
-rw-r--r--gnustep-apps/sogo/files/sogod.initd32
-rw-r--r--gnustep-apps/sogo/metadata.xml15
-rw-r--r--gnustep-apps/sogo/sogo-3.2.10.ebuild100
-rw-r--r--gnustep-apps/sogo/sogo-3.2.9.ebuild100
6 files changed, 260 insertions, 0 deletions
diff --git a/gnustep-apps/sogo/Manifest b/gnustep-apps/sogo/Manifest
new file mode 100644
index 000000000000..2300beb5224e
--- /dev/null
+++ b/gnustep-apps/sogo/Manifest
@@ -0,0 +1,7 @@
+AUX sogod.confd 117 BLAKE2B c47c8a6376967682571cd62766d0cf2422f35dc5ecbf599c616aee2cc5d6b2830ae3c4f3483924e15c59f44610eb8be656c21324f17270dd5eca6eb27780fe34 SHA512 d93bde8c500bf8452d5f32efc35ec12f436afc498d7cc6ac1f55769f8696c9b41cc5edec829a19ea01b24c0d3a2c7901fc797cb04ced371bc8e0c3e6e243f15b
+AUX sogod.initd 681 BLAKE2B b8a55f93a0e623bb5aa13d10658aba644cb9a532d7a5c02beeee8d7e01365944531e081afe77562da8da77a42bec10a125bd386ede063ad230e0135e8bd56c03 SHA512 d6925d49c24ff6ebfd989016a5c0a707c1bc866070cbd9e4e8eca867ec81fe1ad78bd6606b13349ac7d251f62bd85f239b42f65e1d22015c38b4ad6fe9058f4e
+DIST sogo-3.2.10.tar.gz 32528115 BLAKE2B 7543f2165ed20026f00adfac7697fe6bc0e54f06b3c2ccb99fbfe0ddd14bcf8818521e161bb118789175c4245b67a8ad5dd0cd3ef71f61d34d869e1c0c2a4a93 SHA512 3dbd465592fd98968b32e251659a70306a781999bcfa9e63e142d75d7c9274edc7cbe5069881e939f0e9472f0ef8580e4e0f20059bfc97f8c69893d86c8cadf3
+DIST sogo-3.2.9.tar.gz 32443733 BLAKE2B 6a2ae4b5346bc48b9301263fe017308ee34aabcee1ce5444744b22c3af040533d98738fca29a195fd0f792d1d4470418840d0b1ff0e264c2ebc92877f420fa75 SHA512 070b3812d65598364d9204432678ea48705bf7481371e44442a13ad86d219415e24c579ad59212a7631922a527d30e69aeb17711c3abfc01960f663f4e0112a3
+EBUILD sogo-3.2.10.ebuild 2083 BLAKE2B 3939ee6ada88110304d8680e374fc79df4bf07eaf15cd90034f700ac6dab55dccba6a760c4427122a646b4f7abf89441d132b3eca974ba9a88392d99990b9d23 SHA512 836b37feb3c0764782f4d63b5f9074a554f4765da4e7c0177c2227c4e091e29d93c62af13dbb30dfa9f5bc4fc87c152f6aa60839b6fd5f2d2313b58a57077a32
+EBUILD sogo-3.2.9.ebuild 2083 BLAKE2B 3939ee6ada88110304d8680e374fc79df4bf07eaf15cd90034f700ac6dab55dccba6a760c4427122a646b4f7abf89441d132b3eca974ba9a88392d99990b9d23 SHA512 836b37feb3c0764782f4d63b5f9074a554f4765da4e7c0177c2227c4e091e29d93c62af13dbb30dfa9f5bc4fc87c152f6aa60839b6fd5f2d2313b58a57077a32
+MISC metadata.xml 442 BLAKE2B a70c31f8e7b1688d5b42869fe6795ee03f409b9fbcc67c263f5a81abb31f165324724d1e7fde0c3b0dae35d196dfbbfba205c457bd2ae0c007d282bfe82b50de SHA512 135d98d4b53981130f0070d5db4ca71beb9f1a42b36b67ee4d08423955f09ab852991eb7247b5f49851214894ee989f158d479db9bd17e0e455a994d445034b3
diff --git a/gnustep-apps/sogo/files/sogod.confd b/gnustep-apps/sogo/files/sogod.confd
new file mode 100644
index 000000000000..906a6978d862
--- /dev/null
+++ b/gnustep-apps/sogo/files/sogod.confd
@@ -0,0 +1,6 @@
+# /etc/conf.d/sogod: config file for /etc/init.d/sogod
+
+SOGOD_WORKERS=3
+
+# Additional options for SOGo
+SOGOD_OPTS=""
diff --git a/gnustep-apps/sogo/files/sogod.initd b/gnustep-apps/sogo/files/sogod.initd
new file mode 100644
index 000000000000..ad003be62c9b
--- /dev/null
+++ b/gnustep-apps/sogo/files/sogod.initd
@@ -0,0 +1,32 @@
+#!/sbin/openrc-run
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+SOGOD_PID=/run/sogo/sogod.pid
+
+depend() {
+ need net
+ need memcached
+ after postgresql mysql
+ after slapd
+ after mta
+}
+
+start() {
+ checkpath -q -d -m 0755 -o sogo:sogo $(dirname "${SOGOD_PID}")
+ ebegin "Starting SOGo service"
+ start-stop-daemon --start --quiet \
+ --user sogo --exec /usr/sbin/sogod \
+ -- -WOWorkersCount ${SOGOD_WORKERS} \
+ -WOLogFile /var/log/sogo/sogod.log \
+ -WOPidFile "${SOGOD_PID}" \
+ "${SOGOD_OPTS}"
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping SOGo service"
+ start-stop-daemon --stop \
+ --pidfile "${SOGOD_PID}"
+ eend ${?}
+}
diff --git a/gnustep-apps/sogo/metadata.xml b/gnustep-apps/sogo/metadata.xml
new file mode 100644
index 000000000000..2c4b6c6ef092
--- /dev/null
+++ b/gnustep-apps/sogo/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>gnustep@gentoo.org</email>
+ <name>Gentoo GNUstep Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">inverse-inc/sogo</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/gnustep-apps/sogo/sogo-3.2.10.ebuild b/gnustep-apps/sogo/sogo-3.2.10.ebuild
new file mode 100644
index 000000000000..5c728f4bdae5
--- /dev/null
+++ b/gnustep-apps/sogo/sogo-3.2.10.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnustep-2 user vcs-snapshot
+
+DESCRIPTION="Groupware server built around OpenGroupware.org and the SOPE application server"
+HOMEPAGE="http://www.sogo.nu"
+SRC_URI="https://github.com/inverse-inc/sogo/archive/SOGo-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnutls libressl +ssl"
+
+RDEPEND="
+ dev-libs/libmemcached
+ net-misc/curl
+ net-misc/memcached
+ >=gnustep-libs/sope-${PV}[ldap]
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+"
+DEPEND="${RDEPEND}
+ >=gnustep-base/gnustep-make-2.6.3"
+
+pkg_pretend() {
+ if use ssl && use gnutls && use libressl ; then
+ ewarn "You have enabled both gnutls and libressl, but only"
+ ewarn "one provider can be active. Using gnutls!"
+ fi
+}
+
+pkg_setup() {
+ enewuser sogo -1 /bin/bash /var/lib/sogo
+}
+
+src_prepare() {
+ gnustep-base_src_prepare
+ sed -e "s/validateArgs$//" -i configure \
+ || die "GNUstep.conf sed failed"
+
+ default
+}
+
+src_configure() {
+ local ssl_provider
+ if use ssl ; then
+ if use gnutls ; then
+ ssl_provider=gnutls
+ else
+ ssl_provider=ssl
+ fi
+ else
+ ssl_provider=none
+ fi
+
+ egnustep_env
+
+ ./configure \
+ --disable-strip \
+ --prefix=/usr \
+ --with-ssl="${ssl_provider}" \
+ $(use_enable debug) \
+ || die "configure failed"
+}
+
+src_install() {
+ gnustep-base_src_install
+
+ newconfd "${FILESDIR}"/sogod.confd sogod
+ newinitd "${FILESDIR}"/sogod.initd sogod
+
+ insinto /etc/logrotate.d
+ newins Scripts/logrotate sogo
+ newdoc Apache/SOGo.conf SOGo-Apache.conf
+
+ insinto /etc/sogo
+ doins Scripts/sogo.conf
+
+ insinto /etc/cron.d
+ newins Scripts/sogo.cron sogo
+ keepdir /var/log/sogo
+
+ fowners sogo:sogo /var/log/sogo
+ fowners -R root:sogo /etc/sogo
+}
+
+pkg_postinst() {
+ gnustep-base_pkg_postinst
+ elog "SOGo documentation is available online at:"
+ elog "http://www.sogo.nu/downloads/documentation.html"
+ elog
+ elog "Apache sample configuration file is available in:"
+ elog "/usr/share/doc/${PF}"
+}
diff --git a/gnustep-apps/sogo/sogo-3.2.9.ebuild b/gnustep-apps/sogo/sogo-3.2.9.ebuild
new file mode 100644
index 000000000000..5c728f4bdae5
--- /dev/null
+++ b/gnustep-apps/sogo/sogo-3.2.9.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnustep-2 user vcs-snapshot
+
+DESCRIPTION="Groupware server built around OpenGroupware.org and the SOPE application server"
+HOMEPAGE="http://www.sogo.nu"
+SRC_URI="https://github.com/inverse-inc/sogo/archive/SOGo-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnutls libressl +ssl"
+
+RDEPEND="
+ dev-libs/libmemcached
+ net-misc/curl
+ net-misc/memcached
+ >=gnustep-libs/sope-${PV}[ldap]
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+"
+DEPEND="${RDEPEND}
+ >=gnustep-base/gnustep-make-2.6.3"
+
+pkg_pretend() {
+ if use ssl && use gnutls && use libressl ; then
+ ewarn "You have enabled both gnutls and libressl, but only"
+ ewarn "one provider can be active. Using gnutls!"
+ fi
+}
+
+pkg_setup() {
+ enewuser sogo -1 /bin/bash /var/lib/sogo
+}
+
+src_prepare() {
+ gnustep-base_src_prepare
+ sed -e "s/validateArgs$//" -i configure \
+ || die "GNUstep.conf sed failed"
+
+ default
+}
+
+src_configure() {
+ local ssl_provider
+ if use ssl ; then
+ if use gnutls ; then
+ ssl_provider=gnutls
+ else
+ ssl_provider=ssl
+ fi
+ else
+ ssl_provider=none
+ fi
+
+ egnustep_env
+
+ ./configure \
+ --disable-strip \
+ --prefix=/usr \
+ --with-ssl="${ssl_provider}" \
+ $(use_enable debug) \
+ || die "configure failed"
+}
+
+src_install() {
+ gnustep-base_src_install
+
+ newconfd "${FILESDIR}"/sogod.confd sogod
+ newinitd "${FILESDIR}"/sogod.initd sogod
+
+ insinto /etc/logrotate.d
+ newins Scripts/logrotate sogo
+ newdoc Apache/SOGo.conf SOGo-Apache.conf
+
+ insinto /etc/sogo
+ doins Scripts/sogo.conf
+
+ insinto /etc/cron.d
+ newins Scripts/sogo.cron sogo
+ keepdir /var/log/sogo
+
+ fowners sogo:sogo /var/log/sogo
+ fowners -R root:sogo /etc/sogo
+}
+
+pkg_postinst() {
+ gnustep-base_pkg_postinst
+ elog "SOGo documentation is available online at:"
+ elog "http://www.sogo.nu/downloads/documentation.html"
+ elog
+ elog "Apache sample configuration file is available in:"
+ elog "/usr/share/doc/${PF}"
+}