summaryrefslogtreecommitdiff
path: root/gnome-extra/tecla/tecla-46.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/tecla/tecla-46.0.ebuild')
-rw-r--r--gnome-extra/tecla/tecla-46.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnome-extra/tecla/tecla-46.0.ebuild b/gnome-extra/tecla/tecla-46.0.ebuild
new file mode 100644
index 000000000000..134b44ab0c84
--- /dev/null
+++ b/gnome-extra/tecla/tecla-46.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Tecla is a keyboard layout viewer"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/tecla"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ gui-libs/gtk:4[introspection]
+ >=gui-libs/libadwaita-1.4_alpha:1
+ x11-libs/libxkbcommon
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/glib
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}