summaryrefslogtreecommitdiff
path: root/gnome-extra/krb5-auth-dialog/krb5-auth-dialog-43.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/krb5-auth-dialog/krb5-auth-dialog-43.0-r1.ebuild')
-rw-r--r--gnome-extra/krb5-auth-dialog/krb5-auth-dialog-43.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnome-extra/krb5-auth-dialog/krb5-auth-dialog-43.0-r1.ebuild b/gnome-extra/krb5-auth-dialog/krb5-auth-dialog-43.0-r1.ebuild
new file mode 100644
index 000000000000..226a94e02bf7
--- /dev/null
+++ b/gnome-extra/krb5-auth-dialog/krb5-auth-dialog-43.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2 meson
+
+DESCRIPTION="An application to acquire and list Kerberos tickets."
+HOMEPAGE="https://gitlab.gnome.org/GNOME/krb5-auth-dialog/"
+SRC_URI="https://download.gnome.org/sources/${PN}/$(ver_cut 1)/${P}.tar.xz"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-crypt/gcr:0=[gtk]
+ dev-libs/glib:2
+ sys-libs/pam
+ x11-libs/gtk+:3
+ || (
+ app-crypt/heimdal
+ app-crypt/mit-krb5
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/itstool"
+
+PATCHES=( "${FILESDIR}"/${P}-remove-postinstall-script.patch )