summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-shell-extension-applications-overview-tooltip
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/gnome-shell-extension-applications-overview-tooltip')
-rw-r--r--gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest5
-rw-r--r--gnome-extra/gnome-shell-extension-applications-overview-tooltip/files/gnome-shell-extension-applications-overview-tooltip-4-js-warning.patch24
-rw-r--r--gnome-extra/gnome-shell-extension-applications-overview-tooltip/files/gnome-shell-extension-applications-overview-tooltip-4-old-animation.patch45
-rw-r--r--gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-4.ebuild46
-rw-r--r--gnome-extra/gnome-shell-extension-applications-overview-tooltip/metadata.xml7
5 files changed, 127 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
new file mode 100644
index 000000000000..45051bd56d88
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
@@ -0,0 +1,5 @@
+AUX gnome-shell-extension-applications-overview-tooltip-4-js-warning.patch 852 BLAKE2B ee7382dd62c085eafda8013af3cb8f57518ed689b613ef187886b2d22621c036d3b4c3c6582a4edc79bf9b8820fe08b02413618685060bc70216394cef7ef9d9 SHA512 88f58868e3d474088ddbe83cf4b564ebedd2a72f9d4232f2a8df1b244eecbe43af5a0def33078772012ff08ff95ae875f28e62c25e1fb0f80c61b3a0e1c87a7f
+AUX gnome-shell-extension-applications-overview-tooltip-4-old-animation.patch 1139 BLAKE2B f569f41c0bdac260d099b5cf1703787650412ad9c6e68a88c37a194f1b77959afc351bfd325b85439b88df71afc9154b5b071cb4e895b12b13d4095857881f90 SHA512 b13fcc1d56accf985c50c98ddc4a10f87af5a3240566e2dcd51ec9f6aa65a8a88ce3514ca8e77c9d9975582955ad809ca440ece4d777f9c9d4ca3338a4d5659a
+DIST gnome-shell-extension-applications-overview-tooltip-4.tar.gz 79384 BLAKE2B 9e428b66351cb26615050a1c2e8e7ee1e325079b46ae7fc40eb836aef652ca33e04af9b39c07098364b6844c057867e9e5ddee291748afe63084caa108289037 SHA512 befb6f11f7836010077aba10d8664ba462c7153b498e25b5ad0fa12e065dc0b84302b7cc97d1f0685108ea92c20b61491c85a25a4511ad7237b1c0122a587868
+EBUILD gnome-shell-extension-applications-overview-tooltip-4.ebuild 1330 BLAKE2B 900e81b2bc5ea706b8345af6077ebe65a651b75d8a60f51ee826cea0c79c395ee11a4cafa6745ca0ed2cbc0458052f822f4ffb5666a44ff04d5182a62f303502 SHA512 59f4f9e99c31fc7b9d9ae7eafcda0115883e56e62f7025a6ca4b50f802e4b4c7539c1e4873d58f049962b88d323b1545660f4339adbc177555639576c4203811
+MISC metadata.xml 216 BLAKE2B 0fbfa16661345362ff89f87adc0bb42fc5f5c9145cdedb36f3f537b39af4023b91c4dfb0d8e83a4f9ac963141f594ba8ae678371c338d992a96e02c11fd84195 SHA512 628a69805356b7458edaa2297901224178b016477a937f77e692a78ce3e7a0b6d2d7b4c4b7e70d0185d7112e6a59a5131e07d8c950e90b9c8722471d7511afc6
diff --git a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/files/gnome-shell-extension-applications-overview-tooltip-4-js-warning.patch b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/files/gnome-shell-extension-applications-overview-tooltip-4-js-warning.patch
new file mode 100644
index 000000000000..0ed36b288f0e
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/files/gnome-shell-extension-applications-overview-tooltip-4-js-warning.patch
@@ -0,0 +1,24 @@
+From 27af671cca3fc6b9dd5c8687c1b3d0d530ccc516 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Rapha=C3=ABl=20Rochet?= <raphael@rri.fr>
+Date: Sun, 23 Sep 2018 16:39:36 +0200
+Subject: [PATCH] Fix JS warning
+
+---
+ extension.js | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/extension.js b/extension.js
+index 346a89a..1eda926 100644
+--- a/extension.js
++++ b/extension.js
+@@ -250,8 +250,8 @@ function _showTooltip(actor) {
+
+ if (!detailtext) { _ttdetail.hide() } else { _ttdetail.show() };
+
+- [stageX, stageY] = actor.get_transformed_position();
+- [iconWidth, iconHeight] = actor.get_transformed_size();
++ let [stageX, stageY] = actor.get_transformed_position();
++ let [iconWidth, iconHeight] = actor.get_transformed_size();
+ let y = stageY + iconHeight + 5;
+ let x = stageX - Math.round((_ttbox.get_width() - iconWidth)/2);
+
diff --git a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/files/gnome-shell-extension-applications-overview-tooltip-4-old-animation.patch b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/files/gnome-shell-extension-applications-overview-tooltip-4-old-animation.patch
new file mode 100644
index 000000000000..333d1c7c22b3
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/files/gnome-shell-extension-applications-overview-tooltip-4-old-animation.patch
@@ -0,0 +1,45 @@
+From ff442818fb5c4fd9521c532200ff825061fa35e4 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Rapha=C3=ABl=20Rochet?= <raphael@rri.fr>
+Date: Mon, 11 Feb 2019 21:26:24 +0100
+Subject: [PATCH] Fix #6 by removing old swipe animation
+
+---
+ extension.js | 16 ++--------------
+ 1 file changed, 2 insertions(+), 14 deletions(-)
+
+diff --git a/extension.js b/extension.js
+index 1eda926..deffc58 100644
+--- a/extension.js
++++ b/extension.js
+@@ -175,16 +175,10 @@ function _onLeave() {
+ _labelTimeoutId = 0;
+ }
+
+- // but give a chance to skip hover delay if the cursor hovers another icon
+ if (_labelShowing) {
+- _resetHoverTimeoutId = Mainloop.timeout_add(HIDEDELAY, function() {
+- _hideTooltip();
+- _labelShowing = false;
+- _resetHoverTimeoutId = 0;
+- return false;
+- } );
++ _hideTooltip();
++ _labelShowing = false;
+ }
+-
+ }
+
+
+@@ -277,12 +271,6 @@ function _showTooltip(actor) {
+
+ }
+
+- // do not hide tooltip while cursor is on icon
+- if (_resetHoverTimeoutId > 0) {
+- Mainloop.source_remove(_resetHoverTimeoutId);
+- _resetHoverTimeoutId = 0;
+- }
+-
+ } else {
+
+ // No tooltip to show : act like we're leaving an icon
diff --git a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-4.ebuild b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-4.ebuild
new file mode 100644
index 000000000000..73ae2aaec43e
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vcs-snapshot
+
+# Workaround until https://bugzilla.gnome.org/show_bug.cgi?id=663725 is fixed
+DESCRIPTION="Show tooltip with full name and description"
+HOMEPAGE="https://github.com/RaphaelRochet/applications-overview-tooltip"
+SRC_URI="https://github.com/RaphaelRochet/applications-overview-tooltip/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# https://github.com/RaphaelRochet/applications-overview-tooltip/issues/7
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+# glib for glib-compile-schemas at build time, needed at runtime anyways
+COMMON_DEPEND="
+ dev-libs/glib:2
+"
+RDEPEND="${COMMON_DEPEND}
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-3.20
+"
+DEPEND="${COMMON_DEPEND}"
+
+PATCHES=(
+ # From 'master'
+ "${FILESDIR}"/${P}-old-animation.patch
+ "${FILESDIR}"/${P}-js-warning.patch
+)
+
+src_install() {
+ einstalldocs
+ rm -f README.md || die
+ insinto /usr/share/gnome-shell/extensions/applications-overview-tooltip@RaphaelRochet
+ doins -r *
+ glib-compile-schemas "${ED}"/usr/share/gnome-shell/extensions/applications-overview-tooltip@RaphaelRochet/schemas || die
+}
+
+pkg_postinst() {
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
diff --git a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/metadata.xml b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/metadata.xml
new file mode 100644
index 000000000000..020b40648ee8
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>pacho@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>