summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-boxes
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/gnome-boxes')
-rw-r--r--gnome-extra/gnome-boxes/Manifest2
-rw-r--r--gnome-extra/gnome-boxes/gnome-boxes-3.34.4.ebuild128
2 files changed, 130 insertions, 0 deletions
diff --git a/gnome-extra/gnome-boxes/Manifest b/gnome-extra/gnome-boxes/Manifest
index 037bb339f2a3..0a3f6c4f520a 100644
--- a/gnome-extra/gnome-boxes/Manifest
+++ b/gnome-extra/gnome-boxes/Manifest
@@ -1,6 +1,8 @@
AUX 3.32.2-vala-compat.patch 1011 BLAKE2B 99861d3c6c7ae2c35c118676d6805c09ce6475256eea2a90770e0681d01f2cb33351b24854de341752f3e2e4986c1e43dfb7685dbf081ccf2d06193eb03ee7f2 SHA512 c4ebcfdc838ca088fbab980f745c404264927d274f50d4d135d170ebeedcd4c2dc8eb2345d0ba140e4e474a87083dd283e0734c672cc43a70cbe03292b1dc7e9
DIST gnome-boxes-3.30.3.tar.xz 1198224 BLAKE2B 1c65d3f051d32dc85284da4d392e3ec418edf028b61f1166173ac6ced3e6cba687b297ea135a4e54058c561eb5fe69d767e9ee698fb6b16f6bd4cd09b00d5c3a SHA512 fc8a06bb8c71356d50002468f7722aee14abe8432ccce319ada3032746b53eb2f679a93f991c04ae34832a315fc95d561ffc169c4560a23573c046705b5446b4
DIST gnome-boxes-3.32.2.tar.xz 1178340 BLAKE2B 9c345e69cc53b3b06b609c3ddfb0f3e1cb54aaffb9ebad4deafd0414913e6d5bc4faecce6e9714a448da7c6094b27d97f039bb8db512973ffd665a5190ff6561 SHA512 f3208f5185ad65750b2f745e8170aaff6a097aa9d706e5abc74259c0940da8fafb046b55dfcc144e8c64782942dfebb711622b552f6daa2dc45ad863d480855f
+DIST gnome-boxes-3.34.4.tar.xz 1191668 BLAKE2B 98a206abdd8a181979b6d40f176b0a1518b51ebd312929c8eab549e6de83b1d299f4c3177d6b2b07873c2e620a744b627adce6bc1c0ef5ae2aac55189377de4f SHA512 025bfe6fe583cedd80b376b96e87a8ecbbb8f4d723490cf18cc2ca73cb959d9e2bae1b784cc1018866c594962d1e508e5a3b9c9562763eb76e7291c5f6189463
EBUILD gnome-boxes-3.30.3.ebuild 3919 BLAKE2B 40592b490c835d18da742e89ac44941f1f13beefe01cfec8e4b7727208122a8b6cb5d8be8a90fe49280c75ac76b057d3cf3767f8c37b5c982d7c7a7f43dded6b SHA512 e4d3cf2519a0f542a97786154fa802a7aca0cdb5f35f30f04d98293128f625a3cdb13e68f7971668ce23aa18db8a5e55f6505dd0b00c7ec2af000a4fceca61b2
EBUILD gnome-boxes-3.32.2.ebuild 4057 BLAKE2B c9bd3b0df53c691eecce0fbe2e504ff23382c00af0d4b6b14b1fdd9b9599e5e707c8c8a78bb22deeb0f335b62086da3fa7b6b24709c2de8e1a241168522c4f85 SHA512 dbc8a3818fd736413f722affe7216b7df540288a606b2e84b2ed479a2fcbad5b565b89a56cfaec8aa2db3bd477a7e61783a3fec03c66befab49bd83bc5f6de99
+EBUILD gnome-boxes-3.34.4.ebuild 3846 BLAKE2B 213a62dc5b30aa8b2946217647e051fbd4d5f996cbc64192a635fa4b5f8d13a1c3db857430bfd92a3ffae382fbd780944d33720c86719723fca88ca2cd05b516 SHA512 252bc7c687cf8d472e1984c7846a0324e00269b3b1288a676dabeada1d2f2df40045bd495e427d066a2816c77fbe492ea74eac1df038fb0da18fe9ad0b6ad9e7
MISC metadata.xml 253 BLAKE2B a1efbd3751efaa83ee173f557ec1c8a4497a90b60896cf5a7a07da40b4f94a7a299ca0385477e82b2f5e5dbdf9afa482ccbe21f35ef44214e9c451d764b65529 SHA512 8d59f413993268ca783f7407b676900bb2d964754bf705d4175e2bafbe058a52af74f3928e4bd84d292518f8cf13fab7051486ab7cdc61d02fae6e0188d44442
diff --git a/gnome-extra/gnome-boxes/gnome-boxes-3.34.4.ebuild b/gnome-extra/gnome-boxes/gnome-boxes-3.34.4.ebuild
new file mode 100644
index 000000000000..bdb2c2fdda4f
--- /dev/null
+++ b/gnome-extra/gnome-boxes/gnome-boxes-3.34.4.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+VALA_MIN_API_VERSION="0.40"
+
+inherit gnome.org gnome2-utils linux-info meson readme.gentoo-r1 vala xdg
+
+DESCRIPTION="Simple GNOME 3 application to access remote or virtual systems"
+HOMEPAGE="https://wiki.gnome.org/Apps/Boxes"
+
+LICENSE="LGPL-2+ CC-BY-2.0"
+SLOT="0"
+
+IUSE="rdp"
+KEYWORDS="~amd64"
+
+# FIXME: qemu probably needs to depend on spice[smartcard] directly with USE=spice
+# FIXME: Check over libvirt USE=libvirtd,qemu and the smartcard/usbredir requirements
+# Technically vala itself still ships a libsoup vapi, but that may change, and it should be better to use the .vapi from the same libsoup version
+# gtk-vnc raised due to missing vala bindings in earlier ebuilds
+DEPEND="
+ >=app-arch/libarchive-3.0.0:=
+ >=dev-libs/glib-2.52:2
+ >=x11-libs/gtk+-3.22.20:3
+ >=net-libs/gtk-vnc-0.8.0-r1[gtk3(+)]
+ >=sys-libs/libosinfo-1.4.0
+ app-crypt/libsecret
+ >=net-libs/libsoup-2.44:2.4
+ virtual/libusb:1
+ >=app-emulation/libvirt-glib-2.0.0
+ >=dev-libs/libxml2-2.7.8:2
+ >=net-misc/spice-gtk-0.32[gtk3(+),smartcard,usbredir]
+ app-misc/tracker:0/2.0
+ >=x11-libs/vte-0.40.2:2.91
+ net-libs/webkit-gtk:4
+
+ >=dev-libs/gobject-introspection-1.56:=
+ >=dev-libs/libgudev-165:=
+ rdp? ( net-misc/freerdp:= )
+" # gobject-introspection needed for libovf subproject (and gtk-frdp subproject with USE=rdp)
+# These are called via exec():
+# sys-fs/mtools mcopy for unattended file copying for files that libarchive doesn't support
+# virtual/cdrtools mkisofs is needed for unattended installer secondary disk image creation
+# app-emulation/libguestfs virt-sysprep is used for VM cloing, if not there, it logs debug and doesn't function
+# sys-apps/policycoreutils restorecon is used for checking selinux context
+# app-emulation/libvirt virsh used for various checks (and we need the library anyways)
+# sys-auth/polkit used for making all libvirt system disks readable via "pkexec chmod a+r" that aren't already readable to the user (libvirt system importer)
+# app-emulation/qemu qemu-img used to convert image to QCOW2 format during copy
+RDEPEND="${DEPEND}
+ >=app-misc/tracker-miners-2[iso]
+ app-emulation/spice[smartcard]
+ >=app-emulation/libvirt-0.9.3[libvirtd,qemu]
+ >=app-emulation/qemu-1.3.1[spice,smartcard,usbredir]
+ sys-fs/mtools
+ virtual/cdrtools
+ sys-auth/polkit
+"
+# gtk-frdp generates gir and needs gtk+ introspection for it
+# This is only needed for creating the .vapi file, but gnome-boxes needs it
+BDEPEND="
+ $(vala_depend)
+ net-libs/gtk-vnc[vala]
+ sys-libs/libosinfo[vala]
+ app-crypt/libsecret[vala]
+ net-libs/libsoup:2.4[vala]
+ app-emulation/libvirt-glib[vala]
+ net-misc/spice-gtk[vala]
+ x11-libs/vte:2.91[vala]
+ dev-libs/appstream-glib
+ rdp? ( x11-libs/gtk+:3[introspection] )
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="Before running gnome-boxes for local VMs, you will need to load the KVM modules.
+If you have an Intel Processor, run:
+# modprobe kvm-intel
+
+If you have an AMD Processor, run:
+# modprobe kvm-amd"
+
+pkg_pretend() {
+ linux-info_get_any_version
+
+ if linux_config_exists; then
+ if ! { linux_chkconfig_present KVM_AMD || \
+ linux_chkconfig_present KVM_INTEL; }; then
+ ewarn "You need KVM support in your kernel to use GNOME Boxes local VM support!"
+ fi
+ fi
+}
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Ddistributor_name=Gentoo
+ -Ddistributor_version=${PVR}
+ $(meson_use rdp)
+ -Dinstalled_tests=false
+ -Dflatpak=false
+ -Dprofile=default
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}