summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-boxes
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/gnome-boxes')
-rw-r--r--gnome-extra/gnome-boxes/Manifest2
-rw-r--r--gnome-extra/gnome-boxes/gnome-boxes-44.2.ebuild120
2 files changed, 122 insertions, 0 deletions
diff --git a/gnome-extra/gnome-boxes/Manifest b/gnome-extra/gnome-boxes/Manifest
index 6ffd223b4866..4c4b45b794f8 100644
--- a/gnome-extra/gnome-boxes/Manifest
+++ b/gnome-extra/gnome-boxes/Manifest
@@ -1,3 +1,5 @@
DIST gnome-boxes-44.1.tar.xz 1239656 BLAKE2B 86a414982b95840f198dc5adc0bbead117405339a8ab997248768583d6abc5cba635540ec24029e0fc5771926728f6696aa117eb79a9c6dca7dfbfc60dff654c SHA512 75464f0ce6ff72c9da4cf4966f566674f0e16b4c7a51ae472761e4bd9c8fc654b4833f9f8bdc4c3e3581d00e3548ed3d731c4d8d8a05e610126f350136d8f31f
+DIST gnome-boxes-44.2.tar.xz 1239344 BLAKE2B 69b2c387f3482f41450df89ed742d754c68f119c02b4aa7401b019a28e21494d07b6402fe2ae2e5fb59f4c292e7246ef8a5eb240bb586359368c3dbab93b83ca SHA512 08e40cd45a4bdc3ba82bfd0a5f4065e56685c43343d6e745f51a5a8043b402a1eb6b6396193600d89d30b2791cb4e8718194ca1b83b7be954b83b5d939eed948
EBUILD gnome-boxes-44.1.ebuild 3446 BLAKE2B af146f8f12b3ed9967f21f9e3e126cf5bf1703511c32e2305790fa752c8eb7b56e8a068bb095482d92f62d28280dcde827000c45d6b9ed8bc3cfc503ee652007 SHA512 c492e8d00b5b1d40c10dc67ac95019ae1c80d5f7bafe195e901cec0c9b372d3664450b954bdc9bd02f65d1eade8b13591116f40e7e46e73ae7227595a6f81557
+EBUILD gnome-boxes-44.2.ebuild 3467 BLAKE2B bd5fb7805750f4b9dea15530b23f6ad02c711b32ae8a3fb025e27c389680af18c9e9bf3bfcd963c2b300fb24b91e86e6d10b269cbb955471f08685ea3488d6e6 SHA512 51cc358f1929279c8a35b44909edfd26b710633ffd6af3d7a45a6c28728b2ba5e88e1ff63dad3616df34b3df4f874d7424f2e98a13de113a951db581eb97cf2a
MISC metadata.xml 352 BLAKE2B 285b6e588965df3d070f92552b36941c6346a9fde3dce831baa82d42c8ca23f62cc027e5984a27fc87bffca8181c2d13a52b064729349daef0aa815a566a885e SHA512 09baca6576a90ca57b6e0935879f1630550efc9d591b425d6944b28b1184612b34fcdbae6d835d98812c89ec7a47415af9a01678be16f35a52933bb7c374131f
diff --git a/gnome-extra/gnome-boxes/gnome-boxes-44.2.ebuild b/gnome-extra/gnome-boxes/gnome-boxes-44.2.ebuild
new file mode 100644
index 000000000000..49f09ffa0d85
--- /dev/null
+++ b/gnome-extra/gnome-boxes/gnome-boxes-44.2.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils linux-info meson readme.gentoo-r1 vala xdg
+
+DESCRIPTION="Simple GNOME application to access remote or virtual systems"
+HOMEPAGE="https://wiki.gnome.org/Apps/Boxes"
+
+LICENSE="LGPL-2+ CC-BY-2.0"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+# FIXME: qemu probably needs to depend on spice[smartcard] directly with USE=spice
+# FIXME: Check over libvirt USE=libvirtd,qemu and the smartcard/usbredir requirements
+# Technically vala itself still ships a libsoup vapi, but that may change, and
+# it should be better to use the .vapi from the same libsoup version
+DEPEND="
+ >=app-arch/libarchive-3.0.0:=
+ >=dev-libs/glib-2.52:2
+ >=x11-libs/gtk+-3.24.1:3
+ >=gui-libs/libhandy-1.5.0:1
+ >=sys-libs/libosinfo-1.10.0-r1
+ net-libs/libsoup:3.0
+ virtual/libusb:1
+ >=app-emulation/libvirt-glib-4.0.0
+ >=dev-libs/libxml2-2.7.8:2
+ >=net-misc/spice-gtk-0.32[gtk3(+),smartcard,usbredir]
+ >=net-libs/webkit-gtk-2.38.0:4.1
+
+ >=dev-libs/gobject-introspection-1.56:=
+ >=dev-libs/libgudev-165:=
+" # gobject-introspection needed for libovf subproject
+# These are called via exec():
+# - sys-fs/mtools mcopy for unattended file copying for files that libarchive doesn't support
+# - app-cdr/cdrtools mkisofs is needed for unattended installer secondary disk image creation
+# - app-emulation/libguestfs virt-sysprep is used for VM cloing, if not there, it logs debug and doesn't function
+# - sys-apps/policycoreutils restorecon is used for checking selinux context
+# - app-emulation/libvirt virsh used for various checks (and we need the library anyways)
+# - sys-auth/polkit used for making all libvirt system disks readable via "pkexec
+# chmod a+r" that aren't already readable to the user (libvirt system importer)
+# - app-emulation/qemu qemu-img used to convert image to QCOW2 format during copy
+RDEPEND="${DEPEND}
+ app-cdr/cdrtools
+ app-misc/tracker-miners:3[iso]
+ app-emulation/spice[smartcard]
+ >=app-emulation/libvirt-0.9.3[libvirtd,qemu]
+ >=app-emulation/qemu-1.3.1[spice,smartcard,usbredir]
+ sys-fs/mtools
+ sys-auth/polkit
+"
+# This is only needed for creating the .vapi file, but gnome-boxes needs it
+BDEPEND="
+ $(vala_depend)
+ sys-libs/libosinfo[vala]
+ app-crypt/libsecret[vala]
+ net-libs/libsoup:3.0[vala]
+ app-emulation/libvirt-glib[vala]
+ net-misc/spice-gtk[vala]
+ x11-libs/vte:2.91[vala]
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="Before running gnome-boxes for local VMs, you will need to load the KVM modules.
+If you have an Intel Processor, run:
+# modprobe kvm-intel
+
+If you have an AMD Processor, run:
+# modprobe kvm-amd"
+
+pkg_pretend() {
+ linux-info_get_any_version
+
+ if linux_config_exists; then
+ if ! { linux_chkconfig_present KVM_AMD || \
+ linux_chkconfig_present KVM_INTEL; }; then
+ ewarn "You need KVM support in your kernel to use GNOME Boxes local VM support!"
+ fi
+ fi
+}
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Ddistributor_name=Gentoo
+ -Ddistributor_version=${PVR}
+ -Dinstalled_tests=false
+ -Dflatpak=false
+ -Dprofile=default
+ -Duefi=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}