summaryrefslogtreecommitdiff
path: root/gnome-extra/gconf-editor/gconf-editor-3.0.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/gconf-editor/gconf-editor-3.0.1-r1.ebuild')
-rw-r--r--gnome-extra/gconf-editor/gconf-editor-3.0.1-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnome-extra/gconf-editor/gconf-editor-3.0.1-r1.ebuild b/gnome-extra/gconf-editor/gconf-editor-3.0.1-r1.ebuild
new file mode 100644
index 000000000000..46fca22ad7ea
--- /dev/null
+++ b/gnome-extra/gconf-editor/gconf-editor-3.0.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="An editor to the GNOME config system"
+HOMEPAGE="https://git.gnome.org/browse/gconf-editor"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=x11-libs/gtk+-3.0.0:3
+ >=gnome-base/gconf-2.12:2
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ app-text/gnome-doc-utils
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+ ~app-text/docbook-xml-dtd-4.1.2
+"
+# gnome-common for eautoreconf
+
+PATCHES=(
+ # Fix assertion failed crash (from 'master')
+ "${FILESDIR}/${PN}-3.0.1-assertion-crash.patch"
+
+ # Drop use GTK accel maps (from 'master')
+ "${FILESDIR}/${PN}-3.0.1-drop-accel.patch"
+)