summaryrefslogtreecommitdiff
path: root/gnome-base
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/Manifest.gzbin4731 -> 4728 bytes
-rw-r--r--gnome-base/gnome-keyring/Manifest2
-rw-r--r--gnome-base/gnome-keyring/gnome-keyring-46.2.ebuild84
-rw-r--r--gnome-base/gnome-shell/Manifest3
-rw-r--r--gnome-base/gnome-shell/files/37e49e8a22c223b030297f9607bdb748c219e060.patch42
-rw-r--r--gnome-base/gnome-shell/gnome-shell-45.6-r1.ebuild (renamed from gnome-base/gnome-shell/gnome-shell-45.6.ebuild)2
-rw-r--r--gnome-base/gsettings-desktop-schemas/Manifest2
-rw-r--r--gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-46.0.ebuild43
8 files changed, 177 insertions, 1 deletions
diff --git a/gnome-base/Manifest.gz b/gnome-base/Manifest.gz
index f6c970846fb4..f9fbc855f237 100644
--- a/gnome-base/Manifest.gz
+++ b/gnome-base/Manifest.gz
Binary files differ
diff --git a/gnome-base/gnome-keyring/Manifest b/gnome-base/gnome-keyring/Manifest
index e74a76a8c5a0..0556acc50503 100644
--- a/gnome-base/gnome-keyring/Manifest
+++ b/gnome-base/gnome-keyring/Manifest
@@ -1,4 +1,6 @@
AUX gnome-keyring-42.1-c99.patch 2141 BLAKE2B 4eb182721490c785e5d7425243d30b9240183b575d6f10ab85deff917831f595c4a750af8c769daa2056891a5c80fca79ad5397188169a647b18339be01a8f02 SHA512 772f6408c77ef83c3abfb4eb17c370603b0dc549bc306baf7cb7e1a4f4c14011bb03b3f0a41b34ab0bc4919464984d1b3bc46d816a000e4fbcd8c5d388383cb1
DIST gnome-keyring-42.1.tar.xz 1346284 BLAKE2B ff6093cc16c649cda1e6cc2848c2198a502d8aa20a56f0a4dca00550e99f18820028427a7ec3979b6871648a7931da19fced3210558d5ca3de47983b7c94452d SHA512 560dc409c21768dcbdf42151986a5bbbfb9a092d2c36295cf76bd603cdf9650fa80670631c7fb8b3e1822bed6a1f55c34b2170a1419ce45fbe8ca08c7eaf3a57
+DIST gnome-keyring-46.2.tar.xz 1359500 BLAKE2B 47dad5b1eab387e600016828c99d7c829f509e9929e0e06d6427f6c84053050be1e79c4fb369caa1cdfc862e20677a518155b1a5496a64e118f461e81b60edcd SHA512 4229ca0606bdd1b84a3c737288df7f1fc1f8715734e3001964babd882201c3d818deabb3a7662dbf9b67316f03b234de84da3128fb991a500ef8305c2f962ba2
EBUILD gnome-keyring-42.1-r2.ebuild 2298 BLAKE2B d571bf132695ee58f782cb4d86f2c431e0697d4fb6941ca282cf1d7239f3bce92f35a60c5b8f7660dd2c34afeb22fb853718f9912f51900988f27cba5381e756 SHA512 41a6d6256ef5e74ffe0c0596158e77b5debba97e407f27fdb86387ef15c4f96e2320f7e83d2fafe112266fab077177ea37a353d6a7799addf680984d8dec0018
+EBUILD gnome-keyring-46.2.ebuild 2248 BLAKE2B 7fc225cb10d579e1dfa00977dc4bbf5952ec4356659329724e81b4239130bba4bd7c409e3345af06b0f36c4fa02459da6840c2ab37c8e2b20bace9d19504a969 SHA512 9407748199f3e3ae1338d945bc334310a7fe3e0b86604c64640fa5d81c26dc85ced6e17b4b1cbaef1083e40c23292277f65319d23cf9443bb9479ec727081859
MISC metadata.xml 1001 BLAKE2B 276e415289b39f9c75fc156ad695644c5393dff0c689ceacc5c82c2ebee5c4840433966cacb208cff72bcbe6d16a58eea9d59dd75a14839cd2a99cbfa7963ac2 SHA512 7e7e35356506cc0308b7ef42115da4291d6b379094117a516637404ee448d64f5c3477c812c91c7a1cc7e849efed28b67f9a747c303154a9664e5472a558b7c7
diff --git a/gnome-base/gnome-keyring/gnome-keyring-46.2.ebuild b/gnome-base/gnome-keyring/gnome-keyring-46.2.ebuild
new file mode 100644
index 000000000000..0dfa91e4c6c1
--- /dev/null
+++ b/gnome-base/gnome-keyring/gnome-keyring-46.2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit gnome2 pam python-any-r1 virtualx
+
+DESCRIPTION="Password and keyring managing daemon"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-keyring"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="pam selinux +ssh-agent systemd test valgrind"
+RESTRICT="!test? ( test )"
+
+# Replace gkd gpg-agent with pinentry[gnome-keyring] one, bug #547456
+RDEPEND="
+ >=app-crypt/gcr-3.27.90:0=[gtk]
+ >=app-crypt/gnupg-2.0.28:=
+ >=app-eselect/eselect-pinentry-0.5
+ app-misc/ca-certificates
+ >=dev-libs/glib-2.44:2
+ >=dev-libs/libgcrypt-1.2.2:0=
+ pam? ( sys-libs/pam )
+ selinux? ( sec-policy/selinux-gnome )
+ ssh-agent? ( virtual/openssh )
+"
+DEPEND="
+ ${RDEPEND}
+ valgrind? ( dev-debug/valgrind )
+"
+BDEPEND="
+ >=app-eselect/eselect-pinentry-0.5
+ app-text/docbook-xml-dtd:4.3
+ dev-libs/libxslt
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? ( ${PYTHON_DEPS} )
+"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # Disable stupid CFLAGS with debug enabled
+ sed -e 's/CFLAGS="$CFLAGS -g"//' \
+ -e 's/CFLAGS="$CFLAGS -O0"//' \
+ -i configure.ac configure || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --without-libcap-ng \
+ $(use_enable pam) \
+ $(use_with pam pam-dir $(getpam_mod_dir)) \
+ $(use_enable selinux) \
+ $(use_enable ssh-agent) \
+ $(use_with systemd) \
+ $(use_enable valgrind) \
+ --enable-doc
+}
+
+src_test() {
+ # Needs dbus-run-session to not get:
+ # ERROR: test-dbus-search process failed: -6
+ "${BROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/schema" || die
+ GSETTINGS_SCHEMA_DIR="${S}/schema" virtx dbus-run-session emake check
+}
+
+pkg_postinst() {
+ # cap_ipc_lock only needed if building --with-libcap-ng, but that breaks with glib-2.70
+ # Never install as suid root, this breaks dbus activation, see bug #513870
+ gnome2_pkg_postinst
+
+ if ! [[ $(eselect pinentry show | grep "pinentry-gnome3") ]] ; then
+ ewarn "Please select pinentry-gnome3 as default pinentry provider:"
+ ewarn " # eselect pinentry set pinentry-gnome3"
+ fi
+}
diff --git a/gnome-base/gnome-shell/Manifest b/gnome-base/gnome-shell/Manifest
index 1d05dfd70e35..cdce56197862 100644
--- a/gnome-base/gnome-shell/Manifest
+++ b/gnome-base/gnome-shell/Manifest
@@ -1,3 +1,4 @@
+AUX 37e49e8a22c223b030297f9607bdb748c219e060.patch 1613 BLAKE2B 5e9b6206c720bdf6e60c0e89225e094fdda56e6977c78ac8dc694796a3a80ba752461a0288905313aed01b1d7839e53ac9ecf8ca8e7586d317013667f344ee36 SHA512 770c05f6a7de722806508bfdf5637dd87c1f982ed2593b69c45c928e656e2c566857e2433762879922579e643487a25720ef22a0250e0711cf52c8cf6c65f48a
AUX 40.0-defaults.patch 1412 BLAKE2B e36f7215cf756586479b8bdc71339beb3bbde53ca9745ddc4ef1c3feb59c720e4920e8aa4aadd7912874c386e7495a4b5d554e0d0616db17a81c4ec52a2baa6b SHA512 d82cf1e329d5974755738e29e6366bb10452620021a5db6c2ec63c4ee38e87a65dada34d57026e9510dbffa78c7060ae6f2ccec1739e3026bb0c67dab95f94a9
DIST gnome-shell-45.2.tar.xz 2017124 BLAKE2B b1ee0ecb7babadad1b9abed3c9bb2fda4c47e5bff080cfd92db35530b211449a9e3c8db0f63ccf87ae9df05337b9a69546b880c71d7a4a1fca08b773490bbce1 SHA512 d88cb7e385f69416863a5b1299fdd18f228a6f951ee084e0ae79ed668c856e50f19c537d7b40eaf93b9166fa5ef7797b9babc3b8d4f80941e15d53d862734aec
DIST gnome-shell-45.4.tar.xz 2016708 BLAKE2B 1bbc4bc0d5652a3c9332a2f072437919c2cdb3fdf546913d00b65d5806bd7c7f7d7e8f0886fba1b8a6a776598b358882f6285c55f68ec217eb5ac378b73580a3 SHA512 127031302c4f606353292ab2ca2ab7b4c1000eba11bccd30cefb6a0c4a316aac1203d021d713716ad6036e4519700001d564545978f83b1e24668b166dcd66ba
@@ -6,5 +7,5 @@ DIST gnome-shell-45.6.tar.xz 2016488 BLAKE2B 6590c160eabae21e1f5a79787113d02950d
EBUILD gnome-shell-45.2.ebuild 6622 BLAKE2B 873d703c22fa68390f381c29c86cbc87677b76ef52521e108fb41abf4bd084e19d548734469dcd39f23d6e7a7d3245cd83efa05702ca514994e581bd79a3433e SHA512 e4d05f4d3fdecb80aef9b0de8c080b880ee5bb470681ba52d4400de14dd585ffa5b839b0f585dfe8de452d8801f7b6899e4ee0f155d38913b069c3b235f1a23b
EBUILD gnome-shell-45.4.ebuild 6625 BLAKE2B b16115afe5ffe2e1640f13d974766e7101b8853622f77b1347676edd7c32d6610a0532b0b71fbbcf005c0ea3ec4bd519152555aafaab17a8afe66fb99be63119 SHA512 a2a1eff30bda467692758622d6cdce2ddabafec704de82d4f645c97d9c49043218ccca08486bf96e4606717859156d1b8ade02542f70e1ad3cd3c27dbe3a34e2
EBUILD gnome-shell-45.5.ebuild 6622 BLAKE2B 873d703c22fa68390f381c29c86cbc87677b76ef52521e108fb41abf4bd084e19d548734469dcd39f23d6e7a7d3245cd83efa05702ca514994e581bd79a3433e SHA512 e4d05f4d3fdecb80aef9b0de8c080b880ee5bb470681ba52d4400de14dd585ffa5b839b0f585dfe8de452d8801f7b6899e4ee0f155d38913b069c3b235f1a23b
-EBUILD gnome-shell-45.6.ebuild 6625 BLAKE2B b16115afe5ffe2e1640f13d974766e7101b8853622f77b1347676edd7c32d6610a0532b0b71fbbcf005c0ea3ec4bd519152555aafaab17a8afe66fb99be63119 SHA512 a2a1eff30bda467692758622d6cdce2ddabafec704de82d4f645c97d9c49043218ccca08486bf96e4606717859156d1b8ade02542f70e1ad3cd3c27dbe3a34e2
+EBUILD gnome-shell-45.6-r1.ebuild 6751 BLAKE2B c7204282b146c14511c90c9b2ff6af1ef9484b6514d1b9b22781d671a45e86e9082e31bdd8662859009863934620b7a2b2a2bc07e6ed100944c8750c16028d50 SHA512 50411bfb7f968ae18ad06e3a4a22d5a6d05ab1670d2660117db873ddf0bc2c2583e14692cba7640386375f590c80ae4d3c583e7ddaca939fb1ae967ce67fc5ab
MISC metadata.xml 1032 BLAKE2B 2089aace6c8db78bc28c445d9eac949fcea533a9abc26b05430d5e4a11a7bd57ffd00cb8b2edefdd3aa0c0f46e56e573e8f2f544b9e205685877fba957a29de0 SHA512 44e5d05ff803a3fdffe9ad9942da3197150da07e6097f0f92ab9f6b8209b6337149da0a4c535950c879e3184615b2d68a866c1a34d7f2ecdb69810dd5ba0fbd9
diff --git a/gnome-base/gnome-shell/files/37e49e8a22c223b030297f9607bdb748c219e060.patch b/gnome-base/gnome-shell/files/37e49e8a22c223b030297f9607bdb748c219e060.patch
new file mode 100644
index 000000000000..d56db89bbacd
--- /dev/null
+++ b/gnome-base/gnome-shell/files/37e49e8a22c223b030297f9607bdb748c219e060.patch
@@ -0,0 +1,42 @@
+From 37e49e8a22c223b030297f9607bdb748c219e060 Mon Sep 17 00:00:00 2001
+From: Philip Withnall <pwithnall@gnome.org>
+Date: Tue, 28 May 2024 18:08:27 +0100
+Subject: [PATCH] shell-camera-monitor: Fix warning about strict aliasing
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Changing type when casting a double pointer is not strictly allowed in
+C. In order to fix compilation with `-fstrict-aliasing`, don’t use
+`g_clear_pointer()` for clearing this pointer where the type expected by
+the destroy notify function does not match the type stored in the
+`ShellCameraMonitor` struct.
+
+This introduces no functional changes.
+
+Signed-off-by: Philip Withnall <pwithnall@gnome.org>
+Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell/-/merge_requests/3351>
+---
+ src/shell-camera-monitor.c | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/src/shell-camera-monitor.c b/src/shell-camera-monitor.c
+index 1e2e0f14569..b2e6e0b2af2 100644
+--- a/src/shell-camera-monitor.c
++++ b/src/shell-camera-monitor.c
+@@ -298,7 +298,11 @@ shell_camera_monitor_disconnect_core (ShellCameraMonitor *monitor)
+ g_clear_handle_id (&monitor->delayed_disable_id, g_source_remove);
+
+ spa_hook_remove (&monitor->registry_listener);
+- g_clear_pointer ((struct pw_proxy**) &monitor->registry, pw_proxy_destroy);
++ if (monitor->registry != NULL)
++ {
++ pw_proxy_destroy ((struct pw_proxy *) monitor->registry);
++ monitor->registry = NULL;
++ }
+ spa_hook_remove (&monitor->core_listener);
+ g_clear_pointer (&monitor->core, pw_core_disconnect);
+ }
+--
+GitLab
+
diff --git a/gnome-base/gnome-shell/gnome-shell-45.6.ebuild b/gnome-base/gnome-shell/gnome-shell-45.6-r1.ebuild
index 92b6670d0970..c9c3acd73caa 100644
--- a/gnome-base/gnome-shell/gnome-shell-45.6.ebuild
+++ b/gnome-base/gnome-shell/gnome-shell-45.6-r1.ebuild
@@ -134,6 +134,8 @@ BDEPEND="
PATCHES=(
# Change favorites defaults, bug #479918
"${FILESDIR}"/40.0-defaults.patch
+ # backport fix for strict-aliasing violation with USE=pipewire
+ "${FILESDIR}"/37e49e8a22c223b030297f9607bdb748c219e060.patch
)
src_prepare() {
diff --git a/gnome-base/gsettings-desktop-schemas/Manifest b/gnome-base/gsettings-desktop-schemas/Manifest
index 0b8cea43c19f..513ac5d9d58b 100644
--- a/gnome-base/gsettings-desktop-schemas/Manifest
+++ b/gnome-base/gsettings-desktop-schemas/Manifest
@@ -1,4 +1,6 @@
AUX 3.32.0-default-fonts.patch 1386 BLAKE2B 7d1c4a8279b9b8ca752804ea45efed9b61ec9844843793dc568e3012d3cd80c7a5f7a921e8dcc42406c6e15010fa472edf9cb10b7c86d1f8f69da2f6a3a034b7 SHA512 190129064554a36b56ba308f8dd75a9b8ee5ccfadffc0b5d528b5ba70324bcb3436acab116ad7768f59d316c3c2bd85dad9e8147050cb475b21fce439cb92705
DIST gsettings-desktop-schemas-45.0.tar.xz 750056 BLAKE2B b65c846654fac5a104ad9a7d67546c6fb3d54aada178d58c575d22a8c2adc0057c1f1dc177562740f7ae94d0e17743789ca902db7c2fcc42c844bb66e401eaec SHA512 b3e00164aa47cf19b53bf8fd9cd9526c0a4f3d770e8c77953dba0bdf49b85d56f87f45254d18260e7a7b0ec7e24fc049fde503a1ea93e87946dbbd53b5dfc0f2
+DIST gsettings-desktop-schemas-46.0.tar.xz 767460 BLAKE2B 537b37640c17aa8338e2bb520fb1a8184c74a5cb28d6b7d9fa35393c0a76a4a144f6518b58546393c39a9f57889bcb99decc0e9bfbf4a1969c44ecf89462c4ee SHA512 04d43ce3885741afdda2d971ef61332474a114e2b7f82d28e5fb7c831992f95359e3edb1bf60f39d29b5ad509a77d65b76d482c9659cbdd1f7bb1e07c86da912
EBUILD gsettings-desktop-schemas-45.0.ebuild 982 BLAKE2B 2b75b5f5ab711932af31986ec49cd25d8c4e477265ca4a017abb697425a288aa63429a77ee6dd8540dedb043cf0fa5eed73c4a4594e71ef070c24edc56e7fad1 SHA512 d180cfbb34a0a696e0f3d0f89662de1e44c9b61317f1d342fa5357dcfed0b78b8775abb7d682e95ef9f8adf78178a1e56cca8270e7bafa912f4bda4f36882b5c
+EBUILD gsettings-desktop-schemas-46.0.ebuild 990 BLAKE2B b2eeba90e1b7211cc37f8d338f2b72b6ba36f43ee72a7cdd601d3ddd698ac8466b580d7622644700930b6c62996012a94d81d4a75fd8f613cafb78519074f186 SHA512 1c3bd155caf447a1b9fe549dff0acbfe07d77e62e83fd99498c393386966b6ef6712d67ce1b9738aea238681ae5fbf57d4abab23fd960a8baa37de3c239c1cf3
MISC metadata.xml 391 BLAKE2B 8f62d3c558dcf5523f03d85268b9c5b08654c8c4405194596a4a040aeccd42766a969aeae050850bc823b2c6e4f357e862bf5771f52d4979cf01deefc19bc2a5 SHA512 95ed4eb3d13cd1437648c5923f0b21cefd2f40c53b64f8baf56bc673383c6d0048910a3e4782a36f0fec715f2f23bba90de04693ef0ed657019c616bfb018b90
diff --git a/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-46.0.ebuild b/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-46.0.ebuild
new file mode 100644
index 000000000000..5911315d0ebf
--- /dev/null
+++ b/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-46.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Collection of GSettings schemas for GNOME desktop"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+introspection"
+
+BDEPEND="
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Revert change to 'Source Code Pro 10' and 'Cantarell 11' fonts back to generic sans and monospace aliases
+ "${FILESDIR}"/3.32.0-default-fonts.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}