summaryrefslogtreecommitdiff
path: root/gnome-base/libgnomekbd/libgnomekbd-3.22.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/libgnomekbd/libgnomekbd-3.22.0.1.ebuild')
-rw-r--r--gnome-base/libgnomekbd/libgnomekbd-3.22.0.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnome-base/libgnomekbd/libgnomekbd-3.22.0.1.ebuild b/gnome-base/libgnomekbd/libgnomekbd-3.22.0.1.ebuild
new file mode 100644
index 000000000000..afe2aff53cac
--- /dev/null
+++ b/gnome-base/libgnomekbd/libgnomekbd-3.22.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2
+
+DESCRIPTION="Gnome keyboard configuration library"
+HOMEPAGE="https://www.gnome.org"
+
+LICENSE="LGPL-2+"
+SLOT="0/8"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sh ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="+introspection test"
+
+RDEPEND="
+ >=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.91.7:3[X,introspection?]
+ >=x11-libs/libxklavier-5.2[introspection?]
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable test tests)
+}