summaryrefslogtreecommitdiff
path: root/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-40.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-40.0.ebuild')
-rw-r--r--gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-40.0.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-40.0.ebuild b/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-40.0.ebuild
index 02aa7efa2db7..32ded1713c2d 100644
--- a/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-40.0.ebuild
+++ b/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-40.0.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit gnome.org gnome2-utils meson xdg
+
+PYTHON_COMPAT=(python3_{6..9})
+inherit gnome.org gnome2-utils meson python-any-r1 xdg
DESCRIPTION="Collection of GSettings schemas for GNOME desktop"
HOMEPAGE="https://git.gnome.org/browse/gsettings-desktop-schemas"
@@ -17,6 +19,7 @@ BDEPEND="
dev-util/glib-utils
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
+ ${PYTHON_DEPS}
"
PATCHES=(
@@ -24,6 +27,12 @@ PATCHES=(
"${FILESDIR}"/3.32.0-default-fonts.patch
)
+src_prepare() {
+ default
+
+ python_fix_shebang build-aux/meson/post-install.py
+}
+
src_configure() {
meson_src_configure $(meson_use introspection)
}