summaryrefslogtreecommitdiff
path: root/gnome-base/gnome-settings-daemon
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/gnome-settings-daemon')
-rw-r--r--gnome-base/gnome-settings-daemon/Manifest2
-rw-r--r--gnome-base/gnome-settings-daemon/gnome-settings-daemon-45.1.ebuild140
2 files changed, 142 insertions, 0 deletions
diff --git a/gnome-base/gnome-settings-daemon/Manifest b/gnome-base/gnome-settings-daemon/Manifest
index 9e8d76de4087..93fd5d7c7e44 100644
--- a/gnome-base/gnome-settings-daemon/Manifest
+++ b/gnome-base/gnome-settings-daemon/Manifest
@@ -2,5 +2,7 @@ AUX 42.1-build-Make-wacom-optional-and-controllable-via-meson.patch 1759 BLAKE2B
AUX gnome-settings-daemon-3.38.1-build-Allow-NM-optional-on-Linux.patch 694 BLAKE2B e4f32a376c2b1c55a396504e98c8a69d512bb9161a854482aa877023a2761e59d3fc682d724398ffb53bc138b010c33276071359d42ac19bcac2d9af87d42eef SHA512 618ad312b54709d0f95e5d881c2896c156246ae41eee1925f76b0a398b7ce6815a7466f8587f2291b07f7a34d1a3e1afb7df33823d9b52ebe8ad46a3f5f1e84d
AUX org.gnome.settings-daemon.plugins.power.gschema.override 75 BLAKE2B 1c80bbb15e998de9f5fddc956dab862552ecc3734083391f124ef577dd2efb70e29efd230511cca83536dcd8c32118ecebcfe52b2927d6f0094540ec73a6ae23 SHA512 9c4b1e1b63b1a6d97eed962969704accca2fc53763a4b7806e2a3e4ff49ecc7d4a0d7f8253ff2e33d83e766908d852721ffa33f363aed7d04c20002bfdee173b
DIST gnome-settings-daemon-45.0.tar.xz 1465016 BLAKE2B a8a2dcc64d8647d3c5986886b3fccb0f39943be33603f595d990234868d112439d4010306eae7dd1acb76cdb86029cc2fd3a6f23602ddfa58da434ec5ec32cf0 SHA512 d74c01355164ea541ff3973042e8a2182f4be0b9401e4bfa483e5c9e6e20006088dac543789ef1ee56f6026822f450df1f5dfcafa1c74615040b1cb00ed7949e
+DIST gnome-settings-daemon-45.1.tar.xz 1473256 BLAKE2B 25c114cc1918975247db360f24a9041d019546dd0a0714d19f2409b78ee6e2712d6dc1272eb9a40afb7ed4e973eaa45854322947567b5d54d2761b48a2e812b9 SHA512 ccec193f3f2acdfb5eefda697d6ef2ac0edca18e85d934a83cc34fd5af6c78c56469ffeebbd1c64e8c392462686663c2dd55000bc962beac472580fdfa0717a8
EBUILD gnome-settings-daemon-45.0.ebuild 3439 BLAKE2B 94921cdd9b911123dc130cc698265a82e3d3b732e6b2be86418289a52523e46998e0e91c86f043c4f30dcbad72b2ac7e9e5a38723ffd215a812b69cbc665a1eb SHA512 66cf9c171e87db2277c487212030e9ecd4e77234d744a2176d7e07d80d84dbba9e579bde8e51f7302f9e43bc28fe20a889d22f108e07f58a4c046bc6f9c863b7
+EBUILD gnome-settings-daemon-45.1.ebuild 3442 BLAKE2B 4a5d0b3bea868c6c8f59a74f97f89fb9d2c5f8a847e9009594ec576242c381ec609deaf66d15718e40b8670ad5c9d1780445cf9beb45336c3905aa8ab6d8d645 SHA512 0a0e1ccac29ad58d012d576ca6a1237768536207269fe6a6525bb6093091d22d309bb56e044f9c2e7453ca3e5b836fc51d416cc68d6988c4f1a6dc04512e9796
MISC metadata.xml 663 BLAKE2B 27a0e4135576aeea4c6b962c90d894df06f92b3b015fab78246724ce7ca2f985cfde730f1f9c91f0cc01733f274c0225816e24fac2fca40c585b1a8667fd7d4d SHA512 e21c9dc181f13228662a2a91d7d8e0fedc6270f818a79308e270c9de788011379c155e835534ebb5dbd5f3b07a9e83ec618d9d85f81f46784007b380c6a7ef18
diff --git a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-45.1.ebuild b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-45.1.ebuild
new file mode 100644
index 000000000000..d9cd4bff5b8f
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-45.1.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit gnome.org gnome2-utils python-any-r1 meson udev virtualx xdg
+
+DESCRIPTION="Gnome Settings Daemon"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-settings-daemon"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="+colord +cups debug elogind input_devices_wacom modemmanager networkmanager smartcard systemd test wayland"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="^^ ( elogind systemd )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+COMMON_DEPEND="
+ >=sci-geosciences/geocode-glib-3.10:2
+ >=dev-libs/glib-2.58:2
+ >=gnome-base/gnome-desktop-3.37.1:3=
+ >=gnome-base/gsettings-desktop-schemas-42
+ >=x11-libs/gtk+-3.15.3:3[X,wayland?]
+ >=dev-libs/libgweather-4.2.0:4=
+ colord? ( >=x11-misc/colord-1.4.5:= )
+ media-libs/libcanberra[gtk3]
+ >=app-misc/geoclue-2.3.1:2.0
+ >=x11-libs/libnotify-0.7.3
+ >=media-libs/libpulse-16.1[glib]
+ >=sys-auth/polkit-0.114
+ >=sys-power/upower-0.99.12:=
+ x11-libs/libX11
+ >=x11-libs/libXfixes-6.0.0
+ dev-libs/libgudev:=
+ wayland? ( dev-libs/wayland )
+ input_devices_wacom? (
+ >=dev-libs/libwacom-0.7:=
+ >=x11-libs/pango-1.20.0
+ x11-libs/gdk-pixbuf:2
+ )
+ smartcard? ( app-crypt/gcr:4= )
+ cups? ( >=net-print/cups-1.4[dbus] )
+ modemmanager? (
+ >=app-crypt/gcr-3.90.0:4=
+ >=net-misc/modemmanager-1.0:=
+ )
+ networkmanager? ( >=net-misc/networkmanager-1.0 )
+ media-libs/alsa-lib
+ x11-libs/libXi
+ x11-libs/libXext
+ media-libs/fontconfig
+ systemd? (
+ >=sys-apps/systemd-243
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
+# logind needed for power and session management, bug #464944
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/dconf
+ elogind? ( sys-auth/elogind )
+"
+# rfkill requires linux/rfkill.h, thus linux-headers dep, not os-headers.
+# If this package wants to work on other kernels, we need to make rfkill conditional instead
+BDEPEND="
+ sys-kernel/linux-headers
+ dev-util/glib-utils
+ dev-util/gdbus-codegen
+ ${PYTHON_DEPS}
+ test? (
+ dev-util/umockdev
+ $(python_gen_any_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-dbusmock[${PYTHON_USEDEP}]
+ ')
+ gnome-base/gnome-session
+ )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/42.1-build-Make-wacom-optional-and-controllable-via-meson.patch
+ "${FILESDIR}"/${PN}-3.38.1-build-Allow-NM-optional-on-Linux.patch
+)
+
+python_check_deps() {
+ if use test; then
+ python_has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]" &&
+ python_has_version "dev-python/python-dbusmock[${PYTHON_USEDEP}]"
+ fi
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dudev_dir="$(get_udevdir)"
+ $(meson_use systemd)
+ -Dalsa=true
+ -Dgudev=true
+ -Dgcr3=false
+ $(meson_use colord)
+ $(meson_use cups)
+ $(meson_use networkmanager network_manager)
+ -Drfkill=true
+ $(meson_use smartcard)
+ $(meson_use input_devices_wacom wacom)
+ $(meson_use wayland)
+ $(meson_use modemmanager wwan)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ # Don't auto-suspend by default on AC power
+ insinto /usr/share/glib-2.0/schemas
+ doins "${FILESDIR}"/org.gnome.settings-daemon.plugins.power.gschema.override
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ udev_reload
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ udev_reload
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}