summaryrefslogtreecommitdiff
path: root/gnome-base/gnome-menus/gnome-menus-3.36.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/gnome-menus/gnome-menus-3.36.0.ebuild')
-rw-r--r--gnome-base/gnome-menus/gnome-menus-3.36.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnome-base/gnome-menus/gnome-menus-3.36.0.ebuild b/gnome-base/gnome-menus/gnome-menus-3.36.0.ebuild
new file mode 100644
index 000000000000..ad1ecffb8521
--- /dev/null
+++ b/gnome-base/gnome-menus/gnome-menus-3.36.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit gnome2
+
+DESCRIPTION="Library and layout configuration for the Desktop Menu fd.o specification"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-menus"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+
+IUSE="+introspection test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.29.15:2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+ test? ( dev-libs/gjs )
+"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+src_configure() {
+ # Do NOT compile with --disable-debug/--enable-debug=no
+ # It disables api usage checks
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --disable-static
+}