summaryrefslogtreecommitdiff
path: root/gnome-base/gnome-light
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/gnome-light')
-rw-r--r--gnome-base/gnome-light/Manifest1
-rw-r--r--gnome-base/gnome-light/gnome-light-45.2.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/gnome-base/gnome-light/Manifest b/gnome-base/gnome-light/Manifest
index 05867e87a9e5..ce110876b133 100644
--- a/gnome-base/gnome-light/Manifest
+++ b/gnome-base/gnome-light/Manifest
@@ -1,2 +1,3 @@
EBUILD gnome-light-44.4.ebuild 1740 BLAKE2B cb317659c9d46b804d3b2bc2dcc09374966b3dc08bd405fe6fe1b63c447131961f0c6ca7dd6b124948327945db49cd443f542ab21d6d87f1fdb72c95bce410eb SHA512 07be80d0d44f3445b402806d189a8f32891b5b774debb69ae39a3ec6feab1462d92f8fa9de1f7f149496726f07d6fe245551ed4e6f28d0231010b74a0d6124ae
+EBUILD gnome-light-45.2.ebuild 1733 BLAKE2B 6e4ef060df4925a8fd11bbcd0b9ab5b96cceceb056173a1fb68ebdb6a7e2024e9ca6c6f7521086147e48f5dab13f3988e35be71091568f1d65022e613dfe48c8 SHA512 d82225cb7e13da4c950b66570bb573940cd2ae4310d26db798059d7c489d556863586559d9f8cc4ebb528647cd7fb3a291d2f21321966930d813669ec113ec23
MISC metadata.xml 407 BLAKE2B 62f87af3f022751106d2c050ebc1b3ff90d7b0751f354679e8704eb5be3294b3cf1c393c6f1197b3b0c050db7c94124cb21475dd6a07734e0337b85a2c12d62f SHA512 6b3b9d3f87eb94ecdd5abb91f2f1db17914be314faa8c15307c66646feee1ca091daa82d0e5f632f38eccd8d13245c522381a6ba8f366a373588dfc1ac003a0e
diff --git a/gnome-base/gnome-light/gnome-light-45.2.ebuild b/gnome-base/gnome-light/gnome-light-45.2.ebuild
new file mode 100644
index 000000000000..2a3293adda2e
--- /dev/null
+++ b/gnome-base/gnome-light/gnome-light-45.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+P_RELEASE="$(ver_cut 1).0"
+
+DESCRIPTION="Meta package for GNOME-Light, merge this package to install"
+HOMEPAGE="https://www.gnome.org/"
+LICENSE="metapackage"
+SLOT="2.0"
+IUSE="cups +gnome-shell"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+# XXX: Note to developers:
+# This is a wrapper for the 'light' GNOME 3 desktop, and should only consist of
+# the bare minimum of libs/apps needed. It is basically gnome-base/gnome without
+# any apps, but shouldn't be used by users unless they know what they are doing.
+# cantarell minimum version is ensured here as gnome-shell depends on it.
+RDEPEND="
+ >=gnome-base/gnome-core-libs-${PV}[cups?]
+
+ >=gnome-base/gnome-session-45.0
+ >=gnome-base/gnome-settings-daemon-45.0[cups?]
+ >=gnome-base/gnome-control-center-45.1[cups?]
+
+ >=gnome-base/nautilus-45.2
+
+ gnome-shell? (
+ >=x11-wm/mutter-45.2
+ >=dev-libs/gjs-1.78.1
+ >=gnome-base/gnome-shell-45.2
+ >=media-fonts/cantarell-0.303.1
+ )
+
+ >=x11-themes/adwaita-icon-theme-${P_RELEASE}
+ >=x11-themes/gnome-backgrounds-${P_RELEASE}
+
+ || (
+ >=x11-terms/gnome-terminal-3.50.1
+ >=gui-apps/gnome-console-45.0
+ )
+"
+DEPEND=""
+PDEPEND=">=gnome-base/gvfs-1.52.1"
+BDEPEND=""
+S="${WORKDIR}"
+
+pkg_pretend() {
+ if ! use gnome-shell; then
+ # Users probably want to use gnome-flashback, e16, sawfish, etc
+ ewarn "You're not installing GNOME Shell"
+ ewarn "You will have to install and manage a window manager by yourself"
+ fi
+}
+
+pkg_postinst() {
+ # Remember people where to find our project information
+ elog "Please remember to look at https://wiki.gentoo.org/wiki/Project:GNOME"
+ elog "for information about the project and documentation."
+}