summaryrefslogtreecommitdiff
path: root/games-util
diff options
context:
space:
mode:
Diffstat (limited to 'games-util')
-rw-r--r--games-util/Manifest.gzbin7039 -> 7209 bytes
-rw-r--r--games-util/springlobby/Manifest3
-rw-r--r--games-util/springlobby/metadata.xml26
-rw-r--r--games-util/springlobby/springlobby-0.264.ebuild54
-rw-r--r--games-util/xboxdrv/Manifest2
-rw-r--r--games-util/xboxdrv/xboxdrv-0.8.8.ebuild6
6 files changed, 87 insertions, 4 deletions
diff --git a/games-util/Manifest.gz b/games-util/Manifest.gz
index d155bf902317..ee2e75a6955c 100644
--- a/games-util/Manifest.gz
+++ b/games-util/Manifest.gz
Binary files differ
diff --git a/games-util/springlobby/Manifest b/games-util/springlobby/Manifest
new file mode 100644
index 000000000000..6336cd6381b3
--- /dev/null
+++ b/games-util/springlobby/Manifest
@@ -0,0 +1,3 @@
+DIST springlobby-0.264.tar.bz2 2626180 BLAKE2B 01ff51703c3c10c1aaeb342d2644012a6037b1271ba7e36ab7663cde7646d1c9c6bd823fe65c91a8a9e754bbcf1000ce486eeab2d1641c64fad08773c491f9a6 SHA512 f8024a98be7d6ea755c4380494415813084aadb6dcf72ed0aaeba0ddf9fbaf992ccd5455713c807c0d6feb7db606068be62d4bb2cfcb4697f0406a2ec4f404eb
+EBUILD springlobby-0.264.ebuild 1071 BLAKE2B 0e04cf3827794b354dabf9708ffe96f4de7b73bc06340429b048c794ba65d4647a3368d911eed2f277c754431a68949e6a6cb8833f6d5f64a3947d058d5c137c SHA512 88c5161c566ad511db04ea36253fa46facc06731611addc385ed8c8fd906a4456f33ad3996086aae39ce8f66ad907324c602d5d1189226375be62e64cdc80794
+MISC metadata.xml 1168 BLAKE2B 52a394c332bed809d549cf76a750a35cb0c0bcb6af1cf2276d81958abafa6272e58d59d07762929ef05ccece16d5465d5c353dd71974b4ec2657ae99e3d607a5 SHA512 901e3865f60e798625d59085e38e191a256819e5aa0778210190ebc0a08f183b263c3391409079c499a2e2cb6740503371642f0c13eec1e59a8699060c00b59c
diff --git a/games-util/springlobby/metadata.xml b/games-util/springlobby/metadata.xml
new file mode 100644
index 000000000000..eabc7ba13bca
--- /dev/null
+++ b/games-util/springlobby/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+The official lobby client for SpringRTS community games: Balanced Annihilation; Journeywar; Metal Factions; Spring:1944 World War II; Star Wars: Imperial Winter; Tech Annihilation; The Cursed; Evolution RTS; ...
+ </longdescription>
+ <longdescription lang="fr">
+Le client officiel du lobby pour les jeux de la communauté SpringRTS : Balanced Annihilation; Journeywar; Metal Factions; Spring:1944 World War II; Star Wars: Imperial Winter; Tech Annihilation; The Cursed; Evolution RTS; ...
+ </longdescription>
+ <maintainer type="person">
+ <email>totocoq@yahoo.fr</email>
+ <name>Thomas Coquelin</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>fedja@protonmail.ch</email>
+ <name>Fedja Beader</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">springlobby/springlobby</remote-id>
+ <bugs-to>https://github.com/springlobby/springlobby/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/games-util/springlobby/springlobby-0.264.ebuild b/games-util/springlobby/springlobby-0.264.ebuild
new file mode 100644
index 000000000000..510738cb07bd
--- /dev/null
+++ b/games-util/springlobby/springlobby-0.264.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WX_GTK_VER="3.0"
+inherit cmake-utils gnome2-utils wxwidgets
+
+DESCRIPTION="The official lobby client for SpringRTS community games"
+HOMEPAGE="https://springlobby.info"
+SRC_URI="https://www.springlobby.info/tarballs/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +libnotify +nls +sound"
+
+RDEPEND="
+ >=dev-libs/boost-1.35:=
+ dev-libs/openssl:=
+ sound? ( media-libs/alure
+ media-libs/openal
+ )
+ net-misc/curl
+ sys-libs/zlib[minizip]
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXext
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ libnotify? ( x11-libs/libnotify )
+"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ setup-wxwidgets
+ local mycmakeargs=(
+ -DOPTION_NOTIFY=$(usex libnotify)
+ -DOPTION_SOUND=$(usex sound)
+ -DOPTION_TRANSLATION_SUPPORT=$(usex nls)
+ -DAUX_VERSION="(Gentoo,${ARCH})"
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-util/xboxdrv/Manifest b/games-util/xboxdrv/Manifest
index c2e45fc01a5e..e28e31338358 100644
--- a/games-util/xboxdrv/Manifest
+++ b/games-util/xboxdrv/Manifest
@@ -7,5 +7,5 @@ AUX xboxdrv.initd 446 BLAKE2B f78cf4af5cca703efc0a480c2ba34b0189d2b86a64aa89533e
AUX xboxdrv.service 371 BLAKE2B afd5f5397f4ae15af69d8e12865201fe159691ba2a36c00fe207304afe5126814fafd0394e7618e9f4d27611bd2c0dd7371717c7a07a57d27c3a4ab8e6e40140 SHA512 80e7657edae9c771740628ef5f9752b79d50288ead33afe97e71ffc6e7d7c24343eeb213668cdc823b28742976e2e56f4defdcd823716897f3262be1fc7832e9
AUX xboxdrv.udev-rules 225 BLAKE2B 0f027c332b58d7ec3c289d23192355dae8d44f50c7cbf9de42a2023a2db6c29943fc7eecc85a0e802f5925ffdfc145584909140df8c030a120fe3da79c91641e SHA512 eb9e535bb18077e4c61db8fa5020a779b856a6df29eb4daa72a2ab9675720f809a981b0e4706fbbc6bf5a368cc162c7151cd6ae10399d091f10d2f75b1c48a3e
DIST xboxdrv-linux-0.8.8.tar.bz2 267919 BLAKE2B b6f09fc929ba561f0c18a777ca94f6972f366d29709d5fdcb168988311ca53eb813761df0f87d148795aa14d2d89b200e8123502c0b255ebe20e5f9caa18f8f1 SHA512 2978b33d23636431ee0cc393ea32d3d26ebe9f2b914f0bf8bc0e096f98202726768142e653bc5765ac55084b105ff3a6214bdf6e745fdd8aa167260c54c10494
-EBUILD xboxdrv-0.8.8.ebuild 1403 BLAKE2B ebf0642981fdd38501cd8e91f5a2c34552cec462e1b0ebdfa7b210f6a688c98a4b13a7cdfa966b6094d23877ffd2ee4a70713e1dd01242c41620202b9c2a336f SHA512 058783f713c46db2f6c4e86506104ef71c63a2eed6218ff585361616ff05a2b759d5ca20266e7d9bf54949da6e60c0ef582884f77dbb5958c29a553466c0bf2d
+EBUILD xboxdrv-0.8.8.ebuild 1405 BLAKE2B 5636721b89c91b62ac51695148920a0cd1641e5a8f847225a627dc71009a7480fbb02fa884ca590a1f375aca820fe3d3266c814afd1723717cf0b486b8eeffc2 SHA512 f91abd7d9370f4d2e6c79ed38da4eb93592e672dbe0ed2eac377da6fb927ed83e8ffb6eecff29a45926258950ea4da52f53bf619deb9ebedbb383495ca9b5e1a
MISC metadata.xml 252 BLAKE2B 1b951d2e730631865ae5f379b19ed9de2c8adf2f2786da3f75d0871d967374198ddd9106433f388bdc7050c37063fb28cda4320ae7bdc9a03854838693d9f952 SHA512 90798aff93ec7e3881b882e7b10bb1680e8cb7d82b0ef4280e562ab0c9e8a2daba8afe57333dc64697322267a4b651c00ee9b4fdeb56278ff70c073da7b91638
diff --git a/games-util/xboxdrv/xboxdrv-0.8.8.ebuild b/games-util/xboxdrv/xboxdrv-0.8.8.ebuild
index ba30a6e34184..a9324ad2dffe 100644
--- a/games-util/xboxdrv/xboxdrv-0.8.8.ebuild
+++ b/games-util/xboxdrv/xboxdrv-0.8.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,8 +6,8 @@ inherit linux-info scons-utils toolchain-funcs systemd udev
MY_P=${PN}-linux-${PV}
DESCRIPTION="Userspace Xbox 360 Controller driver"
-HOMEPAGE="http://pingus.seul.org/~grumbel/xboxdrv/"
-SRC_URI="http://pingus.seul.org/~grumbel/xboxdrv/${MY_P}.tar.bz2"
+HOMEPAGE="https://pingus.seul.org/~grumbel/xboxdrv/"
+SRC_URI="https://pingus.seul.org/~grumbel/xboxdrv/${MY_P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"