summaryrefslogtreecommitdiff
path: root/games-util
diff options
context:
space:
mode:
Diffstat (limited to 'games-util')
-rw-r--r--games-util/Manifest.gzbin7731 -> 7729 bytes
-rw-r--r--games-util/deutex/Manifest2
-rw-r--r--games-util/deutex/deutex-5.2.2.ebuild25
-rw-r--r--games-util/linux-wbfs-manager/Manifest4
-rw-r--r--games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild11
-rw-r--r--games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild11
-rw-r--r--games-util/lutris/Manifest8
-rw-r--r--games-util/lutris/lutris-0.5.7.1.ebuild5
-rw-r--r--games-util/lutris/lutris-0.5.8.1.ebuild6
-rw-r--r--games-util/lutris/lutris-0.5.8.ebuild6
-rw-r--r--games-util/lutris/lutris-9999.ebuild6
-rw-r--r--games-util/xboxdrv/Manifest4
-rw-r--r--games-util/xboxdrv/metadata.xml20
-rw-r--r--games-util/xboxdrv/xboxdrv-0.8.8_p20190118.ebuild9
14 files changed, 75 insertions, 42 deletions
diff --git a/games-util/Manifest.gz b/games-util/Manifest.gz
index 71da43b1279e..4e13bb7e7642 100644
--- a/games-util/Manifest.gz
+++ b/games-util/Manifest.gz
Binary files differ
diff --git a/games-util/deutex/Manifest b/games-util/deutex/Manifest
index 20988ae67531..3303f9107e45 100644
--- a/games-util/deutex/Manifest
+++ b/games-util/deutex/Manifest
@@ -1,3 +1,5 @@
DIST deutex-5.2.0.tar.xz 165772 BLAKE2B 4451e6abc13d3d6e9176a5d8aad6a5d3d986b2b280b2094d89876ec9bea68db5aa9179f8d650932499a2f8853fb57644f723e4214f5a973f217ef34e236e57a9 SHA512 5baa3e06e8562e36e9e520a52a7b4407277e7741deb543eb7b68587a9aab3f409c574415654e8a1ef15d2afb7750aa603189f8de749353666295c6a292b92a33
+DIST deutex-5.2.2.tar.zst 172022 BLAKE2B ad290ce6792425ba7f643cfe6c09c1a3f040ad0a4c95822f9368592dde6d489d28e892a26d78f2ebfefa086c910c948ef37eb3a3047429605653b273f9b567a8 SHA512 5f3c3d3ecad3a7949270a10c3c7e3a8be938389d4846dcac171526a9fd0485e056889323d303f61630e8735e5735edc91df7ad4efaba3d0b2b66a9d719017ebc
EBUILD deutex-5.2.0.ebuild 565 BLAKE2B 0e507e25b9617714c7e183564af787cb8fc997a08228db79e7b4657764852e695b71ff931652ffb75d0bcdc1436b9f9c5ee453ab9f6ba81e283c5bbdf68f4f7d SHA512 a89f01e8255532877c22bcf0e12232c02e02a6d794fb69cb6734b5f70b69d5d72d4ecd6794342e05d909c72c653e147d3dbf35b3af0fd6b6972fc4bcb3cc1a29
+EBUILD deutex-5.2.2.ebuild 584 BLAKE2B cb9ae5e33c9f750b106828a829884add22b3126e3d7a0e78416802c912fcdb6bd39a19ff9218bf892cab9d86f47c48bc2329e3e3149e7a9553d20b0f991ce880 SHA512 eebbd39fd366dbd057ea702aca7235e331f4afc9ccc18f40ace39b3aee44f3edf642efdfa82db45a9cba17f4183a408856615bad6d33ea37af5d0dcf96a62b5b
MISC metadata.xml 1225 BLAKE2B 5c2a69f813915309ef9da4cdc45c5b6e25cec5c742f6abe321c06245786055c176698ae7275dd507ad06dfb37b6eb093778aa4593a472c9324c97d35ef1c4e27 SHA512 65ab35a0d9b12e6e5dda98b5277bf17ab2f6c655c2fdb09c9b9bed3684a338b7bdf655f864390b6d74207c94ac8baa6776e825db7f8b1f3060c9ca3983885602
diff --git a/games-util/deutex/deutex-5.2.2.ebuild b/games-util/deutex/deutex-5.2.2.ebuild
new file mode 100644
index 000000000000..dcead660a3ae
--- /dev/null
+++ b/games-util/deutex/deutex-5.2.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit unpacker
+
+DESCRIPTION="WAD composer for Doom, Heretic, Hexen, and Strife"
+HOMEPAGE="https://github.com/Doom-Utils/deutex"
+SRC_URI="https://github.com/Doom-Utils/${PN}/releases/download/v${PV}/${P}.tar.zst"
+
+LICENSE="GPL-2+ LGPL-2+ HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="man png"
+
+DEPEND="png? ( media-libs/libpng:0= )"
+RDEPEND="${DEPEND}"
+BDEPEND="man? ( app-text/asciidoc )"
+
+src_configure() {
+ econf \
+ $(use_enable man) \
+ $(use_with png libpng)
+}
diff --git a/games-util/linux-wbfs-manager/Manifest b/games-util/linux-wbfs-manager/Manifest
index 5fc94351162e..09055a76ad72 100644
--- a/games-util/linux-wbfs-manager/Manifest
+++ b/games-util/linux-wbfs-manager/Manifest
@@ -1,4 +1,4 @@
DIST linux-wbfs-manager-0.1.12.tar.gz 34251 BLAKE2B 57a3e5c405318ab128455455e6e45fb58b397c6b3135d97b54642569b26fd9f388d65250723818795fc310704afb59db7a682dbcaaea9c26e113bf0a28998e5d SHA512 58ac4d110e27123d04261d618df8734a0471bcad63171025aa4766a73bcc4a9240fceec59b1ba91fff71230e98f57b5fdd12390d380dc0c41d08740b7076bf6f
-EBUILD linux-wbfs-manager-0.1.12.ebuild 916 BLAKE2B dd786f471afb037d1d4a5f50c311e30322995ad114d7b0c8b5cf16dfbbef1af9f7ad6b8e3434d53824f9f0a557e0af7597400631a8a6d46a0413ce8a0837faa2 SHA512 09e8aab18b18c8b8eb001c844ae589e44ee04c04a668b158dbd6da07891812170f4d4a8d3f945876bce3a9ad6e39859c324ef8a43f2068a5208a6d697036293f
-EBUILD linux-wbfs-manager-9999.ebuild 916 BLAKE2B 060cad1ce2e2e3b1982df08efdefe1d5fbff75b03ce4cb6d14d26040b1737d721f738fa3e1c019c7067e1dd3678ea07e9e88270578b236ac45f0ca57f18fc830 SHA512 a56bb18d7466c517aea67a668bc30b91b8d59773127699963ee5aefc24b706a74751ecfa75fb94b33787ba8979d04bab8980cb7d76c85a2b0652ed065a0b8496
+EBUILD linux-wbfs-manager-0.1.12.ebuild 899 BLAKE2B 4305a9a724db2f45a349adb947287b692261886d9717324c353b0d21118e87fe8ce612dca8eda0e73737d0c1f2869b67dfcf3b49309bd626e9fa9fcc56f2066d SHA512 12af9b808c771f7536872ba89bed5dadaae8444f7d1ae6bb1df795eafa76e1e6f019a3091efbae5ca2e9f71190685646886b559b19bb92c6e7e7dd58761911f2
+EBUILD linux-wbfs-manager-9999.ebuild 899 BLAKE2B 4305a9a724db2f45a349adb947287b692261886d9717324c353b0d21118e87fe8ce612dca8eda0e73737d0c1f2869b67dfcf3b49309bd626e9fa9fcc56f2066d SHA512 12af9b808c771f7536872ba89bed5dadaae8444f7d1ae6bb1df795eafa76e1e6f019a3091efbae5ca2e9f71190685646886b559b19bb92c6e7e7dd58761911f2
MISC metadata.xml 341 BLAKE2B 6dfa68b48d7d834af0a719e930d49fca895d7f929780e087882b9e5889ab492f02ad3f3ebaa990e4c995b80ef43e714fce299ff16181426138dcbe5fe1a6c211 SHA512 46913ec989d81928c2faf97ef1a4e57e19f412189b9acf6de875fea5a9615e808dde58ad29df401fa8d125dd1be232f76800dd2497c60a160db752a13f2ff8cd
diff --git a/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild b/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild
index ac70b1fc110d..b0344682aec6 100644
--- a/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild
+++ b/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild
@@ -1,14 +1,16 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
+
+inherit toolchain-funcs
+
if [[ "${PV}" == "9999" ]]; then
ESVN_REPO_URI="https://linux-wbfs-manager.googlecode.com/svn/trunk/"
- inherit toolchain-funcs subversion
+ inherit subversion
SRC_URI=""
#KEYWORDS=""
else
- inherit toolchain-funcs
SRC_URI="https://linux-wbfs-manager.googlecode.com/files/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi;
@@ -23,7 +25,8 @@ IUSE=""
RDEPEND="dev-libs/glib:2
gnome-base/libglade:2.0"
DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
if [[ ${PV} == "9999" ]] ; then
S=${WORKDIR}/${ECVS_MODULE}
diff --git a/games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild b/games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild
index 59c3678a99f2..b0344682aec6 100644
--- a/games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild
+++ b/games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild
@@ -1,14 +1,16 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
+
+inherit toolchain-funcs
+
if [[ "${PV}" == "9999" ]]; then
ESVN_REPO_URI="https://linux-wbfs-manager.googlecode.com/svn/trunk/"
- inherit toolchain-funcs subversion
+ inherit subversion
SRC_URI=""
#KEYWORDS=""
else
- inherit toolchain-funcs
SRC_URI="https://linux-wbfs-manager.googlecode.com/files/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi;
@@ -23,7 +25,8 @@ IUSE=""
RDEPEND="dev-libs/glib:2
gnome-base/libglade:2.0"
DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
if [[ ${PV} == "9999" ]] ; then
S=${WORKDIR}/${ECVS_MODULE}
diff --git a/games-util/lutris/Manifest b/games-util/lutris/Manifest
index eb060f6aa9f0..48a5b6c15952 100644
--- a/games-util/lutris/Manifest
+++ b/games-util/lutris/Manifest
@@ -2,8 +2,8 @@ AUX lutris-0.5.7-copy_paste_fix.patch 1178 BLAKE2B fcb28456fb0ced4e7f53156bbaed7
DIST lutris_0.5.7.1.tar.xz 2145584 BLAKE2B eb766d5e36aca63af7af8f2e85f51b4e3e37b8372b13a59702c545a0c697fa5feb1403cd9589d22c2bdff6593f69ed39e1bcb7ecb28ecc24b7a77b09ed1b2f89 SHA512 9efff4d92ae4d9051a7253324047dfa57f463188ebdbcede5feba2c0268494e8fa7929d2ef30bfe85e52824bbb9c05b1f1688b6658376597cc4cc35c26a19da3
DIST lutris_0.5.8.1.tar.xz 893328 BLAKE2B 67c66b59c3fa78af46f953b6e27fb3dd77d0e4cb0746f490716c7c074e81afa4f9c4e8c10dc6d4dab3e2b37d03254bae5eda0b777da72bc17f18dda5fd1f990a SHA512 da3b5ebf3e5dcc5011351197c5a80e8547e54df4555ea9124a8404877c5b75225cfae970819a171c55454fef73afdd927dafbf427301b71618c33660a1c8c022
DIST lutris_0.5.8.tar.xz 892740 BLAKE2B eaa8c71ade35392e701b3fd1d8ef2c0077e7fb7b96c3f037b5e4353d89b50b82e8a75fb2fb537e6ceeb9b6faaa5962e0ffe425f52820168b60eed742024610a4 SHA512 dcd963ff8b3c6d66fe79acc1e1c237196f7351d87bf1b4e5920201ecd7f1b2a80ac59f7151287e70e68c402c2b1b00e961d7314e6d5cbbbae0f4ca5fda562a0f
-EBUILD lutris-0.5.7.1.ebuild 1894 BLAKE2B 81f5eb0ba0b07676f2317fa52daabbed987707ab83921d797887834ded7b9a84187ee426ccab5c4baf7235424750844ecf4491e155542c78e2b14ad9bfa07ca6 SHA512 5845f01a0832c236b727af191f6ef55abf7ba08487d0b921b51a939001cd3245a0f5b9efdf235b7c59371b87c647ab61fa81380019a7faa916da3019f403222f
-EBUILD lutris-0.5.8.1.ebuild 1833 BLAKE2B b9130c739bdd68f87f29a2f95bfc9acf60196cbd9279d128be8d13c2736ed1a6355e765ce34e0edb0db1b4d50ee985acd7f25ea4865f5d2891bca96538bd5b7c SHA512 3d29f3b8dd92c94d177dfa7e3789d31d14dcb3d8c8cbebb6f76a374f8f4761dae779563703d4d49e4ee0ddd6616dfed93d6fa3cf395392d811ee59f5b1dcc3ad
-EBUILD lutris-0.5.8.ebuild 1833 BLAKE2B b9130c739bdd68f87f29a2f95bfc9acf60196cbd9279d128be8d13c2736ed1a6355e765ce34e0edb0db1b4d50ee985acd7f25ea4865f5d2891bca96538bd5b7c SHA512 3d29f3b8dd92c94d177dfa7e3789d31d14dcb3d8c8cbebb6f76a374f8f4761dae779563703d4d49e4ee0ddd6616dfed93d6fa3cf395392d811ee59f5b1dcc3ad
-EBUILD lutris-9999.ebuild 1833 BLAKE2B b9130c739bdd68f87f29a2f95bfc9acf60196cbd9279d128be8d13c2736ed1a6355e765ce34e0edb0db1b4d50ee985acd7f25ea4865f5d2891bca96538bd5b7c SHA512 3d29f3b8dd92c94d177dfa7e3789d31d14dcb3d8c8cbebb6f76a374f8f4761dae779563703d4d49e4ee0ddd6616dfed93d6fa3cf395392d811ee59f5b1dcc3ad
+EBUILD lutris-0.5.7.1.ebuild 1892 BLAKE2B 76c0d77e6be634e27d2d873d2756622ff92ce42c0fec3ac71d59d460332178418216c0a99c7bfe525180dc6481d0fd3160b7717d2289d03f468844bbd0906509 SHA512 f456f6ca26d91aa97ce2159c00a5789a255e36ab069bb40d45bc1ec5858d1dd83fd828b2b34b8e2a6fd709e6cb37ddd95b5318e23156c748806039709bf3d18b
+EBUILD lutris-0.5.8.1.ebuild 1875 BLAKE2B c5d633b619d334c3cae7ed31786f335792a44e8a70618d36466287ce6c8829c9a1fe79a3228ec698948fb603e83a7370e92c37e5eecf3cb966793d32720af6ad SHA512 24600a07731d4f13d5ef20464ac92c52a4fb2fa8e15f40259bf76481e8493b71a2181c9bf5671bf45f454727599bf2d32a1e6b7c83e4dc22916167faced22988
+EBUILD lutris-0.5.8.ebuild 1875 BLAKE2B c5d633b619d334c3cae7ed31786f335792a44e8a70618d36466287ce6c8829c9a1fe79a3228ec698948fb603e83a7370e92c37e5eecf3cb966793d32720af6ad SHA512 24600a07731d4f13d5ef20464ac92c52a4fb2fa8e15f40259bf76481e8493b71a2181c9bf5671bf45f454727599bf2d32a1e6b7c83e4dc22916167faced22988
+EBUILD lutris-9999.ebuild 1875 BLAKE2B c5d633b619d334c3cae7ed31786f335792a44e8a70618d36466287ce6c8829c9a1fe79a3228ec698948fb603e83a7370e92c37e5eecf3cb966793d32720af6ad SHA512 24600a07731d4f13d5ef20464ac92c52a4fb2fa8e15f40259bf76481e8493b71a2181c9bf5671bf45f454727599bf2d32a1e6b7c83e4dc22916167faced22988
MISC metadata.xml 661 BLAKE2B 8b05694fe3755a3b2b1546c1392bccb408d99f430c361e6058702107d665b13e0d36834d37c2a31ab7065290363e6af7712fcf4b36542222b59e47b508b7d1ef SHA512 e5d7a7023e9aa025d8d526457ba61ec9d9ceadf472d3f04f6b799cb3c130543e4300a56ce1830c163650f0554e2a87d705152b3771bb4f7fd9edeba3db16b9a7
diff --git a/games-util/lutris/lutris-0.5.7.1.ebuild b/games-util/lutris/lutris-0.5.7.1.ebuild
index fb54a72d2b4d..bf776348a5a6 100644
--- a/games-util/lutris/lutris-0.5.7.1.ebuild
+++ b/games-util/lutris/lutris-0.5.7.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
PYTHON_REQ_USE="sqlite,threads(+)"
DISTUTILS_SINGLE_IMPL="1"
@@ -36,7 +36,6 @@ BDEPEND="
RDEPEND="
app-arch/cabextract
app-arch/p7zip
- app-arch/unrar
app-arch/unzip
$(python_gen_cond_dep '
dev-python/dbus-python[${PYTHON_USEDEP}]
@@ -54,7 +53,7 @@ RDEPEND="
x11-apps/xgamma
x11-apps/xrandr
x11-libs/gtk+:3[introspection]
- x11-libs/libnotify
+ x11-libs/libnotify[introspection]
"
PATCHES=(
diff --git a/games-util/lutris/lutris-0.5.8.1.ebuild b/games-util/lutris/lutris-0.5.8.1.ebuild
index 4052ada5d976..1daf6b1bf933 100644
--- a/games-util/lutris/lutris-0.5.8.1.ebuild
+++ b/games-util/lutris/lutris-0.5.8.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
PYTHON_REQ_USE="sqlite,threads(+)"
DISTUTILS_SINGLE_IMPL="1"
@@ -36,13 +36,13 @@ BDEPEND="
RDEPEND="
app-arch/cabextract
app-arch/p7zip
- app-arch/unrar
app-arch/unzip
$(python_gen_cond_dep '
dev-python/dbus-python[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
dev-python/python-evdev[${PYTHON_USEDEP}]
+ dev-python/python-magic[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
')
@@ -54,7 +54,7 @@ RDEPEND="
x11-apps/xgamma
x11-apps/xrandr
x11-libs/gtk+:3[introspection]
- x11-libs/libnotify
+ x11-libs/libnotify[introspection]
"
python_install_all() {
diff --git a/games-util/lutris/lutris-0.5.8.ebuild b/games-util/lutris/lutris-0.5.8.ebuild
index 4052ada5d976..1daf6b1bf933 100644
--- a/games-util/lutris/lutris-0.5.8.ebuild
+++ b/games-util/lutris/lutris-0.5.8.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
PYTHON_REQ_USE="sqlite,threads(+)"
DISTUTILS_SINGLE_IMPL="1"
@@ -36,13 +36,13 @@ BDEPEND="
RDEPEND="
app-arch/cabextract
app-arch/p7zip
- app-arch/unrar
app-arch/unzip
$(python_gen_cond_dep '
dev-python/dbus-python[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
dev-python/python-evdev[${PYTHON_USEDEP}]
+ dev-python/python-magic[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
')
@@ -54,7 +54,7 @@ RDEPEND="
x11-apps/xgamma
x11-apps/xrandr
x11-libs/gtk+:3[introspection]
- x11-libs/libnotify
+ x11-libs/libnotify[introspection]
"
python_install_all() {
diff --git a/games-util/lutris/lutris-9999.ebuild b/games-util/lutris/lutris-9999.ebuild
index 4052ada5d976..1daf6b1bf933 100644
--- a/games-util/lutris/lutris-9999.ebuild
+++ b/games-util/lutris/lutris-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
PYTHON_REQ_USE="sqlite,threads(+)"
DISTUTILS_SINGLE_IMPL="1"
@@ -36,13 +36,13 @@ BDEPEND="
RDEPEND="
app-arch/cabextract
app-arch/p7zip
- app-arch/unrar
app-arch/unzip
$(python_gen_cond_dep '
dev-python/dbus-python[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
dev-python/python-evdev[${PYTHON_USEDEP}]
+ dev-python/python-magic[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
')
@@ -54,7 +54,7 @@ RDEPEND="
x11-apps/xgamma
x11-apps/xrandr
x11-libs/gtk+:3[introspection]
- x11-libs/libnotify
+ x11-libs/libnotify[introspection]
"
python_install_all() {
diff --git a/games-util/xboxdrv/Manifest b/games-util/xboxdrv/Manifest
index be714d76c2af..232f426381af 100644
--- a/games-util/xboxdrv/Manifest
+++ b/games-util/xboxdrv/Manifest
@@ -4,5 +4,5 @@ AUX xboxdrv.initd 446 BLAKE2B f78cf4af5cca703efc0a480c2ba34b0189d2b86a64aa89533e
AUX xboxdrv.service 371 BLAKE2B afd5f5397f4ae15af69d8e12865201fe159691ba2a36c00fe207304afe5126814fafd0394e7618e9f4d27611bd2c0dd7371717c7a07a57d27c3a4ab8e6e40140 SHA512 80e7657edae9c771740628ef5f9752b79d50288ead33afe97e71ffc6e7d7c24343eeb213668cdc823b28742976e2e56f4defdcd823716897f3262be1fc7832e9
AUX xboxdrv.udev-rules 251 BLAKE2B 5a3af6d378b2d6ad5bb2da0dfa356c6939a274b194f075281bbfc3dcaee1c5b9fc63740bbfec2ecd0c8245065262a0449c47fad6c522e4773ef2e193018dc95f SHA512 131c90bee6ac4da5e3d51c7212abb362a540092db97af56332cdfe14e836c84c97727823462ea378da6e5544fda2fb4d36fbe00b6210e5663316f914eaa3f4ad
DIST xboxdrv-0.8.8_p20190118.tar.gz 322541 BLAKE2B ffa1021f974414ab9efebccf89e8be9137647ba7e1adf3bc9dad3b17b362b340f087fdac42c9b91a29a4cfe13295df6d3861fe953d9f96e80df08d4a6b1ce754 SHA512 ede650090c67642dc4729acc37630ae807f354d76f9bf31e23357668b6ae2b8d0261d2cf6e33090ab2120083b0664332dab22f1ed682bcdcbf1cac88b97e67af
-EBUILD xboxdrv-0.8.8_p20190118.ebuild 1536 BLAKE2B 576d869b1d5b9c5d3ab18545895c241fa7df76e3326a7bfdbc9c2f74683b70e931564c29e4067c6158d93f9c61003bb873b313014f7b3fe6e5c0ab6733806b41 SHA512 28931e15330eaae86c73c39d72530a193ac074a7f2ab5512437cce2435d52b836f57dfdea087ef2765ee791ffd3316580aea79c83831e1cff4a763622e1ef83c
-MISC metadata.xml 494 BLAKE2B 365b4d5cc3a91765b96e4e206c9beb261e318798e90437e39ae7c2c437f1df07100233f0458acca702e1efadd092a4f788c81ddcdc40b8997cc91a1041047997 SHA512 dec2bdb2eb9d7cab3cb481d9694a805175a4004f0be5956b6711acb833732d7bc8ec3dc9b2c61d00b724bc7986ec186e7b36aa0327337bdab9241d45ee5f1f0e
+EBUILD xboxdrv-0.8.8_p20190118.ebuild 1591 BLAKE2B 09a48909d1b6d11520cefbc5b06bfbb247d5d246d5022861ece8855f49f8e32fab5964bda799b8dcadad9a64c18f47a0f7e9db47c6660cdecd89b0a390c1aa1a SHA512 45ba92ad9a6c21e8722b1e82116909eb3e9a58dadbb273e0ae2f10a6a445b43a42d684222502d31e78e6454316e99acda61da7506b1216a9512d28bb32305def
+MISC metadata.xml 393 BLAKE2B d8177cd12ab0e79dc748743bcaad99dd9bb77542703bbac6040af639e191f2fca4356d0edef80b7d21c7b8c27c269b3e1fe04f03ea8d725ab86920c08394f310 SHA512 e8913486c54693f734d541a4f1f72bc1b29adc9e4de3b8b9c16d657082643f256d87d6888ef7e6dd63f540106f96a9a0fe90aef8334629b73ef75b607709c33d
diff --git a/games-util/xboxdrv/metadata.xml b/games-util/xboxdrv/metadata.xml
index fe838d30a8ff..36f65aa6d477 100644
--- a/games-util/xboxdrv/metadata.xml
+++ b/games-util/xboxdrv/metadata.xml
@@ -1,16 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>chewi@gentoo.org</email>
- <name>James Le Cuirot</name>
- </maintainer>
- <maintainer type="project">
- <email>games@gentoo.org</email>
- <name>Gentoo Games Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">chewi/xboxdrv</remote-id>
- <remote-id type="gitlab">xboxdrv/xboxdrv</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>juippis@gentoo.org</email>
+ <name>Joonas Niilola</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">chewi/xboxdrv</remote-id>
+ <remote-id type="gitlab">xboxdrv/xboxdrv</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/games-util/xboxdrv/xboxdrv-0.8.8_p20190118.ebuild b/games-util/xboxdrv/xboxdrv-0.8.8_p20190118.ebuild
index 76f9f0a91fc9..fe9386eaac63 100644
--- a/games-util/xboxdrv/xboxdrv-0.8.8_p20190118.ebuild
+++ b/games-util/xboxdrv/xboxdrv-0.8.8_p20190118.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit linux-info python-any-r1 scons-utils toolchain-funcs systemd udev
@@ -38,6 +38,11 @@ S="${WORKDIR}/${PN}-${COMMIT}"
CONFIG_CHECK="~INPUT_EVDEV ~INPUT_JOYDEV ~INPUT_UINPUT ~!JOYSTICK_XPAD"
+pkg_setup() {
+ linux-info_pkg_setup
+ python_setup
+}
+
src_prepare() {
default