summaryrefslogtreecommitdiff
path: root/games-util/xpadneo
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/xpadneo')
-rw-r--r--games-util/xpadneo/Manifest4
-rw-r--r--games-util/xpadneo/metadata.xml15
-rw-r--r--games-util/xpadneo/xpadneo-0.9.ebuild62
-rw-r--r--games-util/xpadneo/xpadneo-9999.ebuild64
4 files changed, 145 insertions, 0 deletions
diff --git a/games-util/xpadneo/Manifest b/games-util/xpadneo/Manifest
new file mode 100644
index 000000000000..f7860be3c1aa
--- /dev/null
+++ b/games-util/xpadneo/Manifest
@@ -0,0 +1,4 @@
+DIST xpadneo-0.9.tar.gz 1351003 BLAKE2B dd41e687a44415c9c44d70ae4df9c858a7218eca301e61421cee4b9e80d912f9336dad15636dc38cb79128a635e33bb2b795fadebe2f53ebe42d192212364cb0 SHA512 0819af24bfa556dd330abeb1180b0a46105428b6b2c8529bb357cd5b578fe6f21e057f3f457994b21b6d5d6b207d46bdf0ff80a6415f833396595ba5e7309389
+EBUILD xpadneo-0.9.ebuild 1706 BLAKE2B e4ce9ece179256d849d7716dfe4baebff7456a9b737b2519e10c3dd5a0c4cd67cd81447cf02da52ab57bb68b39ac0e57482a63e1b135c03d708dafc9fed1fd20 SHA512 2380b84a58460eaa0a59625c5788b0f8250523c06e114818e9e9a6fb602b85bd202ba3ef5d9c55b099cc7541943d4168a36e14f57cdabd23ed0502b8bf0f2d97
+EBUILD xpadneo-9999.ebuild 1779 BLAKE2B beaffe9f6a92f66c10458e1c435b16f52167b0a475ffe3c45aeaefeaa0436849e9457dcf9cca4fd1924563308b2c069ac83bfc65541bc647d498ce1d71824546 SHA512 7b624b853869a97d3d886c5837ac614e361d93d18d067555f99529abdb877267b43ac55e0ab1208801a133c8ea6568c6cab572533d4211bab0f5c826ea5fe0c6
+MISC metadata.xml 476 BLAKE2B 88a9a4d49f902c50d87fe36c98f6f4f2c553c6cb6882966f0d4858413ed8b603f428c7b3b43d157a6ff25fb1ab26231657119e14b4a0260a159a372501593391 SHA512 9f3a4e2063cb3e30b8ba428930715533c0c3fe7defda881d1a86f5f652fc736938e88ce21e4f028f57f9edc14f6528c8a731a6689242c0d369f44a2606425fd7
diff --git a/games-util/xpadneo/metadata.xml b/games-util/xpadneo/metadata.xml
new file mode 100644
index 000000000000..32782d0fcfbb
--- /dev/null
+++ b/games-util/xpadneo/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>sudinave@gmail.com</email>
+ <name>Ionen Wolkens</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">atar-axis/xpadneo</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-util/xpadneo/xpadneo-0.9.ebuild b/games-util/xpadneo/xpadneo-0.9.ebuild
new file mode 100644
index 000000000000..33ed81817a28
--- /dev/null
+++ b/games-util/xpadneo/xpadneo-0.9.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod toolchain-funcs udev
+
+DESCRIPTION="Advanced Linux Driver for Xbox One Wireless Controller"
+HOMEPAGE="https://atar-axis.github.io/xpadneo/"
+SRC_URI="https://github.com/atar-axis/xpadneo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S+="/hid-${PN}"
+MODULE_NAMES="hid-${PN}(kernel/drivers/hid::src)"
+BUILD_PARAMS='V=1 LD="$(tc-getLD)" KERNEL_SOURCE_DIR="${KERNEL_DIR}"'
+BUILD_TARGETS="modules"
+
+CONFIG_CHECK="INPUT_FF_MEMLESS"
+
+src_prepare() {
+ default
+ sed -i "s/@DO_NOT_CHANGE@/v${PV}/" src/version.h || die
+}
+
+src_install() {
+ linux-mod_src_install
+
+ insinto /etc/modprobe.d
+ doins etc-modprobe.d/${PN}.conf
+
+ udev_dorules etc-udev-rules.d/98-${PN}.rules
+
+ dodoc -r ../docs/{[^i]*.md,descriptors,reports} ../NEWS.md
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ udev_reload
+
+ local ertm=/sys/module/bluetooth/parameters/disable_ertm
+ if ! [[ ${REPLACING_VERSIONS} && $(<${ertm}) == Y ]]; then
+ elog "To pair the gamepad and view module options, see documentation in:"
+ elog " ${EROOT}/usr/share/doc/${PF}"
+ elog
+ elog "Be warned that bluetooth's ERTM (Enhanced ReTransmission Mode) can"
+ elog "cause the gamepad to enter a re-connection loop."
+ elog "- To disable immediately:"
+ elog " echo Y > ${ertm}"
+ elog "- To disable for next and subsequent boot:"
+ elog " echo 'options bluetooth disable_ertm=y' > ${EROOT}/etc/modprobe.d/no-ertm.conf"
+ elog "- Or, if bluetooth isn't a module, add to the kernel's command line:"
+ elog " bluetooth.disable_ertm=y"
+ fi
+}
+
+pkg_postrm() {
+ linux-mod_pkg_postrm
+ udev_reload
+}
diff --git a/games-util/xpadneo/xpadneo-9999.ebuild b/games-util/xpadneo/xpadneo-9999.ebuild
new file mode 100644
index 000000000000..a40a337a9918
--- /dev/null
+++ b/games-util/xpadneo/xpadneo-9999.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod toolchain-funcs udev
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/atar-axis/xpadneo.git"
+ EGIT_MIN_CLONE_TYPE="single"
+else
+ SRC_URI="https://github.com/atar-axis/xpadneo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Advanced Linux Driver for Xbox One Wireless Controller"
+HOMEPAGE="https://atar-axis.github.io/xpadneo/"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+S+="/hid-${PN}"
+MODULE_NAMES="hid-${PN}(kernel/drivers/hid::src)"
+BUILD_PARAMS='V=1 LD="$(tc-getLD)" KERNEL_SOURCE_DIR="${KERNEL_DIR}"'
+BUILD_TARGETS="src/version.h modules"
+
+CONFIG_CHECK="INPUT_FF_MEMLESS"
+
+src_install() {
+ linux-mod_src_install
+
+ insinto /etc/modprobe.d
+ doins etc-modprobe.d/${PN}.conf
+
+ udev_dorules etc-udev-rules.d/98-${PN}.rules
+
+ dodoc -r ../docs/{[^i]*.md,descriptors,reports} ../NEWS.md
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ udev_reload
+
+ local ertm=/sys/module/bluetooth/parameters/disable_ertm
+ if ! [[ ${REPLACING_VERSIONS} && $(<${ertm}) == Y ]]; then
+ elog "To pair the gamepad and view module options, see documentation in:"
+ elog " ${EROOT}/usr/share/doc/${PF}"
+ elog
+ elog "Be warned that bluetooth's ERTM (Enhanced ReTransmission Mode) can"
+ elog "cause the gamepad to enter a re-connection loop."
+ elog "- To disable immediately:"
+ elog " echo Y > ${ertm}"
+ elog "- To disable for next and subsequent boot:"
+ elog " echo 'options bluetooth disable_ertm=y' > ${EROOT}/etc/modprobe.d/no-ertm.conf"
+ elog "- Or, if bluetooth isn't a module, add to the kernel's command line:"
+ elog " bluetooth.disable_ertm=y"
+ fi
+}
+
+pkg_postrm() {
+ linux-mod_pkg_postrm
+ udev_reload
+}