summaryrefslogtreecommitdiff
path: root/games-util/sc-controller
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/sc-controller')
-rw-r--r--games-util/sc-controller/Manifest4
-rw-r--r--games-util/sc-controller/sc-controller-0.4.8.2.ebuild29
-rw-r--r--games-util/sc-controller/sc-controller-0.4.8.6-r2.ebuild38
3 files changed, 40 insertions, 31 deletions
diff --git a/games-util/sc-controller/Manifest b/games-util/sc-controller/Manifest
index a06d8a9b0bf6..b1ed69d4033b 100644
--- a/games-util/sc-controller/Manifest
+++ b/games-util/sc-controller/Manifest
@@ -1,3 +1,3 @@
-DIST sc-controller-0.4.8.2.tar.gz 2520528 BLAKE2B 0c98e1fd49e846909ec0a78c5bbf48731de464ab79ebe3e1b0370e2a6f176e925e6f2b288c17358221b2e50be0cd783f31f05324ac585aec310967d148ce5011 SHA512 8d157e871fa519ebd3eee27dd1c0ff1afe6f79201df12578aa31f3cbc62974bd7ba47c8a097870b693a7abaacaadd1e502012c9664c0aecddbd982fa10c7f84d
-EBUILD sc-controller-0.4.8.2.ebuild 767 BLAKE2B fe5e2a7886234bdecd105fe0131a5ab1bcda755ee04092c9af5dfadf8dc0915b6a76931b2dc074549c330e682fea283bc1807f02ef96d8ade64637e211f2d244 SHA512 d5933b34fb3955a11a8532a986199d0a5b738c218836480ec647e797026d67771c660b462f0a31c22bc20eea2b173e37fb7e121fbe0f77b2af2169c1f889a9bc
+DIST sc-controller-0.4.8.6.tar.gz 2524756 BLAKE2B b31454fde0705bd49cdf3d56aec43d230617877a1dd1f72bef84d772c28f153b2e6812fd50b096e32a2ea3be549cfd1ee5fb3f9cf138c1dbc73c004ec11984b7 SHA512 d6f8098bff0fce064e194815a6c9bbf6ee974e22af056df9a12ebc24de4f1a22decfcf5191565c81aed39e3aa73b742bdc26040945e2b87543b67202834b46ea
+EBUILD sc-controller-0.4.8.6-r2.ebuild 1041 BLAKE2B bc35fe71336adba0c19134aa97fdcce9741c6fbf96ef9228cef46dd7fe67ea6b99f520f0cb40227897fedaf591c912047f428e13274883c48a8b476ff0d64500 SHA512 834a384623bae922e5363eba96f79bf102ef93c209466cfe64cf1b62fe413c1f223d16ea21edf41192b75ac08aab47ee5d51a5e1c6ca33fa6b61b070a6717cac
MISC metadata.xml 341 BLAKE2B 8bfad400d398e07b5c8ba2c0a54c3fb3768d6748df641c4d2ad75a8032fd7f351f023acf791b9b61da0e70500cfdb1b669eaaa140f6351a851b6b2e23d3c5147 SHA512 4f17d6bd17da51eec7d7b90a3c72b9ef29bb6780dc4b67245ca4ce17a62128eb800ae1e519d2b136763c3c26cf89473fb23a7e878c1e4b19b116ed9546547f58
diff --git a/games-util/sc-controller/sc-controller-0.4.8.2.ebuild b/games-util/sc-controller/sc-controller-0.4.8.2.ebuild
deleted file mode 100644
index fd7546b73bf5..000000000000
--- a/games-util/sc-controller/sc-controller-0.4.8.2.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit distutils-r1 xdg
-
-DESCRIPTION="User-mode driver and GTK-based GUI for Steam Controllers and others"
-HOMEPAGE="https://github.com/Ryochan7/sc-controller/"
-SRC_URI="https://github.com/Ryochan7/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="GPL-2 CC0-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+udev"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/pygobject[${PYTHON_USEDEP},cairo]
- dev-python/pylibacl[${PYTHON_USEDEP}]
- dev-python/python-evdev[${PYTHON_USEDEP}]
- ')
- gnome-base/librsvg
- x11-libs/gtk+:3
- udev? ( games-util/game-device-udev-rules )
-"
diff --git a/games-util/sc-controller/sc-controller-0.4.8.6-r2.ebuild b/games-util/sc-controller/sc-controller-0.4.8.6-r2.ebuild
new file mode 100644
index 000000000000..04d45d6855e4
--- /dev/null
+++ b/games-util/sc-controller/sc-controller-0.4.8.6-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 linux-info xdg
+
+DESCRIPTION="User-mode driver and GTK-based GUI for Steam Controllers and others"
+HOMEPAGE="https://github.com/Ryochan7/sc-controller/"
+SRC_URI="https://github.com/Ryochan7/sc-controller/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 BSD CC-BY-3.0 CC0-1.0 LGPL-2.1 MIT PSF-2 ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+udev"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pygobject[${PYTHON_USEDEP},cairo]
+ dev-python/pylibacl[${PYTHON_USEDEP}]
+ dev-python/python-evdev[${PYTHON_USEDEP}]
+ dev-python/vdf[${PYTHON_USEDEP}]')
+ gnome-base/librsvg[introspection]
+ virtual/libusb
+ x11-libs/gtk+:3[introspection]
+ udev? ( games-util/game-device-udev-rules )"
+
+distutils_enable_tests pytest
+
+pkg_setup() {
+ local CONFIG_CHECK="~INPUT_UINPUT"
+
+ linux-info_pkg_setup
+ python-single-r1_pkg_setup
+}