summaryrefslogtreecommitdiff
path: root/games-util/qstat
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/qstat')
-rw-r--r--games-util/qstat/Manifest3
-rw-r--r--games-util/qstat/files/qstat-2.14-gcc-10.patch51
-rw-r--r--games-util/qstat/qstat-2.14.ebuild6
3 files changed, 58 insertions, 2 deletions
diff --git a/games-util/qstat/Manifest b/games-util/qstat/Manifest
index a4dfc2ac60f9..f1f8292c7e54 100644
--- a/games-util/qstat/Manifest
+++ b/games-util/qstat/Manifest
@@ -1,5 +1,6 @@
+AUX qstat-2.14-gcc-10.patch 1546 BLAKE2B 4510244b1bd6cbaa0488b13c413d6ed2e58f0cb189cea23e4777415fd4d7b9b67b300eee30c14e39f0ef8c594117eab23962232de65683b37bcc5bc88f707fb1 SHA512 445c7fa7ba892ece7a6ae55c3fadb4a5691ad9e37bdca40541efece6cd053651a4bd6089aadaa0661c5d97db76530d2b04def3df6ca9bf11af3eb37de3c410e6
DIST qstat-2.11.tar.gz 258335 BLAKE2B f12d0f69c8a73f9eeb273c46aefe2008b8c724b132e02d2fa156c2456f537d2162ae7db6acd0007c7db8bc87dafcfb41355466008c74ce3e912023a7c8cb42cc SHA512 e3ff732c6fc45300eb2f32b3f3e8e1e5f8ee32234535e8d2ca19cf95cf6d4a6de5b6f1e48a5c64315d60a8b388521106b2de9d307f718f6150ad2cf40ba75a22
DIST qstat-2.14.tar.gz 210440 BLAKE2B 2a33287a69fe63c59a1cb136e84ea29cccd27f4468cb4b38b4e9ce49f28a558dc67793eaa7ead7addd828730e084a15f9684ccba7753852ce1c2795c7c94cb78 SHA512 f2054d74399fe1773a19ca43629e10364fdd87e551459719685c11f38245a05906631b456848b1a3764b4e6843baf654af6a9b174c7b16908b6bcb97ac64c6d6
EBUILD qstat-2.11.ebuild 677 BLAKE2B d5997ad9bf5dcb6e9e5d689080f2056c310b8924e636e4e1b61d8c7a5362c4dd46301e34ffd11500e01753692af86e897facc2185ad9713ee0fcd7605ea33b03 SHA512 14bd978d242400b4929997011f8c4bb55171504f132400d71d2b4723569385779f0b6d6017675b67a90ffe8418d80ba0a4605c7a71de5b4a3325bc66cc601b95
-EBUILD qstat-2.14.ebuild 775 BLAKE2B d410af9edf50b7a31d5be7d1306db8e9fab011a3cba172b849f842822ed944feda75691335281a038b49b88d8884636d7c092d543993291c6569474b11696dcb SHA512 5b82f8c8182b1c01f9e46fb83fc7ad87a22b34d8c1cb18cea2f8c010202fcec274d9742ecb97eae7b82800eb5ae91fff299c38303854e067c1869ae20fa65a62
+EBUILD qstat-2.14.ebuild 818 BLAKE2B c19fe95427c004be3c1357f01b89b95d89fd4b7cc8d4c2736381a43cd29b6b64ea86ea351d5f23dd859186627029812244e9c7461c57e7358f6567692be9acb8 SHA512 0016b864ba3c90ae6b92681e70f0f5991d030b33e0fb4d4da11abf68907f5c55b29b503e2176435ddddb61de462c37a5ff24cbdb8d882a2d1391715388421257
MISC metadata.xml 328 BLAKE2B 05e29df4e66acb89893251aec455d3f05f38344bd12414e74ac46d23573afcd8c7e4d7b2e03d217c443a32e31beaea3d122cd474e317e3490c1d6bbdb7de4c4d SHA512 1f3cbc63b69d59880ff6fe131bf838f69bfd259a93882ef9b38c1d101d4048c2894cf99725d3ce683f9f05da035567d6e4bdafa9d4349844f7b8af98c13f999f
diff --git a/games-util/qstat/files/qstat-2.14-gcc-10.patch b/games-util/qstat/files/qstat-2.14-gcc-10.patch
new file mode 100644
index 000000000000..e16e701330a0
--- /dev/null
+++ b/games-util/qstat/files/qstat-2.14-gcc-10.patch
@@ -0,0 +1,51 @@
+From 878fa5fd6475685c3465a6e71a10c2fc61c1a09c Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Sun, 26 Jan 2020 11:15:10 +0000
+Subject: [PATCH] qstat: fix build failure against gcc-10
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+On gcc-10 (and gcc-9 -fno-common) build fails as:
+
+```
+gcc ... -o qstat ...
+ld: config.o:qstat/display_json.h:24:
+ multiple definition of `json_printed'; xform.o:qstat/display_json.h:24: first defined here
+ld: config.o:qstat/display_json.h:23:
+ multiple definition of `json_encoding'; xform.o:qstat/display_json.h:23: first defined here
+```
+
+gcc-10 will change the default from -fcommon to fno-common:
+https://gcc.gnu.org/PR85678.
+
+The error also happens if CFLAGS=-fno-common passed explicitly.
+
+Reported-by: Toralf Förster
+Bug: https://bugs.gentoo.org/706390
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+---
+ debug.c | 2 +-
+ debug.h | 2 +-
+
+--- a/debug.c
++++ b/debug.c
+@@ -114,6 +114,7 @@ static void _dump_packet(const char* tag, const char* buf, int buflen)
+ close(fd);
+ }
+
++int do_dump = 0;
+ ssize_t send_dump(int s, const void *buf, size_t len, int flags)
+ {
+ if(do_dump)
+--- a/debug.h
++++ b/debug.h
+@@ -47,7 +47,7 @@ void dump_packet(const char* buf, int buflen);
+ #endif
+ #include <sys/types.h>
+ #include <sys/stat.h>
+-int do_dump;
++extern int do_dump;
+ ssize_t send_dump(int s, const void *buf, size_t len, int flags);
+ #ifndef QSTAT_DEBUG_C
+ #define send(s, buf, len, flags) send_dump(s, buf, len, flags)
diff --git a/games-util/qstat/qstat-2.14.ebuild b/games-util/qstat/qstat-2.14.ebuild
index 3dbdb38a119f..ee781cb84953 100644
--- a/games-util/qstat/qstat-2.14.ebuild
+++ b/games-util/qstat/qstat-2.14.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,6 +18,10 @@ DEPEND="!sys-cluster/torque"
DOCS=( CHANGES.txt COMPILE.txt template/README.txt )
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc-10.patch
+)
+
src_prepare() {
default
eautoreconf