summaryrefslogtreecommitdiff
path: root/games-util/nml/nml-0.4.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/nml/nml-0.4.5-r1.ebuild')
-rw-r--r--games-util/nml/nml-0.4.5-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/games-util/nml/nml-0.4.5-r1.ebuild b/games-util/nml/nml-0.4.5-r1.ebuild
new file mode 100644
index 000000000000..6f8e7f6ea8da
--- /dev/null
+++ b/games-util/nml/nml-0.4.5-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Compiler of NML files into grf/nfo files"
+HOMEPAGE="https://dev.openttdcoop.org/projects/nml"
+SRC_URI="http://bundles.openttdcoop.org/nml/releases/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="dev-python/pillow[zlib,${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( docs/{changelog,readme}.txt )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.4-pillow3.patch
+ "${FILESDIR}"/${PN}-0.4.5-pillow6.patch
+)
+
+src_install() {
+ distutils-r1_src_install
+ doman docs/nmlc.1
+}