summaryrefslogtreecommitdiff
path: root/games-util/mcrcon/mcrcon-0.7.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/mcrcon/mcrcon-0.7.1.ebuild')
-rw-r--r--games-util/mcrcon/mcrcon-0.7.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/games-util/mcrcon/mcrcon-0.7.1.ebuild b/games-util/mcrcon/mcrcon-0.7.1.ebuild
new file mode 100644
index 000000000000..d840cef90470
--- /dev/null
+++ b/games-util/mcrcon/mcrcon-0.7.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Remote connection client for Minecraft servers"
+HOMEPAGE="https://github.com/Tiiffi/mcrcon"
+SRC_URI="https://github.com/Tiiffi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${LDFLAGS} -std=gnu99 -Wall -Wextra -Wpedantic"
+}
+
+src_install() {
+ emake install PREFIX="${ED}/usr"
+}