summaryrefslogtreecommitdiff
path: root/games-util/mcrcon/mcrcon-0.0.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/mcrcon/mcrcon-0.0.5.ebuild')
-rw-r--r--games-util/mcrcon/mcrcon-0.0.5.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/games-util/mcrcon/mcrcon-0.0.5.ebuild b/games-util/mcrcon/mcrcon-0.0.5.ebuild
new file mode 100644
index 000000000000..ad05389b005a
--- /dev/null
+++ b/games-util/mcrcon/mcrcon-0.0.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs games
+
+DESCRIPTION="Remote connection client for Minecraft servers"
+HOMEPAGE="https://sourceforge.net/projects/mcrcon/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_compile() {
+ # Flags taken from COMPILING.txt.
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -std=gnu11 -pedantic -Wall -Wextra -o "${PN}" "${PN}.c" || die
+}
+
+src_install() {
+ dogamesbin "${PN}"
+ dodoc README.txt
+}