summaryrefslogtreecommitdiff
path: root/games-util/mcrcon/mcrcon-0.0.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/mcrcon/mcrcon-0.0.5-r1.ebuild')
-rw-r--r--games-util/mcrcon/mcrcon-0.0.5-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/games-util/mcrcon/mcrcon-0.0.5-r1.ebuild b/games-util/mcrcon/mcrcon-0.0.5-r1.ebuild
new file mode 100644
index 000000000000..01c42e501eda
--- /dev/null
+++ b/games-util/mcrcon/mcrcon-0.0.5-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Remote connection client for Minecraft servers"
+HOMEPAGE="https://sourceforge.net/projects/mcrcon/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_compile() {
+ # Flags taken from COMPILING.txt.
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -std=gnu11 -pedantic -Wall -Wextra -o "${PN}" "${PN}.c" || die
+}
+
+src_install() {
+ default
+ dobin "${PN}"
+}