summaryrefslogtreecommitdiff
path: root/games-util/lgogdownloader/lgogdownloader-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/lgogdownloader/lgogdownloader-9999.ebuild')
-rw-r--r--games-util/lgogdownloader/lgogdownloader-9999.ebuild25
1 files changed, 20 insertions, 5 deletions
diff --git a/games-util/lgogdownloader/lgogdownloader-9999.ebuild b/games-util/lgogdownloader/lgogdownloader-9999.ebuild
index a04e8bc6c49e..d0d1304d0133 100644
--- a/games-util/lgogdownloader/lgogdownloader-9999.ebuild
+++ b/games-util/lgogdownloader/lgogdownloader-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit cmake-utils git-r3
@@ -10,6 +10,7 @@ HOMEPAGE="https://sites.google.com/site/gogdownloader/"
EGIT_REPO_URI="https://github.com/Sude-/lgogdownloader.git"
LICENSE="WTFPL-2"
SLOT="0"
+IUSE="gui"
RDEPEND=">=app-crypt/rhash-1.3.3-r2:0=
dev-cpp/htmlcxx:0=
@@ -17,8 +18,22 @@ RDEPEND=">=app-crypt/rhash-1.3.3-r2:0=
>=dev-libs/jsoncpp-1.7:0=
dev-libs/tinyxml2:0=
net-libs/liboauth:0=
- >=net-misc/curl-7.32:0=[ssl]"
+ >=net-misc/curl-7.32:0=[ssl]
+ gui? ( dev-qt/qtwebengine:5=[widgets] )"
-DEPEND="${RDEPEND}
- sys-apps/help2man
+DEPEND="${RDEPEND}"
+
+BDEPEND="sys-apps/help2man
virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT_GUI=$(usex gui)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ gunzip "${ED}"/usr/share/man/man1/${PN}.1.gz || die
+}