summaryrefslogtreecommitdiff
path: root/games-util/grfcodec
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/grfcodec')
-rw-r--r--games-util/grfcodec/Manifest3
-rw-r--r--games-util/grfcodec/files/grfcodec-6.0.6-gcc10.patch12
-rw-r--r--games-util/grfcodec/grfcodec-6.0.6.ebuild4
3 files changed, 17 insertions, 2 deletions
diff --git a/games-util/grfcodec/Manifest b/games-util/grfcodec/Manifest
index 76ae1902c91f..25fd6fe6bec6 100644
--- a/games-util/grfcodec/Manifest
+++ b/games-util/grfcodec/Manifest
@@ -1,3 +1,4 @@
+AUX grfcodec-6.0.6-gcc10.patch 507 BLAKE2B 7f09d9e6468f059780e1253a32431c88b8a980276b81f02b50c72a8650b05da1709d951cccc71daa7c6109b8ebb80450073cfc1057997cb7ffb008f964b7281d SHA512 27e4055efe874d7833d98feb45af84717120188a805307915f0f0a05adf696960a75662f0f1a67a46b0e0780f3d85646cb626b33559db77a925c20ef750fceb0
DIST grfcodec-6.0.6-source.tar.xz 166820 BLAKE2B ba81e31477fb15bb5273add4d993ee7de88cfd47fd8300743e97c4abd19b0daf736d78b5bafc82569ff110757131501c07d7365a4e7ffde8d3a7fcc2e277bada SHA512 543123c794bfdb5b6556f7a897bcd2f3bdd09be8ad6a4ff07b138e0cac62621a4801c732bb20099c1bb383ad5822fc4ade276d49acf2744c811edd10d7699480
-EBUILD grfcodec-6.0.6.ebuild 1066 BLAKE2B ca41f8822b55fba5dac610e2bb9efcd786b5ee9bda3084407953cbade5c450f383337ef11c354e44a4ebd7c42ef60ab55a614c94f204602c17c7d6bb7dcaaa08 SHA512 6ac4994f25b2cfe551e56d9d9d828797928ae3a205e440a743213a468cd697d15d7442af0313744a296fa6d1a4b37baf295f696b9434a4fa5dc8c9757c847921
+EBUILD grfcodec-6.0.6.ebuild 1112 BLAKE2B 0b32ca4b024654f95a314a6410ebc148464e3d03c6f1f1af55f73d74637c50aac98df096725e568e62f0b57ef702c280689588db1857cac371739532f09aad3c SHA512 00b18f346295bb9f2c81ba3f714ea462b7440b9db26738662453460165a50439ef0703aa5e1ba93fc94925d5acc5f1b7b577e74e5bea79d863663f71a576b6dd
MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-util/grfcodec/files/grfcodec-6.0.6-gcc10.patch b/games-util/grfcodec/files/grfcodec-6.0.6-gcc10.patch
new file mode 100644
index 000000000000..baf84a435f69
--- /dev/null
+++ b/games-util/grfcodec/files/grfcodec-6.0.6-gcc10.patch
@@ -0,0 +1,12 @@
+diff -Nrup a/src/command.cpp b/src/command.cpp
+--- a/src/command.cpp 2015-05-09 04:59:46.000000000 -0600
++++ b/src/command.cpp 2019-09-24 11:37:06.667911307 -0600
+@@ -303,7 +303,7 @@ bool parse_comment(const string&line){
+ uint val=find_command(command_part,beaut),togglebit;
+ if(val!=(uint)-1&&val!=OFF)_commandState.beautifier=true;
+ switch(val){
+- case -1:
++ case -1u:
+ IssueMessage(0,COMMAND_INVALID_ARG,gen[BEAUTIFY].name);
+ return true;
+ case OFF:_commandState.beautifier=false;break;
diff --git a/games-util/grfcodec/grfcodec-6.0.6.ebuild b/games-util/grfcodec/grfcodec-6.0.6.ebuild
index ebfb9b894f6b..2c4927b37555 100644
--- a/games-util/grfcodec/grfcodec-6.0.6.ebuild
+++ b/games-util/grfcodec/grfcodec-6.0.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -27,6 +27,8 @@ DEPEND="
dev-libs/boost
"
+PATCHES=("${FILESDIR}/${PN}-6.0.6-gcc10.patch")
+
src_prepare() {
default