summaryrefslogtreecommitdiff
path: root/games-util/cartridges/cartridges-2.6.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/cartridges/cartridges-2.6.1-r1.ebuild')
-rw-r--r--games-util/cartridges/cartridges-2.6.1-r1.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/games-util/cartridges/cartridges-2.6.1-r1.ebuild b/games-util/cartridges/cartridges-2.6.1-r1.ebuild
deleted file mode 100644
index 09205490fed1..000000000000
--- a/games-util/cartridges/cartridges-2.6.1-r1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit gnome2-utils meson python-single-r1 xdg
-
-DESCRIPTION="Simple game launcher written in Python using GTK4 and Libadwaita"
-HOMEPAGE="https://github.com/kra-mo/cartridges/"
-
-if [[ "${PV}" == *9999* ]] ; then
- inherit git-r3
-
- EGIT_REPO_URI="https://github.com/kra-mo/${PN}.git"
-else
- SRC_URI="https://github.com/kra-mo/${PN}/archive/v${PV}.tar.gz
- -> ${P}.tar.gz"
-
- KEYWORDS="amd64 ~x86"
-fi
-
-LICENSE="GPL-3+"
-SLOT="0"
-RESTRICT="test" # Just appstream file validation that uses network.
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- >=gui-libs/libadwaita-1.4.0:1[introspection]
- gui-libs/gtk:4[introspection]
- $(python_gen_cond_dep '
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- ')
-"
-BDEPEND="
- ${RDEPEND}
- dev-libs/appstream-glib
- dev-util/blueprint-compiler
- dev-util/desktop-file-utils
-"
-
-PATCHES=( "${FILESDIR}/${PN}-1.5.4-dont-validate-appstream.patch" )
-
-src_install() {
- meson_src_install
-
- python_fix_shebang "${ED}/usr/bin"
- python_optimize "${ED}/usr"
-}
-
-pkg_postinst() {
- gnome2_schemas_update
- xdg_pkg_postinst
-}
-
-pkg_postrm() {
- gnome2_schemas_update
- xdg_pkg_postrm
-}