summaryrefslogtreecommitdiff
path: root/games-strategy/xbattleai/xbattleai-1.2.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/xbattleai/xbattleai-1.2.2-r1.ebuild')
-rw-r--r--games-strategy/xbattleai/xbattleai-1.2.2-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-strategy/xbattleai/xbattleai-1.2.2-r1.ebuild b/games-strategy/xbattleai/xbattleai-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..536c92a0439d
--- /dev/null
+++ b/games-strategy/xbattleai/xbattleai-1.2.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A multi-player game of strategy and coordination"
+HOMEPAGE="https://inf.ug.edu.pl/~piotao/xbattle/mirror/www.lysator.liu.se/XBattleAI/"
+SRC_URI="https://inf.ug.edu.pl/~piotao/xbattle/mirror/www.lysator.liu.se/XBattleAI/${P}.tgz"
+
+LICENSE="xbattle"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+# Since this uses similar code and the same binary name as the original XBattle,
+# we want to make sure you can't install both at the same time
+RDEPEND="
+ x11-libs/libXext
+ x11-libs/libX11
+ dev-lang/tcl:0
+ dev-lang/tk:0
+ !games-strategy/xbattle"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ app-text/rman
+ x11-misc/imake"
+
+src_prepare() {
+ rm -f xbcs/foo.xbc~
+ epatch "${FILESDIR}"/${P}-sandbox.patch
+}
+
+src_install() {
+ DOCS="CONTRIBUTORS README README.AI TODO xbattle.dot" \
+ default
+ mv "${D}/${GAMES_BINDIR}"/{,xb_}gauntletCampaign
+ prepgamesdirs
+}