summaryrefslogtreecommitdiff
path: root/games-strategy/tornado/tornado-1.4-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/tornado/tornado-1.4-r2.ebuild')
-rw-r--r--games-strategy/tornado/tornado-1.4-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-strategy/tornado/tornado-1.4-r2.ebuild b/games-strategy/tornado/tornado-1.4-r2.ebuild
new file mode 100644
index 000000000000..c2a5f7c2f76c
--- /dev/null
+++ b/games-strategy/tornado/tornado-1.4-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Clone of a C64 game - destroy the opponent's house"
+HOMEPAGE="https://github.com/kouya/tornado"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+DEPEND="
+ nls? ( sys-devel/gettext )
+"
+
+RDEPEND="
+ nls? ( virtual/libintl )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PF}-gentoo.patch
+)
+
+src_configure() {
+ if ! use nls; then
+ sed -i \
+ -e '/^all:/s|locales||g' \
+ -e '/^install:/s|install-locale-data||g' \
+ Makefile || die
+ fi
+
+ tc-export CC PKG_CONFIG
+}
+
+src_install() {
+ default
+ fperms 664 "/var/games/tornado.scores"
+}