summaryrefslogtreecommitdiff
path: root/games-strategy/netherearth/files/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/netherearth/files/Makefile')
-rw-r--r--games-strategy/netherearth/files/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/games-strategy/netherearth/files/Makefile b/games-strategy/netherearth/files/Makefile
new file mode 100644
index 000000000000..07c671a10e31
--- /dev/null
+++ b/games-strategy/netherearth/files/Makefile
@@ -0,0 +1,20 @@
+# ls *.cpp
+#
+#3dobject-ase.cpp construction.cpp maps.cpp netherdebug.cpp radar.cpp
+#3dobject.cpp enemy_ai.cpp menu.cpp nethersave.cpp robot_ai.cpp
+#bitmap.cpp glprintf.cpp myglutaux.cpp particles.cpp robots.cpp
+#bullet.cpp main.cpp nether.cpp piece3dobject.cpp shadow3dobject.cpp
+#cmc.cpp mainmenu.cpp nethercycle.cpp quaternion.cpp vector.cpp
+
+
+SOURCES = 3dobject-ase.cpp 3dobject.cpp cmc.cpp nether.cpp piece3dobject.cpp vector.cpp bitmap.cpp bullet.cpp glprintf.cpp main.cpp mainmenu.cpp maps.cpp menu.cpp myglutaux.cpp nethercycle.cpp netherdebug.cpp nethersave.cpp particles.cpp construction.cpp quaternion.cpp radar.cpp enemy_ai.cpp robot_ai.cpp robots.cpp shadow3dobject.cpp
+OBJECTS = $(SOURCES:.cpp=.o)
+TARGET = nether_earth
+
+.cpp.o:
+ g++ ${CXXFLAGS} -c $< -o $@
+
+all: $(TARGET)
+
+$(TARGET): $(OBJECTS)
+ g++ $(OBJECTS) -o $(TARGET) -lGL -lGLU -lglut -lSDL -lSDL_mixer -lpthread