summaryrefslogtreecommitdiff
path: root/games-strategy/megaglest-data/megaglest-data-3.11.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/megaglest-data/megaglest-data-3.11.1.ebuild')
-rw-r--r--games-strategy/megaglest-data/megaglest-data-3.11.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-strategy/megaglest-data/megaglest-data-3.11.1.ebuild b/games-strategy/megaglest-data/megaglest-data-3.11.1.ebuild
new file mode 100644
index 000000000000..c10fa689e223
--- /dev/null
+++ b/games-strategy/megaglest-data/megaglest-data-3.11.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit cmake-utils games
+
+MY_PN="megaglest"
+DESCRIPTION="Data files for the cross-platform 3D realtime strategy game MegaGlest"
+HOMEPAGE="http://www.megaglest.org/"
+SRC_URI="https://github.com/MegaGlest/megaglest-data/releases/download/${PV}/megaglest-data-${PV}.tar.xz"
+
+LICENSE="CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DOCS=( docs/AUTHORS.data.txt docs/CHANGELOG.txt docs/README.txt )
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_prepare() {
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DMEGAGLEST_BIN_INSTALL_PATH="${GAMES_BINDIR}"
+ -DMEGAGLEST_DATA_INSTALL_PATH="${GAMES_DATADIR}/${MY_PN}"
+ -DMEGAGLEST_ICON_INSTALL_PATH="/usr/share/pixmaps"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ use doc && HTML_DOCS="docs/glest_factions/"
+ cmake-utils_src_install
+ prepgamesdirs
+}