summaryrefslogtreecommitdiff
path: root/games-strategy/ja2-stracciatella/files/ja2-stracciatella-0.20.0-lua-cmake.patch
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/ja2-stracciatella/files/ja2-stracciatella-0.20.0-lua-cmake.patch')
-rw-r--r--games-strategy/ja2-stracciatella/files/ja2-stracciatella-0.20.0-lua-cmake.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/games-strategy/ja2-stracciatella/files/ja2-stracciatella-0.20.0-lua-cmake.patch b/games-strategy/ja2-stracciatella/files/ja2-stracciatella-0.20.0-lua-cmake.patch
new file mode 100644
index 000000000000..d09ac895119b
--- /dev/null
+++ b/games-strategy/ja2-stracciatella/files/ja2-stracciatella-0.20.0-lua-cmake.patch
@@ -0,0 +1,14 @@
+--- a/dependencies/lib-lua/CMakeLists.txt
++++ b/dependencies/lib-lua/CMakeLists.txt
+@@ -3,9 +3,9 @@
+ option(LOCAL_LUA_LIB "Download and build Lua instead of searching the system" ON)
+ if (NOT LOCAL_LUA_LIB)
+ message(STATUS "Using system Lua")
+- find_package(Lua "5.3" REQUIRED)
++ find_package(Lua "${LUA_VERSION}" REQUIRED EXACT)
+ if (NOT LUA_FOUND)
+- message(FATAL_ERROR "Lua 5.3 not found")
++ message(FATAL_ERROR "Lua ${LUA_VERSION} not found")
+ endif()
+
+ set(LUA_INCLUDE_DIRS "${LUA_INCLUDE_DIR}" PARENT_SCOPE)