summaryrefslogtreecommitdiff
path: root/games-strategy/freeorion/freeorion-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/freeorion/freeorion-9999.ebuild')
-rw-r--r--games-strategy/freeorion/freeorion-9999.ebuild11
1 files changed, 3 insertions, 8 deletions
diff --git a/games-strategy/freeorion/freeorion-9999.ebuild b/games-strategy/freeorion/freeorion-9999.ebuild
index 5bf1f6f4f99a..048d1b8bf695 100644
--- a/games-strategy/freeorion/freeorion-9999.ebuild
+++ b/games-strategy/freeorion/freeorion-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
inherit cmake-utils python-single-r1 xdg
DESCRIPTION="A free turn-based space empire and galactic conquest game"
@@ -15,7 +15,7 @@ if [[ ${PV} == 9999 ]]; then
else
KEYWORDS="~amd64"
if [[ ${PV} = *_p* ]]; then
- COMMIT="2a49c05796f1c92b96ce9b2aeaf0124fc8be7a77"
+ COMMIT="1570afb475763b13f5d2f434037ec907da812bb4"
SRC_URI="https://github.com/${PN}/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${COMMIT}"
else
@@ -35,7 +35,7 @@ BDEPEND="
"
RDEPEND="
$(python_gen_cond_dep '
- >=dev-libs/boost-1.58:=[python,threads,${PYTHON_MULTI_USEDEP}]
+ >=dev-libs/boost-1.67:=[python,threads,${PYTHON_MULTI_USEDEP}]
')
!dedicated? (
media-libs/freealut
@@ -54,11 +54,6 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
-pkg_setup() {
- # build system is using FindPythonLibs.cmake which needs python:2
- python-single-r1_pkg_setup
-}
-
src_prepare() {
sed -e "s/-O3//" -i CMakeLists.txt || die