summaryrefslogtreecommitdiff
path: root/games-sports/ultimatestunts/ultimatestunts-0.7.7-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-sports/ultimatestunts/ultimatestunts-0.7.7-r1.ebuild')
-rw-r--r--games-sports/ultimatestunts/ultimatestunts-0.7.7-r1.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/games-sports/ultimatestunts/ultimatestunts-0.7.7-r1.ebuild b/games-sports/ultimatestunts/ultimatestunts-0.7.7-r1.ebuild
deleted file mode 100644
index 53a8f0c1a688..000000000000
--- a/games-sports/ultimatestunts/ultimatestunts-0.7.7-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils flag-o-matic versionator
-
-MY_P=${PN}-srcdata-$(replace_all_version_separators)1
-DESCRIPTION="Remake of the famous Stunts game"
-HOMEPAGE="http://www.ultimatestunts.nl/"
-SRC_URI="mirror://sourceforge/ultimatestunts/${MY_P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="nls"
-
-RDEPEND="
- media-libs/freealut
- media-libs/libsdl[joystick,opengl,video]
- media-libs/libvorbis
- >=media-libs/openal-1
- media-libs/sdl-image
- virtual/opengl
- virtual/glu
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- sys-devel/gettext"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=(
- "${FILESDIR}"/${P}-paths.patch
- "${FILESDIR}"/${P}-gcc-4.7.patch
-)
-
-src_prepare() {
- default
-
- esvn_clean
- append-cppflags $(sdl-config --cflags)
-}
-
-src_configure() {
- econf \
- --with-openal \
- $(use_enable nls)
-}
-
-src_compile() {
- emake -C trackedit libtrackedit.a
- emake
-}
-
-src_install() {
- default
-
- newicon data/cars/diablo/steer.png ${PN}.png
- make_desktop_entry ustunts "Ultimate Stunts"
-}