summaryrefslogtreecommitdiff
path: root/games-sports/gracer/files
diff options
context:
space:
mode:
Diffstat (limited to 'games-sports/gracer/files')
-rw-r--r--games-sports/gracer/files/0.1.5-gldefs.patch33
-rw-r--r--games-sports/gracer/files/gracer-0.1.5-as-needed.patch11
-rw-r--r--games-sports/gracer/files/gracer-0.1.5-gcc10.patch14
-rw-r--r--games-sports/gracer/files/gracer-0.1.5-gcc41.patch11
-rw-r--r--games-sports/gracer/files/gracer-0.1.5-giflib.patch14
-rw-r--r--games-sports/gracer/files/gracer-0.1.5-libpng14.patch13
-rw-r--r--games-sports/gracer/files/gracer-0.1.5-png15.patch11
-rw-r--r--games-sports/gracer/files/gracer-0.1.5-warnings.patch21
-rw-r--r--games-sports/gracer/files/gracer-gcc-3.4.patch120
9 files changed, 0 insertions, 248 deletions
diff --git a/games-sports/gracer/files/0.1.5-gldefs.patch b/games-sports/gracer/files/0.1.5-gldefs.patch
deleted file mode 100644
index 43fe7385dc6e..000000000000
--- a/games-sports/gracer/files/0.1.5-gldefs.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- a/src/glbind.c 2003-07-30 00:18:37.000000000 -0400
-+++ b/src/glbind.c 2003-07-30 00:19:32.000000000 -0400
-@@ -22,6 +22,8 @@
- #include <unistd.h>
- #include <GL/gl.h>
- #include <GL/glut.h>
-+#undef GL_EXT_texture_object
-+#include <GL/glext.h>
- #include <string.h>
- #include <stdlib.h>
- #include <ctype.h>
---- a/src/glhash.h 2003-07-30 00:20:32.000000000 -0400
-+++ b/src/glhash.h 2003-07-30 00:20:58.000000000 -0400
-@@ -1,4 +1,5 @@
- /* this file is generated automaticaly from GL/gl.h */
-+#undef GL_EXT_paletted_texture
- #include <GL/gl.h>
-
- glWordList glwordlist[] = {
-@@ -632,13 +632,11 @@
-
- #ifdef GL_SGIS_multitexture
- {"selected_texture_sgis", GL_SELECTED_TEXTURE_SGIS},
-- {"selected_texture_coord_set_sgis", GL_SELECTED_TEXTURE_COORD_SET_SGIS},
- {"max_textures_sgis", GL_MAX_TEXTURES_SGIS},
- {"texture0_sgis", GL_TEXTURE0_SGIS},
- {"texture1_sgis", GL_TEXTURE1_SGIS},
- {"texture2_sgis", GL_TEXTURE2_SGIS},
- {"texture3_sgis", GL_TEXTURE3_SGIS},
-- {"texture_coord_set_source_sgis", GL_TEXTURE_COORD_SET_SOURCE_SGIS},
- #endif
-
- #ifdef GL_EXT_multitexture
diff --git a/games-sports/gracer/files/gracer-0.1.5-as-needed.patch b/games-sports/gracer/files/gracer-0.1.5-as-needed.patch
deleted file mode 100644
index 1b8b21f1a186..000000000000
--- a/games-sports/gracer/files/gracer-0.1.5-as-needed.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/Makefile.in 2009-02-11 14:31:56.000000000 +0100
-+++ b/src/Makefile.in 2009-02-11 14:32:29.000000000 +0100
-@@ -109,7 +109,7 @@
- INCLUDES = -I$(top_srcdir) @X_CFLAGS@ @GL_CFLAGS@ @GLUT_CFLAGS@ @TCL_CFLAGS@ @GIF_CFLAGS@ @JPEG_CFLAGS@ @PNG_CFLAGS@ @PLIB_CFLAGS@
-
-
--gracer_LDADD = @PLIB_LDFLAGS@ @GIF_LDFLAGS@ @JPEG_LDFLAGS@ @PNG_LDFLAGS@ @GL_LDFLAGS@ @GLUT_LDFLAGS@ @X_LDFLAGS@ @TCL_LDFLAGS@ @TCL_LIBS@ @X_LIBS@ @GL_LIBS@ @GLUT_LIBS@ @GIF_LIBS@ @JPEG_LIBS@ @PNG_LIBS@ @SOUND_LIBS@ $(top_builddir)/common/libcommon.a
-+gracer_LDADD = $(top_builddir)/common/libcommon.a @PLIB_LDFLAGS@ @GIF_LDFLAGS@ @JPEG_LDFLAGS@ @PNG_LDFLAGS@ @GL_LDFLAGS@ @GLUT_LDFLAGS@ @X_LDFLAGS@ @TCL_LDFLAGS@ @TCL_LIBS@ @X_LIBS@ @GL_LIBS@ @GLUT_LIBS@ @GIF_LIBS@ @JPEG_LIBS@ @PNG_LIBS@ @SOUND_LIBS@
-
-
- gracer_SOURCES = control.h glbind.c glbind.h glutwidgets.c glutwidgets.h gluttclwidgets.c gluttclwidgets.h glutgame.c glutgame.h gr_world.c gr_world.h glhash.h gluthash.h vehicle.c vehicle.h lap.c lap.h joystick.c joystick.h tcldefs.h sound.h sound.cxx main.cxx
diff --git a/games-sports/gracer/files/gracer-0.1.5-gcc10.patch b/games-sports/gracer/files/gracer-0.1.5-gcc10.patch
deleted file mode 100644
index a7539248e50d..000000000000
--- a/games-sports/gracer/files/gracer-0.1.5-gcc10.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Fix -fno-common
-
-diff -r c259e312716e vehicle.h
---- a/src/vehicle.h Sat Oct 03 12:42:08 2020 +0000
-+++ b/src/vehicle.h Sat Oct 03 12:44:13 2020 +0000
-@@ -70,7 +70,7 @@
-
- /* constants */
- float mu[128]; /* friction factor */
--} GrBreak;
-+};
-
- struct _GrTireData {
- GrRef ref;
diff --git a/games-sports/gracer/files/gracer-0.1.5-gcc41.patch b/games-sports/gracer/files/gracer-0.1.5-gcc41.patch
deleted file mode 100644
index 3877e76e577e..000000000000
--- a/games-sports/gracer/files/gracer-0.1.5-gcc41.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/common/gr_memory.h 2006-05-23 09:16:21.000000000 +0200
-+++ b/common/gr_memory.h 2006-05-23 09:16:40.000000000 +0200
-@@ -64,7 +64,7 @@
- void gr_dlist_free (GrDList *list);
-
- #define gr_FOREACH(l,p) \
-- for (; (l) != NULL && ((void *)(p) = (l)->data, 1); (l) = (l)->next)
-+ for (; (l) != NULL && (p = (l)->data, 1); (l) = (l)->next)
-
- void gr_ref_incr (GrRef *ref);
- void gr_ref_decr (GrRef *ref);
diff --git a/games-sports/gracer/files/gracer-0.1.5-giflib.patch b/games-sports/gracer/files/gracer-0.1.5-giflib.patch
deleted file mode 100644
index a5ce023f5734..000000000000
--- a/games-sports/gracer/files/gracer-0.1.5-giflib.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- gracer-0.1.5/common/gr_texture.c
-+++ gracer-0.1.5/common/gr_texture.c
-@@ -274,7 +274,11 @@
- int index;
- int width, height;
-
-+#if (GIFLIB_MAJOR >= 5&& !(GIFLIB_MAJOR == 5 && GIFLIB_MINOR == 0))
-+ file = DGifOpenFileName (filename, &i);
-+#else
- file = DGifOpenFileName (filename);
-+#endif
- if (!file)
- return -1;
-
diff --git a/games-sports/gracer/files/gracer-0.1.5-libpng14.patch b/games-sports/gracer/files/gracer-0.1.5-libpng14.patch
deleted file mode 100644
index 618c987a3152..000000000000
--- a/games-sports/gracer/files/gracer-0.1.5-libpng14.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-http://bugs.gentoo.org/show_bug.cgi?id=308885
-
---- a/common/gr_texture.c
-+++ b/common/gr_texture.c
-@@ -419,7 +419,7 @@ read_png_file (GrTexture *texture, char
- if (fread (header, 1, PNG_BYTES_TO_CHECK, file) != PNG_BYTES_TO_CHECK) {
- goto ERROR;
- }
-- if (!png_check_sig (header, PNG_BYTES_TO_CHECK)) {
-+ if (png_sig_cmp (header, 0, PNG_BYTES_TO_CHECK)) {
- goto ERROR;
- }
-
diff --git a/games-sports/gracer/files/gracer-0.1.5-png15.patch b/games-sports/gracer/files/gracer-0.1.5-png15.patch
deleted file mode 100644
index d606c14cd4e2..000000000000
--- a/games-sports/gracer/files/gracer-0.1.5-png15.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/common/gr_texture.c 2011-09-14 14:23:46.820207882 +0200
-+++ b/common/gr_texture.c 2011-09-14 14:24:22.861203604 +0200
-@@ -431,7 +431,7 @@
- if (!info_ptr) {
- goto ERROR;
- }
-- if (setjmp (png_ptr->jmpbuf)) {
-+ if (setjmp (png_jmpbuf(png_ptr))) {
- goto ERROR;
- }
- png_init_io (png_ptr, file);
diff --git a/games-sports/gracer/files/gracer-0.1.5-warnings.patch b/games-sports/gracer/files/gracer-0.1.5-warnings.patch
deleted file mode 100644
index b5ede40e1492..000000000000
--- a/games-sports/gracer/files/gracer-0.1.5-warnings.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- gracer-0.1.5/src/glbind.c
-+++ gracer-0.1.5/src/glbind.c
-@@ -142,7 +142,7 @@
- return NULL;
-
- entry = Tcl_FindHashEntry (&cache_hash, key);
-- if (&entry)
-+ if (!entry)
- return NULL;
-
- return Tcl_GetHashValue (entry);
---- gracer-0.1.5/src/joystick.c
-+++ gracer-0.1.5/src/joystick.c
-@@ -20,6 +20,7 @@
- */
-
- #include <unistd.h>
-+#include <string.h>
- #include <errno.h>
- #include <sys/types.h>
- #include <sys/stat.h>
diff --git a/games-sports/gracer/files/gracer-gcc-3.4.patch b/games-sports/gracer/files/gracer-gcc-3.4.patch
deleted file mode 100644
index c12cb9a1f0cf..000000000000
--- a/games-sports/gracer/files/gracer-gcc-3.4.patch
+++ /dev/null
@@ -1,120 +0,0 @@
---- a/src/glbind.c 2004-11-05 01:15:07.141221016 +0000
-+++ b/src/glbind.c 2004-11-05 01:15:32.808319024 +0000
-@@ -2150,6 +2150,7 @@
- return 3;
-
- default:
-+ ;
- }
-
- ERROR:
-@@ -2889,6 +2890,7 @@
- return 6;
-
- default:
-+ ;
- }
-
- ERROR:
-@@ -3081,6 +3083,7 @@
- return 4;
-
- default:
-+ ;
- }
-
- ERROR:
---- a/src/glutwidgets.c 2004-11-05 01:17:17.941336376 +0000
-+++ b/src/glutwidgets.c 2004-11-05 01:18:42.059548464 +0000
-@@ -255,6 +255,7 @@
- widget->width += (width - screen_width);
- break;
- default:
-+ ;
- }
- switch (widget->anchor & GR_VERTICAL_MASK) {
- case GR_BOTTOM:
-@@ -268,6 +269,7 @@
- widget->height += (width - screen_height);
- break;
- default:
-+ ;
- }
- glut_widget_calc_bbox (widget);
- }
-@@ -327,6 +329,7 @@
- break;
-
- default:
-+ ;
- }
- }
-
-@@ -504,6 +507,7 @@
- break;
-
- default:
-+ ;
- }
- }
-
-@@ -1299,6 +1303,7 @@
- break;
-
- default:
-+ ;
- }
- }
-
-@@ -1571,6 +1576,7 @@
- break;
-
- default:
-+ ;
- }
-
- glColor4fv (widget->fg_color[GR_STATE_NORMAL]);
---- a/src/gr_world.c 2004-11-05 01:19:30.766143936 +0000
-+++ b/src/gr_world.c 2004-11-05 01:19:07.717647840 +0000
-@@ -169,6 +169,7 @@
- break;
-
- default:
-+ ;
- }
-
- tlist = entry->triggers;
---- a/ac2scene/ac2scene.c 2004-11-05 01:13:55.845059680 +0000
-+++ b/ac2scene/ac2scene.c 2004-11-05 01:14:32.526483256 +0000
-@@ -162,6 +162,7 @@
- break;
-
- default:
-+ ;
- }
-
- return 0;
-@@ -234,6 +235,7 @@
- break;
-
- default:
-+ ;
- }
-
- return 0;
-@@ -316,6 +318,7 @@
- }
- break;
- default:
-+ ;
- }
-
- return 0;
-@@ -399,6 +402,7 @@
- break;
-
- default:
-+ ;
- }
- }
-